Comment 21 for bug 408165

Revision history for this message
Yohann CHASTRE (yohann-chastre) wrote :

Sorry, yes, the lastest release (date 12/14/09, version 2.3.0.0). I have to add the device and vendor id in "common/rtusb_dev_id.c" file (between the "ifdef RT35xx ... #endif // RT35xx //") else it doesn't work.

In the "os/linux/config.mk", I enable "HAS_WPA_SUPPLICANT", "HAS_NATIVE_WPA_SUPPLICANT_SUPPORT", "HAS_QOS_DLS_SUPPORT", "HAS_DOT11N_DRAFT3_SUPPORT", "HAS_DOT11_N_SUPPORT" and "HAS_STATS_COUNT". I tried to enable "HAS_CFG80211_SUPPORT" but I have build errors. for the moment, I dont try others options.

lsusb says:
      Bus 001 Device 004: ID 1737:0079 Linksys

ifconfig ra0 says:
      ra0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
                  inet adr:192.168.2.102 Bcast:192.168.2.255 Masque:255.255.255.0
                  adr inet6: xxxx::xxxx:xxxx:xxxx:xxxx/64 Scope:Lien
                  UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
                  Packets reçus:432694 erreurs:0 :0 overruns:0 frame:0
                  TX packets:24952 errors:0 dropped:0 overruns:0 carrier:0
                  collisions:0 lg file transmission:1000
                  Octets reçus:104196211 (104.1 MB) Octets transmis:3136614 (3.1 MB)

iwconfig ra0 says:
      ra0 Ralink STA ESSID:"xxxxxxx" Nickname:"RT3572STA"
                  Mode:Managed Frequency=2.462 GHz Access Point: xx:xx:xx:xx:xx:xx
                  Bit Rate=130 Mb/s
                  RTS thr:off Fragment thr:off
                  Link Quality=100/100 Signal level:-57 dBm Noise level:-63 dBm
                  Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
                  Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Steve Sinclair > Can you tell me your bit rate when it will work for you ? I think it's too low.