Intel WiFi rfkill switch now defaults to on (wireless off)

Bug #405152 reported by Matthew Lai on 2009-07-27
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

For my laptop (Acer Timeline 3810t), after upgrading to 2.6.31, the RFKILL switch now defaults to on (wireless disabled) on every boot. It works if I manually turn off the switch.

The switch is a toggle switch, and it used to default to off under 2.6.30/alpha 2.

I am using the iwlagn driver. The card is an Intel 5100.

01:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

I have tried using the RFKILL utility found here - http://wireless.kernel.org/en/users/Documentation/rfkill, to no avail. The wifi device is "hard blocked".

This is annoying because I need to use wifi everytime I use my laptop, and there is no programmatic way to enable it.

Thanks!

ProblemType: Bug
Architecture: i386
Date: Mon Jul 27 14:08:16 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=6f9ae10f-02b2-4a96-a7d7-700e22184757
MachineType: Acer Acer Project
Package: linux-image-2.6.31-4-generic 2.6.31-4.22
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-4-generic root=UUID=b6d9abe7-e298-4e5e-984c-336ff8330d98 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-4-generic N/A
SourcePackage: linux
Uname: Linux 2.6.31-4-generic i686
dmi.bios.date: 05/27/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Acer Project
dmi.board.vendor: Acer
dmi.board.version: PSMBOU-1234567
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnAcer:bvrV1.04:bd05/27/2009:svnAcer:pnAcerProject:pvrV1.04:rvnAcer:rnAcerProject:rvrPSMBOU-1234567:cvnAcer:ct10:cvrNone:
dmi.product.name: Acer Project
dmi.product.version: V1.04
dmi.sys.vendor: Acer

Matthew Lai (cyberfish) wrote :
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
Matthew Lai (cyberfish) wrote :

Blacklisting acer_wmi reverts this behaviour, so it is probably something related to acer_wmi.

I can confirm the killswitch behaviour on a default 9.10 alpha 3 x64 installation on same 3810T acer laptop

Matthew Lai (cyberfish) wrote :

"Fixed" in 2.6.31-5!

The switch now defaults to off on every boot.

I guess it would be the best if it can somehow "remember" the state across reboots, but I'm not sure if that's possible, and for me, default to on is good :).

Thanks for the hardwork!

Changed in linux (Ubuntu):
status: Triaged → Fix Released
harrydance (harry-dance) wrote :

Great news, thanks to the people who helped fix this!

rsoika (ralph-soika) wrote :

To me it seams that the issue is back in 2.6.31-14-generic.
wifi works only if I switch wlan off before I boot.
Otherwise rfkill list shows:

rfkill list
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: yes
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

and it is than impossible to enable wlan - no wifi!.
But it works if I switch wlan off before I boot. than I can toogle the switch and >rfkill list shows allways the right state.

Matthew Lai (cyberfish) wrote :

I think you may be seeing a different bug, and may want to report it as a separate bug. The original bug is Acer-specific (since blacklisting acer_wmi worked-around it). And I don't think the problem came back for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers