Ubuntu

Resolver ignores ndots option

Reported by Martin Stepanek on 2009-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Regardless of ndots option in /etc/resolv.conf, when NXDOMAIN is returned from the DNS server then resolver always try another attempt with the original name extended by what is in search option.
For example, if you're looking for very.long.url.nowhere and there is a line "search ubuntu.com" in resolv.conf you will get addres of server very.long.url.nowhere.ubuntu.com if such exists. It is incorrect, it should occurs only for urls having less that ndots option dots in its name.
Experienced on Kubuntu 9.04 with linux-image-2.6.28-13-generic kernel package.

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: resolvconf None [modified: /var/lib/dpkg/info/resolvconf.list]
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
SourcePackage: resolvconf
Uname: Linux 2.6.28-13-generic i686
UnreportableReason: This is not a genuine Ubuntu package

tags: added: resolver
removed: apport-bug
tags: removed: i386
Jeremy Foshee (jeremyfoshee) wrote :

Hi Martin,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 401202

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 1647 F.... knotify4
                      martin 1673 F.... pulseaudio
                      martin 1679 F.... kmix
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdfebc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801c2,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 13
   Simple ctrls : 8
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=2874eff0-85fc-4a72-989b-ee9e391fa844
MachineType: Dell Inc. Latitude D620
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=259ec1d2-bd83-4037-8671-150f9ab6af5b ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=cs_CZ.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-20-generic N/A
 linux-firmware 1.26
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin mythtv plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 04/11/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0TD761
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd04/11/2006:svnDellInc.:pnLatitudeD620:pvr:rvnDellInc.:rn0TD761:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D620
dmi.sys.vendor: Dell Inc.

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

Tried and got the same result on the recent Karmic and Lucid kernels as well. My notebook unfortunately does not boot with a standard mainstream kernel, so I can not verify it.
Just to verify we understand each other, please look at the attached file. The home domain stemar.cz has been deliberately modified for this test in order to return a positive response for any request. As you can see, the dig returns NXDOMAIN for a.nonexistingdomain.com. The host command however continues with searching for a.nonexistingdomain.com.stemar.cz which is then successful. It should not be correct as a.nonexistingdomain.com contains more that ndots option dots. Unfortunately, the same way as the host command does any other apps (Firefox, Thunderbird, ping, etc.). From this I believe the problem is in the kernel resolver procedure.

Brad Figg (brad-figg) on 2010-12-03
tags: added: acpi-method-return
Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: b73a1py79

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers