Ubuntu

Realtek RTL8192SE WLAN Card Fails to work on Medion Akoya E1312 Netbook

Reported by Sweevo on 2009-07-18
416
This bug affects 77 people
Affects Status Importance Assigned to Milestone
Debian
New
Undecided
Unassigned
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Nominated for Karmic by Asem
Nominated for Lucid by Asem

Bug Description

On my new Medion Akoya E1312 Netbook (http://www.medion.com/ms/aldi/md97690/uk/) the WLAN card, which I believe is a Realtek RTL8192SE card (at least that's what Windows XP reports it as) fails to be detected and work.

The only option I have is to use the Realtek onboard wired LAN, which is detected correctly.

I'm currently running:

Ubuntu 9.04 (with all updates applied)
Kernel: 2.6.28-13-generic

I'm attaching:

dsmesg, lspci and lspci -n

Please let me know if there's anything further that I can add to be of assistance

Same problem, same symptoms on a new Toshiba L505-10P. The card is Realtek Semiconductor Co., Ltd. Device 8172 (rev 10). With the drivers provided below, the connection is successful but once I use Internet, a kernel panic occurs....(Karmic 64 bits, latest update)

Sweevo (mark-mark-stevenson) wrote :
Sweevo (mark-mark-stevenson) wrote :
Philip Muškovac (yofel) on 2009-07-18
affects: ubuntu → linux (Ubuntu)
Sweevo (mark-mark-stevenson) wrote :

Just to add a little more information to this, I've tried the following without any success:

sudo apt-get install ndiswrapper-utils-1.9
sudo ndiswrapper -i net8192se.inf (this was taken from the Windows XP driver for the card)
sudo ndiswrapper -l

This produced:

net8192se : driver installed
 device (10EC:8172) present

sudo ndiswrapper -m
sudo modprobe ndiswrapper
sudo /etc/init.d/networking restart
iwconfig

This produced:

lo no wireless extensions.
eth0 no wireless extensions.
vboxnet0 no wireless extensions.
pan0 no wireless extensions.

So no joy with ndiswrapper :(

description: updated
summary: - Realtek RTL8191 WLAN Card Fails work on Medion Akoya E1312 Netbook
+ Realtek RTL8192SE WLAN Card Fails work on Medion Akoya E1312 Netbook

Same prob :-( with Medion akoya P6620 with Realtek rtl8191se w-lan 802.11 n Pci-E NIC --- using Ubuntu 9.04 64-bit. ndiswrapper don't work with xp/xp64/vista/vista64 .inf :-((

zippy165141 (glosscomputers) wrote :

rtl8191se wlan working fine on my e1312 using the win2k driver from the windows cd with the ndiswrapper commands from above. tested in ubuntu 9.10 will try 9.04 asap

zippy165141 (glosscomputers) wrote :

dont forget to add ndiswrapper to the end of sudo gedit /etc/modules

it takes about 30sec to reconect after sleep

zippy165141 (glosscomputers) wrote :

tested on 9.04 works great but takes a while to work after sleeping

Sweevo (mark-mark-stevenson) wrote :

Hi zippy165141

Thanks for your testing.

I've now tried the Win2k driver on both Jaunty and Karmic and although it installs in NDISWrapper fine and it becomes available in Network Manager, I am unable to scan for any wireless networks or connect to my WPA2 network.

Searching around on the web, it looks like I'm far from alone in this:

http://ubuntuforums.org/showthread.php?t=1182457
http://ubuntuforums.org/showthread.php?t=1209710
http://ohioloco.ubuntuforums.org/showthread.php?t=1190996
http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/Replacing-T400-wireless-card/m-p/134159
http://lnv.lithium.com/t5/Linux-Discussion/New-T500-no-wifi-drivers/m-p/148683

These are just a few of the posts I've found.

I'd be really grateful if you could provide me with an idiots guide to what you've done to get yours working please.

Thanks for all of your help

Sweevo

zippy165141 (glosscomputers) wrote :

thats strange,i can scan and join any network,i dont want to make u sound stupid but u have turned the fn f8 wireless on havent u? download the package ive posted it works fine.

Sweevo (mark-mark-stevenson) wrote :

Don't worry about making me sound stupid, I'm glad I asked you for and idiots guide!

I could kick myself, I was convinced I had the WLAN switched on as the Wireless Indicator light was showing dark blue...

However, RTFM - there are four states for the WLAN:

Lights green - The wireless LAN function is activated
Lights blue - The Bluetooth function is activated.
Lights light blue - Wireless LAN and Bluetooth functions are both activated.
Lights off - Wireless and Bluetooth both disabled

So basically I'd just enable bluetooth, not the WLAN - on setting it to light blue and using the Win2k driver, the card's working really well.

I hope this post will help all of the other people who have been struggling with it the same as I have.

Thanks so much for all of your help.

Sweevo

zippy165141 (glosscomputers) wrote :

i changed the card for a intel one and it still takes 30sec to reconect from sleep,any ideas y anyone?

I was able to implement this on a 32-bit Ubuntu 9.04 installation. Do you have similar solution for 64-bit Ubuntu 9.04 version?

zakzor (zakzor) wrote :

Thanks for the Win2K driver tip.

Just for the note.
Realtek RTL8192SE working great in Toshiba L500-13W with the Win2K driver with Ubuntu 9.04 32bit.

zakzor (zakzor) wrote :

My router is a IEEE 802.11g.

Did anyone already tried this Win2K driver + ndiswrapper in any N or N-draft router?

I ask this because when i installed the driver (before connecting to my WPA 54Mbps network) the rate stated on iwconfig was only 65Mbps.
After connecting to the router it went to the router max (54Mbps).

I know we can always change the rate manually but will it go further?

Thanks in advance,
zakzor

david woo (wooshwu) wrote :

Please try the rtl8192se Linux driver in the attachment from Realtek.
just use the command of `make; make install`,
then reboot,
the network shall work now.

Sweevo (mark-mark-stevenson) wrote :

Hi David

Many thanks for posting the driver.

In my efforts to get this card working, I've ended up on the Beta of Ubuntu 9.10 (Karmic) with Kernel 2.6.31-14-generic

I've tried making the drivers, "make" completes successfully, but I get the following error when I "sudo make install":

make[2]: Entering directory `/usr/src/linux-headers-2.6.31-14-generic'
  CHK include/linux/version.h
  CHK include/linux/utsrelease.h
  SYMLINK include/asm -> include/asm-x86
make[3]: *** No rule to make target `kernel/bounds.c', needed by `kernel/bounds.s'. Stop.
make[2]: *** [prepare0] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.31-14-generic'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/mark/Desktop/rtl8192se_linux_2.6.0010.1012.2009/HAL/rtl8192'
make: *** [install] Error 2

I've made sure that the kernel headers and source and also build-essential are all installed, but still no luck.

I can see from the readme file included with the drivers that it should work on Karmic, so I'm guessing that I'm either doing something wrong or that something is wrong with my Karmic install.

I've Googled the error and been through the Ubuntu Forums and have found other people with similar issues, but I can't find anything to help me with this issue.

Any help that anyone here can provide would be gratefully received.

Thanks and kind regards

Sweevo

summary: - Realtek RTL8192SE WLAN Card Fails work on Medion Akoya E1312 Netbook
+ Realtek RTL8192SE WLAN Card Fails to work on Medion Akoya E1312 Netbook
Sweevo (mark-mark-stevenson) wrote :

Just to let you know that following method 2 in the readme file works!

It does mean that until I can get the driver to compile properly, following method 1, that I have to manually bring the card up by running "sudo ./wlan0up", but it works - and it works much better than ndiswrapper which was giving me lots of headaches.

I'd been finding that with ndiswrapper, since kernel 2.6.31-10, I was having to run "sudo renice +19 $(pidof wpa_supplicant)" just to get it to make a connection to my router - but I don't have to do that any longer with this driver.

So if anyone has any ideas to help me out with the "make install" error then I'd be really happy to hear from you.

David - thanks so much for passing this driver on, but where did you find it? Realtek never got back to me on any of my (many) emails and I still can't find any mention of the driver on Google.

Thanks

Sweevo

david woo (wooshwu) wrote :

Hi Sweevo,

   The driver has been verified Ok with the kernel version of 2.6.31-10-generic based on
    Ubuntu 9.10 Karmic.
    As you mentioned, I'll check the driver with the kernel 2.6.31-15-generic, and see
   whether the issue also exists?

   You can also request for the drive from the Realtek with mail address <email address hidden>,
   just as it was mentioned within the driver package.

  Thanks

David

david woo (wooshwu) wrote :

With kernel image updated, I just tried the driver with "make" and "make install" on the Beta of Ubuntu 9.10 (Karmic) with Kernel 2.6.31-14-generic, and it also seems to be working now.

make[1]: Entering directory `/usr/src/linux-headers-2.6.31-14-generic'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]:Leaving directory `/usr/src/linux-headers-2.6.31-14-generic'
make[1]: Entering directory `/home/david/rtl8192se_linux_2.6.0010.1012.2009/HAL/rtl8192'
make -C /lib/modules/2.6.31-14-generic/build M=/home/david/rtl8192se_linux_2.6.0010.1012.2009 CC=gcc modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.31-14-generic'
  Building modules, stage 2.
  MODPOST 0 modules
make[2]:Leaving directory `/usr/src/linux-headers-2.6.31-14-generic'
install -p -m 644 r8192se_pci.ko /lib/modules/2.6.31-14-generic/kernel/drivers/net/wireless/
depmod -a
make[1]:Leaving directory `/home/david/rtl8192se_linux_2.6.0010.1012.2009/HAL/rtl8192'

    After reboot, the networks now can also be scanned and connected with OPEN/WEP/WPA/WPA2, etc
    by NetworkManager,

   Thanks

David

david woo (wooshwu) wrote :

Or would you try to install the driver module manually with the following steps,
[1] Copy the target module rtl8192se_pci.ko to /lib/modules/2.6.31-14-generic/kernel/drivers/net/wireless/
[2] Copy rtl8192se firmware folder to /lib/firmware/`uname -r`
[3] Run the command of `depmod -a`
[4] Run the command of 'modprobe rtl8192se_pci', or reboot.
[5] Check the NetworkManager, and see whether there's network list show out?

   Thanks!

David

fiat1100d (gratteri-email) wrote :

Hello,

I tried to compile the driver on another notebook based on the same network card (Toshiba Satellite A500D-10K).
"make" works, but "sudo make install" doesn't do its job, with the same error about "bounds.c" stated by Sweevo.
I manually installed the driver, as suggested by David, but I get what seems to be a kernel panic! I had to boot from Ubuntu Live CD, delete the firmware folder and then the system could continue booting.

This on amd64 platform:
Linux satellite 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

Daniele

Nigel Pallett (nigelp) wrote :

Hello David,

Is this rtl8192se driver from Realtek designed to work with Ubuntu 64bit ?

I can get it to work ok on 32 bit , but on Ubuntu 9.04 AMD64 Desktop version, it compiles and installs, but will not scan for available network access points.

Regards,
Nigel.

Sweevo (mark-mark-stevenson) wrote :

Hi David

Thanks once again, following your steps to install the driver module manually works perfectly.

There is one small change to your instructions, the file is called "r8192se_pci.ko" not "rtl8192se_pci.ko".

Even after a reboot, my WLAN starts automatically each time now.

Brilliant!

By the way - I must have sent at least half a dozen emails to <email address hidden> since August requesting the driver, all of them have gone unanswered - you must have the magic touch!

Thanks and kind regards

Mark

Francisco Peña (tkd) wrote :

Hi david! Thanks again for this driver.
I compiled under ArchLinux 64bits with out any issue, after reboot the driver load perfect on my thinkpad T500.
The only issue is that my card can't see any wireless network.
My wireless scurity is: WPA2+AES and I use NetworkManager.

mrklaw (sloan) wrote :

This is awesome. I'm running the karmic beta, and was able to manually copy the kernel module over. Now I'm wondering if there is any chance that this will actually make it in to the final karmic release.

david woo (wooshwu) wrote :

Hi Sweevo,

   Thanks for you pointing out. The driver module really shall be called r8192se_pci.ko, :-)

   The emails you sent to <email address hidden> may be filtered by Realtek's email server, I used to
   contact with the Realtek's Wlan FAE, and just learned this info.

   Thanks.

David

david woo (wooshwu) wrote :

Hi All,

    Thanks for all of yours response.

    The driver has only been checked with 32bit platform here, and will check with the 64bit platform further.
    Just hope the platform issue can be made clear soon, :)

    Thanks.

David

david woo (wooshwu) wrote :

With minor update with skb tail(skb->tail => skb_tail_pointer(skb)), the attached updated driver shall also support AMD-64bit platform.

david woo (wooshwu) wrote :

HI Francisco,

   With minor update(skb->tail ==> skb_tail_pointer(skb)), the attached driver seem to both support 32bit and AMD-64bit
   platform.

   Please help to try it.

   Thanks.

David

Nigel Pallett (nigelp) wrote :

HI David,

Thank you so much for your help.

The 64Bit driver that you supplied above works perfectly on my Novatech Xplora E16 laptop containing a Realtek 8172 WiFi card.

The driver works perfectly with Network-Manager and WPA2 under Ubuntu 9.04 AMD64 version with both of the following kernels:

2.6.28-15 Generic AMD64
2.6.31-14 Generic AMD64

Thanks again for all your help.

Regards,
Nigel.

dmanges (dmanges) wrote :
Download full text (8.3 KiB)

Looks like people are having luck with this driver... except me! I have an Lenovo ThinkPad R500 with the Realtek 8172. I was referred to this thread for help. When I install the driver in Ubuntu 9.04 AMD 64 using:

sudo make
sudo make install

I get the following:

make[1]: Entering directory `/usr/src/linux-headers-2.6.28-11-generic'
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_core.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl8192se.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_eeprom.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_wx.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_cam.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_pm.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_ps.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_debug.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/rtl_ethtool.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8190_rtl8256.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_Efuse.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_phy.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_firmware.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192E_dm.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_rtl6052.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_hwimg.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_led.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/r8192S_mp.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_rx.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_softmac.o
/home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_softmac.c: In function ‘ieee80211_sta_send_associnfo’:
/home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_softmac.c:2350: warning: format ‘%d’ expects type ‘int’, but argument 3 has type ‘size_t’
/home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_softmac.c:2350: warning: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_tx.o
  CC [M] /home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee80211_wx.o
/home/dmanges/Desktop/rtl8192se_linux_2.6.0010.1020.2009_64bit/HAL/rtl8192/../../ieee80211/ieee...

Read more...

Francisco Peña (tkd) wrote :

Hi David, I try this driver with out luck.
The same issue, the driver load perfectly, but no scan wireless networks.

ArchLinux
Linux thinkpad 2.6.31-ARCH #1 SMP PREEMPT x86_64 Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz GenuineIntel GNU/Linux

I try it with networkmanager, netcfg, and standar commands (iwlist wlan0 scan)

zakzor (zakzor) wrote :

Hi David,

Thanks a lot !!!

I've been using ndiswrapper with the Win2K driver on my Toshiba L500 with the Realtek 8192SE and sometimes it gave me some headaches like lost signal and also I wanted to set the wireless card to monitor mode which is not available with ndiswrapper.

$ uname -a
Linux zakzor-laptop-ubuntu 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:49:34 UTC 2009 i686 GNU/Linux

You're the man,

zakzor

zakzor (zakzor) wrote :

Tested both on Network Manager and Wicd with wext as WPA Supplicant Driver.

Getting full speed with my NAS.

You should be called David Woo Woo !!! :)

zakzor

Francisco Peña (tkd) wrote :

Ohhhhhhhh yes!
Now it work! very very good!
Thank you David :)
Now I can connect to my WPA2 network. COOL!

david woo (wooshwu) wrote :

Hi dmanges,

   How about trying to install the driver module manually with the steps @ #12 ?
   And the module name shall be r8192se_pci.ko instead of rtl8192se_pci.ko.

   Wish it works. :)

   Thanks.

David

david woo (wooshwu) wrote :

Hi dmanges,

   sorry, minor update.
   How about trying to install the driver module manually with the steps @ #20 ?
                                                                                                                ~~~~~
   And the module name shall be r8192se_pci.ko instead of rtl8192se_pci.ko.

   Wish it works. :)

   Thanks.

David

fiat1100d (gratteri-email) wrote :

On amd64, with the modified driver, I no longer have kernel panic, but the interface wlan0 won't work fine, even if Wi-Fi is enabled in NetworkManager.
dmesg gives this sort of output:

[ 350.072012] ===>ieee80211_start_scan_rsl()
[ 350.084596] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 352.060132] ====================>haha:IPSEnter()
[ 352.060151] =========>NicIFDisableNIC()
[ 352.060167] PHY_SetRtl8192seRfHalt save BB/RF
[ 370.069854] =========>r8192_wx_set_scan(): IPSLeave
[ 370.070185] ===========>NicIFEnableNIC()
[ 370.077265] gen_RefreshLedState first init
[ 370.077274] =================> NIC version : C-cut
[ 370.187598] ===>rtl8192_SetWirelessMode(), wireless_mode:0x10, support_mode:0x16
[ 370.187608] <===rtl8192_SetWirelessMode(), wireless_mode:10, bEnableHT = 1
[ 372.060133] ====================>haha:IPSEnter()
[ 372.060152] =========>NicIFDisableNIC()

continuously, it only stops if I disable the RF with the switch:

[ 523.786345] GPIOChangeRF - HW Radio OFF
[ 523.852605] rtl819xSE:==========>rtl8192_down()
[ 523.852613]
[ 523.853178] Save max pwr
[ 523.872719] rtl819xSE:<==========rtl8192_down()

david woo (wooshwu) wrote :

HI Fiat,

    It seems that there's no network available.
    please check whether there's .wireless AP around,
    or the same hardware platform used to be linked to wireless AP before?

   Thanks.

David

fiat1100d (gratteri-email) wrote :

Hi David,

seems it was a fault of mine, I was trying to connect in a place of my University where I was sure there should have been Wi-Fi access, and instead there was no AP at all! :-/

Tried at home, works just fine!

tags: added: realtek rtl8172 rtl8192se wireless wlan
tags: added: rtl8191se
description: updated
Keng-Yu Lin (lexical) on 2009-12-11
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Confirmed
229 comments hidden view all 309 comments
Nuno (nuno-miguel-vitorino) wrote :

I'm using the latest drivers and having the same problems as Øsse on post #268. Is this a regression from previous drivers?
There are lots of messages in dmesg but seems there are two errors causing the connection to fail:

[ 5850.474867] rtllib: ERR! in GetTs(), TID(10) is not valid
[ 5850.474876] rtllib: can't get TS for RXTS in rtllib_rx_DELBA().dst:00:24:17:99:e8:d3 TID:10

Any ideas? Should I just try the previous driver?

Thanks,

Nuno

Asem (the1asem) wrote :

Hello;
i just installed ubuntu 10.04 beta1 64 bit,and found the wireless working natively but with the same problem as that posted at 268
, i hardly can maintain a couple of minutes of connection then i must restart the network to get the connection working again.
i installed the latest drivers from realtek v.15 and there is no effect on the situation.
i am still using ubuntu 9.10 2.6.31.20 with the realtek driver and the connection is very good actually...so is it a problem with the 2.6.32 kernel?

Howard Chu (hyc) wrote :

I just got a Thinkpad Edge yesterday and installed 10.04 beta1 x64 on it. Out of the box the driver was only seeing 1 unencrypted network. I grabbed the latest realtek driver and then was able to see the other networks (my own is WPA/Enterprise). After I deleted the original driver (from /lib/modules/<version>/kernel/ubuntu) and installed the new one, things seemed to be working OK.

But it looks like the driver stops working after the machine has gone to sleep and waken up again. It would see my network but failed on WPA authentication. rmmod / modprobe seemed to take care of that.

Nuno (nuno-miguel-vitorino) wrote :

BTW, I'm running Karmic with the 2.6.31.20 kernel and I have the problem of maintaining a connection so it's not a specific 2.6.32 kernel problem.

Nuno

Øsse (oystwa) wrote :

The same problems exists wtih 2.6.33 as well, using Karmic. However, it seemed like it managed to reconnect after 30 seconds or so. I wil ltry this out some more.

Nuno (nuno-miguel-vitorino) wrote :

After a lot of testing I found that the problem occurred only when connecting with WPA2. I changed my wireless security to connect through WPA and the connection is working fine with the latest drivers.I've tried playing a bit with wpa_supplicant but to no avail. So it seems like it's a bug with WPA2 only. Another option is some problem with my wireless router (a BT HomeHub 2, which is pretty common here in the UK. I have no problems at all with the connection on my Windows computers.

Ivo Sir (ivo-sir) wrote :

Hi folks,

Sorry for crossposting... but after a sleepless night I managed to make my connection working and stable. I can confirm the post #275, thanks to Nuno for the hint.

Running Ubuntu Karmic (9.10) 64bit on Asus EEE 1201N with rtl8192se wifi interface.

A few days ago I bought a new wifi router, 802.11n capable. Since that time the connection was a nightmare. Drop-outs every few minutes, kernel panics, cold resets. I tried many driver versions from both https://bugs.launchpad.net/ubuntu/+s...ux/+bug/401126 and http://www.realtek.com.tw/downloads/, no joy. Ndiswrapper does not work for this network interface on the 64bit OS.

Finally, switching the router from WPA2 to WPA did the magic. Now running the latest driver from the Realtek web site, the connection has been rock stable, about 30 hours without a single drop-out, 150 Mbps.

Either the WPA2 implementation is faulty in the device driver or there is a coincidence of the WPA2 and the 802.11n standard.

Cheers!
Ivo

Meng Zhuo (mengzhuo1203) wrote :

I had make some deb for this card in http://www.thinkwiki.org/wiki/ThinkPad_11b/g/n_Wireless_LAN_Mini-PCI_Express_Adapter_II
welcome every body go and test it

Øsse (oystwa) wrote :

Thanks, Meng Zhuo! Have you made any changes to the drives, except for making the debs?

Øsse (oystwa) wrote :

From #275 and #276 I decided to change the encryption on my router as well. On my router I have the possibility of choosing between WPA2 (AES) and WPA2 Mixed. The default was WPA2 (AES). After changing it to WPA2 Mixed the connection doesn't drop anymore. Sometimes the signal strength drops from the usual value of 88% to 65% and bounces back up again but it seems I am ping the router perpetually.

I don't really know what WPA2 Mixed is, but I guess it is better than WPA.

barroca (barroca) wrote :

Just to mention, this isn't a distribution related issue, i've confirmed the problem with this driver in a Meego based distribution.
In my case, i wasn't abble to connect into N-based network with WEP.

My card is a rtl8191se.

barroca (barroca) wrote :

Hello all, i've found another bug in the launchpad #530275 and it might be related.

In my system the driver found here worked:
https://launchpad.net/~matt-price/+archive/mattprice/+packages

Thanks.

I know there has been a great many comments about this issue, but I'd like to throw in my voice. I have a Toshiba L555D-S7930 with the Realtek 8172 (though it shows up under Win 7 as an 8191se). I've installed the 10.04 beta 2 and am able to connect without WPA only. If I stop working for all of 5 minutes, it simply stops working and will not reconnect without having to shut down to a power off state, then reconnecting.

I've tried all the suggestions regarding compiling a driver, but on my computer it exits with error 2 during the make install. (and Yes, I've installed the sources, headers, and everything else that needs to be installed to compile the driver, and yes, I did use sudo make install.) Every time I try to compile the drivers, it gives me the error.

The very strange thing about all this is I have to turn off WPA in order to connect at all, and even then it is for a very limited time, and that is out of the box.

I've done all the updates and have had to connect to a wired network to do so. lcpci shows the same as most others here, the card is found as 8172.

Is there a setting somewhere or other drivers I must be missing??? I'm willing to try anything at this point including a reinstall, though somehow I doubt that will make a difference.

I am using the i386 version as I only have 3gig of mem to begin with. Would switching to 64bit make a difference?

Katana (katana--) wrote :

@Ken Nelan: Sounds like your issue is the command. You say you're using "sudo make install", yes?

If that is the case, for this set of drivers that doesn't seem to work. You _must_ build the drivers with "su", not "sudo".

For Ubuntu, use these terminal commands:
$ sudo su
(enter sudo password)
$ make; make install; modprobe rtl8192se_pci

(I do this with a few differences, since I run on Fedora, but that's the gist of it)

Hope that helps.

@Obsidian,

I did try that and it was still no go. Still got the same error message. Running Ubuntu 10.04 b2 here. I did discover that the AMD Turino II M500 is a 64 bit so I'm going to download the 64 version and see if that makes the difference... Everything I've read shows people using the 64 bit with great success.

pablomme (pablomme) wrote :

@Ken: try the dkms package in Matt Price's PPA, https://launchpad.net/~matt-price/+archive/mattprice . Simply install the package using synaptic/apt-get/..., and possibly reboot. This is just the latest Realtek driver release packaged as a dkms module, for which everything is done automatically. See bug #530275 for more info.

On a separate note, whether you choose to install 32- or 64-bit Ubuntu has no effect on this. In practice it might be marginally "safer" to stay on 32-bit Ubuntu, while you may obtain marginally better performance on 64-bit Ubuntu - it's your choice.

@pablomme et al...

Wow. That's all I can say. Wow!!!

I don't know if it was something I was doing then, which I admit is entirely possible, but it is working so well now!!! No pauses, no complaints!!!!

I probably missed reading that there were updated drivers. I was using an old set.

This is no longer an issue for me.

pablomme, thank you so much for the quick response, and to you as well Obsidian!!!! I'll give it a thorough work out to make sure nothing freezes up. (oh... and wpa now works as well.)

Peace ya'all.

Kjnelan

Chih-Hsyuan Ho (chih) wrote :

In my system, after installing the latest driver from Realtek (Version: 0015.0127.2010), the wireless function would work properly upon a fresh system start. However, it could no longer connect to internet after coming back from suspend or hibernate. It would simply keep trying and trying and fail eventually. Anyone else has similar experience?

Chih-Hsyuan Ho (chih) wrote :

Later I learned that adding the following line to a newly created file in /etc/pm/config.d/wireless

SUSPEND_MODULES="r8192se_pci"

to force an unload/load the r8192se_pci module during S3/S4 process seems to fix the issue.

Chih Ho: what is your system?

I have a Asus EEE 1201N laptop with the same characteristics.
However it seems to be related to other bugs that makes hibernate &
suspend not work properly on that laptop.

hello everyone! after grappling with this problem myself. ok first of all you need to use the realtek driver as david woo suggested. manual or automatic install is your choice. try automatic. much quicker i guess. then you might come across the situation where the GUI will still not show the list of wireless networks nearby. go to terminal and then:

ifconfig wlan0 up

should do the trick.

otherwise, from the folder where you extracted the drivers,

./wlan0 up

where i got this from? - the driver readme! check it out and its quite helpful and straightforward!

Brian Harkness (maestro-bwh) wrote :

Sadly, I see the same issue that others are seeing with 64 bit. The module/driver is there but it fails to find any networks.

Martin Lindhe (martinlindhe) wrote :

Brian:

try installing rtl8192se-dkms from https://launchpad.net/~matt-price/+archive/mattprice

Chih-Hsyuan Ho (chih) wrote :

Martin, it is a generic laptop system made an unknown ODM. The wireless module is identified as [10ec:8172] and the driver from Matt Price's PPA is used.

For what it's worth, I just discovered that to make wireless function work more reliably upon resuming from suspend, in addition to the file added to /etc/pm/config.d/, a manual rmmod and modprobe operation to the r8192se_pci module at resume is needed. Reason is completely unknown though.

Brian Harkness (maestro-bwh) wrote :

Martin:Thanks for this. I was wading through this very long post yesterday after getting my ASUS EEEPC 1201N and was trying everything.
It was frustrating to see wlan0, only to find that it was inoperable. A kernel driver that does not work on the device creates more problems than not having the driver.
I will post a short how to on Ubuntu: there is nothing there that solves this problem yet. I am up and running with the internal wireless card now:-)

Nico Lang (rebmevon77) wrote :

Hi!
Does anybody have a working connection with 8192SE and new 10.04? Under 9.10 the last driver (0015) has worked perfect but now under 10.04 nothing :-(
P.S. I made a update from 9.10 to 10.04 and have reinstalled the 0015 driver

Nico

Hello!

I have 0015 driver working with 10.04, kernel version is
"2.6.32-21-generic #32-Ubuntu".
Device: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)

Have you removed /lib/modules/2.6.32-21-generic/kernel/ubuntu/rtl8192se/ ?

On Sat, 01 May 2010 10:47:33 -0000, Nico Lang <email address hidden>
wrote:
> *** This bug is a duplicate of bug 567016 ***
> https://bugs.launchpad.net/bugs/567016
>
> Hi!
> Does anybody have a working connection with 8192SE and new 10.04? Under
> 9.10 the last driver (0015) has worked perfect but now under 10.04
nothing
> :-(
> P.S. I made a update from 9.10 to 10.04 and have reinstalled the 0015
> driver
>
> Nico

Nico Lang (rebmevon77) wrote :

@Valdimir
No, it is still there. At this moment wifi works fine but sometimes I have interruptions and I have to stay 1m from my router away. It seems to be the same problem as earlier with battery power and 'normal' power management. Keep trying...

Nico

I was actually wrong when I stated everything worked fine. I had forgotten I was not using any encryption for my wireless when I was doing all the testing.

The moment I turned on encryption on my router I had problems all over again. It turns out it was my router setting.

I don't know if this will work or not for anyone out there having this problem, but I had one bugger of a time getting the realtek 8192SE to work on my Toshiba Satellite. The fix actually was not on my computer, but on the router. The moment I changed the router from both “WPA2 and WPA” to just WPA everything worked. I had used the updated drivers, compiled drivers, did everything suggested in forums and in bug reports and nothing worked. Making that one change in my router made everything work perfectly.

I've tried several live CD's, all of which now work with my wireless 8192SE after making that change to my router.

I'm just still learning the finer intricacies of Linux myself. I hope this helps someone out there, though I don't think this is a fix. It just worked for me...

theUg (theug) wrote :

@Ken Nelan. It shouldn’t be the router issue. For instance, my new laptop doesn’t work with Realtek 8192 card (network manager states  “device not ready”), while Linksys USB adapter works on the same network.

@theUg,

Forgive me, I thought I added that I didn't think my post was a fix, but it may help some out there who are able to "see" their network, but unable to connect to it. They may think it's a error with their hardware when it may be a router issue.

Please do note, I say "may" be. I am in no way making statements of fact. I am only saying I had an issue where I could not get my Toshiba laptop's wireless (which has the 8192SE in it) to even find, let alone use the wireless card. I did update drivers, compiled drivers, updated kernels, etc... everything suggested by all bug reports and forums. When I could finally "see" my network I could not connect and thought it was still an issue with my driver or with wpasupplicant. Making the change from WPA2 and WPA to just WPA allowed me to then connect into my network.

I am merely suggesting that those who are able to "see" their network, but are still unable to connect should at least "try" what I suggested. For those who can not get their devices to work at all, then obviously my suggestion is moot. Perhaps I should have been clearer with my suggestion. Forgive me... One is merely trying to help those who may be in the same situation I was in.

theUg (theug) wrote :

@Ken Nelan. No, there is no problem. Really, what I was saying it never should be router problem, and system should ideally figure it all out on its own. But that’s why we have bug reports. :)

STaRMaN (jarizaro) wrote :

For me, today, in Lucid, with kernel.. Linux 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

I'm not having problems using this wlan.
Drivers are defaults from lucid, i did't touch something.
In karmic i had to compile and build rtl8192se_linux_xxx_64bit.tar.gz .

I have been running this machine (default Lucid install) , for 4 - 5 days without stop (no more hangs). So i think this problem is solved in lucid ...

Marius (wishinet) wrote :

You can sum up all these posts in one sentence:
Realtec's RTL8192SE Linux drivers are buggy, there're no in-Kernel drivers, and Realtec doesn't have any intention to fix this.

No one cares whether it works with some unknown router. It has nothing to do with "the router". Your router configuration doesn't really matter.

The device drivers at current state do not allow to use WPA Enterprise. It's not deactivated, it crashes. It won't be fixed. Therefore change the status to "WONTFIX" clean up this mess, and wait until Linux supports this hardware, too.

Mancy (mancy) wrote :

it Works for me.
my station: Toshiba L510 Satellite Realtek 8172 with driver RTL8192SE

I've discovered my WIFI problem with Lucid 2.6.32-24-generic

my system was in dual-boot, i logged in to windows then i was using the LAN which led me to deactivate/disable the WLAN using the keyboard function keys.

then all solutions on Ubuntu doesn't work, until i booted to windows again and activated the WLAN driver then rebooted to Ubuntu and that made it WORK.

so my suggestion is to activate your WLAN using the keyboard function keys from Windows or other application because i cannot use the keyboard functions keys on Ubuntu to activate or deactivate the WLAN Driver.

hope it helps ;)

Yang Zhou (yangorang) wrote :

Same issue with my Lenovo x100e under Ubuntu 10.4. I really wish this would get fixed so I can use Linux rather than Windows 7 as my laptop is not terribly fast.
I need to be able to connect to my university network, which uses WPA-Enterprise with PEAP.
Also my home network uses WPA2-Personal; I've been having a lot of issues with the Realtek drivers connecting to these so heh...

Jared Biel (sylvester-0) wrote :

Just adding another "me too" here. Using 10.04 w/ all updates (2.6.32-24-generic #39) my machine is unusable with the RTL 8172 wireless card turned on. It randomly locks up my machine - sometimes within minutes of boot, othertimes within hours. I'm upgrading to Maverick right now to see if the situation has improved. I WOULD just switch out the wireless card but this machine is a Lenovo X201 and Lenovo only allows their "authorized" (locked by BIOS) network cards to be installed...

I have the same problem on a Toshiba x505-890 Using 10.04 w/ all updates (2.6.32-24-generic) . My machine randomly locks up. Actually, one wireless network at the university, my machine always goes into a kernel panic as soon as the wireless connects.

meneer (meneer) wrote :
Download full text (3.4 KiB)

I just installed the latest driver for rtl8192se card on my Lenovo Thinkpad Edge 13 (AMD processor powered), and after installing these messages are logged in the message log repeatedly:

Aug 25 08:46:26 Thinkpad kernel: [ 244.604057] =====>rtl8192_set_chan()====ch:13
Aug 25 08:46:26 Thinkpad kernel: [ 244.716085] Scan in 20M, back to 40M
Aug 25 08:46:26 Thinkpad kernel: [ 244.716111] =====>rtl8192_set_chan()====ch:9
Aug 25 08:46:26 Thinkpad kernel: [ 244.726404] ===>rtl8192se_link_change():ieee->iw_mode is 2
Aug 25 08:46:26 Thinkpad kernel: [ 244.726421] rtl8192_update_cap(): WLAN_CAPABILITY_SHORT_PREAMBLE
Aug 25 08:47:18 Thinkpad kernel: [ 296.825792] rtl8192_hw_sleep_down(): RF Change in progress!
Aug 25 08:47:21 Thinkpad kernel: [ 300.111095] r8169: eth0: link up
Aug 25 08:47:24 Thinkpad kernel: [ 302.828137] rtl8192_hw_wakeup(): RF Change in progress! schedule wake up task again
Aug 25 08:48:04 Thinkpad kernel: [ 342.826050] rtl8192_hw_sleep_down(): RF Change in progress!
Aug 25 08:48:05 Thinkpad kernel: [ 343.204997] LPS leave: notify AP we are awaked ++++++++++ SendNullFunctionData
Aug 25 08:48:05 Thinkpad kernel: [ 343.205251] ===>rtl8192se_link_change():ieee->iw_mode is 2
Aug 25 08:48:05 Thinkpad kernel: [ 343.260187] Scan in 40M, force to 20M first:3, 1
Aug 25 08:48:05 Thinkpad kernel: [ 343.260251] =====>rtl8192_set_chan()====ch:1
Aug 25 08:48:05 Thinkpad kernel: [ 343.372053] =====>rtl8192_set_chan()====ch:2
Aug 25 08:48:05 Thinkpad kernel: [ 343.484181] =====>rtl8192_set_chan()====ch:3
Aug 25 08:48:05 Thinkpad kernel: [ 343.597249] =====>rtl8192_set_chan()====ch:4
Aug 25 08:48:05 Thinkpad kernel: [ 343.708233] =====>rtl8192_set_chan()====ch:5
Aug 25 08:48:05 Thinkpad kernel: [ 343.820057] =====>rtl8192_set_chan()====ch:6
Aug 25 08:48:05 Thinkpad kernel: [ 343.932223] =====>rtl8192_set_chan()====ch:7
Aug 25 08:48:05 Thinkpad kernel: [ 344.044093] =====>rtl8192_set_chan()====ch:8
Aug 25 08:48:05 Thinkpad kernel: [ 344.156062] =====>rtl8192_set_chan()====ch:9
Aug 25 08:48:06 Thinkpad kernel: [ 344.268054] =====>rtl8192_set_chan()====ch:10
Aug 25 08:48:06 Thinkpad kernel: [ 344.380054] =====>rtl8192_set_chan()====ch:11
Aug 25 08:48:06 Thinkpad kernel: [ 344.492411] =====>rtl8192_set_chan()====ch:12
Aug 25 08:48:06 Thinkpad kernel: [ 344.604080] =====>rtl8192_set_chan()====ch:13
Aug 25 08:48:06 Thinkpad kernel: [ 344.716093] Scan in 20M, back to 40M
Aug 25 08:48:06 Thinkpad kernel: [ 344.716107] =====>rtl8192_set_chan()====ch:9
Aug 25 08:48:06 Thinkpad kernel: [ 344.726266] ===>rtl8192se_link_change():ieee->iw_mode is 2
Aug 25 08:48:06 Thinkpad kernel: [ 344.726279] rtl8192_update_cap(): WLAN_CAPABILITY_SHORT_PREAMBLE
Aug 25 08:48:08 Thinkpad kernel: [ 346.821522] rtl8192_hw_sleep_down(): RF Change in progress!
Aug 25 08:48:10 Thinkpad kernel: [ 348.827117] rtl8192_hw_wakeup(): RF Change in progress! schedule wake up task again

The driver I downloaded form the realtek site and installed is rtl8192se_linux_2.6.0017.0705.2010.tar.gz (published augustus 24th).
Running ubuntu 10.04.1, kernel 2.6.32-24-generic
I issued these commands to install the kerneldriver:
    $ sudo su
    # make
    # make install
  ...

Read more...

JL (vwyodapink) wrote :

The problem is still here for me running any version of this driver either from Ubuntu or Realtek themselves. I have even tried emailing their tech support for help and the drivers they sent me still cause the same problems, some even worse than before. For me even if I am not connected to anything just have the driver installed I get the hard lock up and have to do a hard reboot and then restart again to get everything going correctly again. I have to resort to using a USB dongle for wifi and leaving the driver out of the system. Funny thing is my USB adapter is a realtek as well just different chip version and it rocks no issues at all. I am on a toshiba x505-887 running Ubuntu 10.10 Kernel 2.6.35-23-generic, nvidia driver.

I have done every possible combination to confirm its this driver alone and for my system its only this that makes it unusable.

Displaying first 40 and last 40 comments. View all 309 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers