Ubuntu

ecafe ec-900 Fn+vol Keys render System useless

Reported by jotronic on 2009-07-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Once the Keycombination is used, the OSD shows up and won't ever go away. The Mousecursor can be moved, but nothing can be clicked. ALT+F1 also doesn't work.

Instead of one step per button push the volume is maxing out to 100% or 0%, depending on which button pressed but won't even stop there.

jotronic (jotronic) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.10
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_DE.UTF-8
Uname: Linux 2.6.31-4-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin plugdev sambashare tape video

tags: added: apport-collected
jotronic (jotronic) wrote :

Is this in ubuntu? http://aur.archlinux.org/packages.php?ID=24050 When not, then this might be the reason for that bug.

robod (robert-dobozy) wrote :

Hi there,

I just want to confirm that this problem is still present in Lucid (as well as all previous releases - tried 9.10, 9.04).
Not sure if there is anything else we can collect/try/test to help to get this resolved.

Fabio Marconi (fabiomarconi) wrote :

Hello robod.
Can you please attach these file from Lucid:
/var/log/syslog
/var/log/dmesg
/var/log/kern.log
:)Fabio

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robo 1291 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe938000 irq 43'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,1071d221,00100101'
   Controls : 21
   Simple ctrls : 13
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=d7948597-196a-409f-bdce-b94df19a2ae5
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
MachineType: Hercules EC-900
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-16-generic root=UUID=03ab77f9-3af2-4c5e-9f5a-51ad4ce62def ro quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-16.22~lucid2-generic 2.6.35.2
Regression: No
RelatedPackageVersions: linux-firmware 1.34.1
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
StagingDrivers: rt2860sta
Tags: ubuntu-une lucid needs-upstream-testing staging
Title: [STAGING]
Uname: Linux 2.6.35-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/26/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: To be filled by O.E.M.
dmi.board.vendor: To be filled by O.E.M.
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd09/26/2008:svnHercules:pnEC-900:pvr1.0:rvnTobefilledbyO.E.M.:rnTobefilledbyO.E.M.:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: EC-900
dmi.product.version: 1.0
dmi.sys.vendor: Hercules

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

robod (robert-dobozy) wrote :

Syslog

robod (robert-dobozy) wrote :

kern.log

robod (robert-dobozy) wrote :

Hi there,
I've used appport to upload info about my system. In a hindsight it was probably too much information. Sorry about that. Dmesg is in apport report and I've attached the other two as requested.
There is absolutely no info or warning message in any of the logs when it happens, so it's difficult to be more specific as I can't tell where exactly it happens.
Probably need to enable some debugging in X or acpi(?) and press the buttons to collect more information. However I'm not sure how....

Rob

Fabio Marconi (fabiomarconi) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

tags: added: ecafe-ec900 jaunty karmic lucid
affects: linux (Ubuntu) → xserver-xorg-input-keyboard (Ubuntu)
Changed in xserver-xorg-input-keyboard (Ubuntu):
status: Incomplete → Confirmed
robod (robert-dobozy) wrote :

Hi there,
Just a little bump and confirmation that this is still an issue in Natty. Behaviour the same as previous Ubuntu versions...

Bryce Harrington (bryce) wrote :

This was filed against the wrong driver package. -keyboard is no longer maintained; keyboards are managed via the -evdev driver now. However hotkeys are handled lower down than X these days; see http://wiki.ubuntu.com/Hotkeys for directions on troubleshooting these kinds of problems. I'm bumping to kernel for now, but it may well be some intervening package at fault.

affects: xserver-xorg-input-keyboard (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium

jotronic, thank you for reporting this and helping make Ubuntu better. Karmic reached EOL on April 30, 2011.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:
https://help.ubuntu.com/community/ReportingBugs

tags: added: needs-kernel-logs needs-upstream-testing
removed: ecafe-ec900 karmic lucid
tags: added: karmic
removed: jaunty
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
robod (robert-dobozy) on 2012-12-17
Changed in linux (Ubuntu):
status: Expired → Confirmed

robod, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments