[i855] (Needs intel 2.10) No Xv support for 82852/855GM (KMS bug)

Bug #395932 reported by Baard Johansen on 2009-07-06
152
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
xf86-video-intel
Fix Released
Wishlist
linux (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by Matteo Settenvini
Lucid
Wishlist
Unassigned
xserver-xorg-video-intel (Ubuntu)
Wishlist
Bryce Harrington
Nominated for Karmic by Matteo Settenvini
Lucid
Wishlist
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

After upgrading to Karmic (alpha) my graphics driver is unable to provide Xv. The following line is printed in Xorg.0.log:

(WW) intel(0): Disabling Xv because no adaptors could be initialized.

I've tried various settings in xorg.conf, with no luck. (XvPreferOverlay, Tiling).

[Update]

From the Q4 anouncment [1]:
Video overlay support with KMS is now supported in xserver-xorg-video-intel 2.10.0. This currently requires Linux 2.6.33, but a backport to 2.6.32 (Lucid version) is available from [2]. Daniel Vetter intends to support this backport which is intended for distros that use kernel 2.6.32 [3]. Although the main code is in the kernel, intel driver 2.10.0 is apparently required [4].

[1]: http://intellinuxgraphics.org/2009Q4.html
[2]: http://gitorious.org/daniel-s-linux-stuff/linux-kernel/commits/intel-kms-overlay-for-2.6.32
[3]: http://lists.freedesktop.org/archives/intel-gfx/2010-January/005372.html
[4]: https://bugs.freedesktop.org/show_bug.cgi?id=20901#c42

[lspci]
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
     Subsystem: Acer Incorporated [ALI] Device 0035
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
     Subsystem: Acer Incorporated [ALI] Device 0035

*** Bug 21510 has been marked as a duplicate of this bug. ***

I can confirm this behavior with i915.
This is important until Bug 20664 is fixed. If textured video works without tearing and has no performance issues there is no need for Overlay.

> --- Comment #2 from <email address hidden> 2009-05-03 08:03:42 PST ---
> I can confirm this behavior with i915.
> This is important until Bug 20664 is fixed. If textured video works without
> tearing and has no performance issues there is no need for Overlay.

wrong. i8xx has no textured video.

Right, guess which card support will be dropped next ;)

Any news from the devs on this issue?

Binary package hint: xserver-xorg-video-intel

After upgrading to Karmic (alpha) my graphics driver is unable to provide Xv. The following line is printed in Xorg.0.log:

(WW) intel(0): Disabling Xv because no adaptors could be initialized.

I've tried various settings in xorg.conf, with no luck. (XvPreferOverlay, Tiling).

Geir Ove Myhr (gomyhr) wrote :

Could you please run `apport-collect 395923` on your machine, so that we get the various logs that are useful for troubleshooting and reporting upstream?

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Geir Ove Myhr (gomyhr) on 2009-07-06
tags: added: 855gm karmic videoplayback
Baard Johansen (baard) wrote :

I think you typed the wrong bug-number above. However, apport-collect fails with:

$ apport-collect 395932
Logging into Launchpad...
Downloading bug...
Bug title: No Xv support for 82852/855GM in Karmic
Collecting apport information for source package xserver-xorg-video-intel...
Uploading additional information to Launchpad bug...
   short text data...
Traceback (most recent call last):
  File "/usr/bin/apport-collect", line 145, in <module>
    upload(report, bug)
  File "/usr/bin/apport-collect", line 52, in upload
    subject='apport-collect data')
  File "/usr/lib/python2.6/dist-packages/launchpadlib/resource.py", line 337, in __call__
    args[key] = simplejson.dumps(value, cls=DatetimeJSONEncoder)
  File "/usr/lib/pymodules/python2.6/simplejson/__init__.py", line 237, in dumps
    **kw).encode(obj)
  File "/usr/lib/pymodules/python2.6/simplejson/encoder.py", line 194, in encode
    return encode_basestring_ascii(o)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xff in position 911: unexpected code byte

1 comments hidden view all 228 comments
Baard Johansen (baard) wrote :
Baard Johansen (baard) wrote :
Baard Johansen (baard) wrote :

I would also like to add that Xv is enabled with the alpha 2 release, but stopped working after upgrading the system after installation. Attaching the Xorg-log from before the upgrade, in case this helps.

1 comments hidden view all 228 comments
Baard Johansen (baard) wrote :
Geir Ove Myhr (gomyhr) wrote :

Thank you! It is very useful to know that it worked with alpha 2 before upgrades. The one major change I can think of after alpha 2 is that kernel modesetting (KMS) has been enabled in the kernel. Could you try to disable KMS on an upgraded Karmic to see if KMS is the culprit? To do that, add the following kernel parameter on boot (by pressing E on the GRUB boot menu IIRC): i915.modeset=0

More information about the addition of KMS in ubuntu:
https://lists.ubuntu.com/archives/ubuntu-x/2009-June/000578.html

Xorg.0.log from the test would be appreciated.

Geir Ove Myhr (gomyhr) wrote :

Btw, I think you can also enable KMS with i915.modeset=1 on alpha-2 if you haven't upgraded yet, and see if it causes the problem.

Bryce Harrington (bryce) on 2009-07-06
summary: - No Xv support for 82852/855GM in Karmic
+ [i855] No Xv support for 82852/855GM in Karmic

The problem is gone when KMS is disabled. I've already upgraded, but I can reinstall if that will provide you with much extra info.

Geir Ove Myhr (gomyhr) on 2009-07-06
summary: - [i855] No Xv support for 82852/855GM in Karmic
+ [i855] No Xv support for 82852/855GM (KMS bug)
Geir Ove Myhr (gomyhr) wrote :

> The problem is gone when KMS is disabled. I've already upgraded, but I can reinstall if that will provide you with much extra info.

That shouldn't be necessary.

It would probably be nice to have the output of `xvinfo` both with and without KMS. Also, are you on 32-bit or 64-bit?

With that information I think this is more or less ready to go upstream. If you feel that you are up to it, you can do it yourself. Otherwise I can put together a report once time permits. Instructions (and a template) for filing a bug upstream is at http://intellinuxgraphics.org/how_to_report_bug.html .

Actually, would you mind reporting the apport-collect problem as a bug as well? I suspect the output would actually mean something useful to the developer.

Bryce Harrington (bryce) on 2009-07-16
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Confirmed

Textured video works better than before but it still tears in some parts with an i915.

So what is the status of this issue?

*** Bug 22978 has been marked as a duplicate of this bug. ***

Hi Baard,

I've forwarded your bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=22978 - please subscribe to this bug in case upstream needs further information or wishes you to test something. Thanks ahead of time.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Baard Johansen (baard) wrote :

Why has this been marked as "Invalid"? Is it because the bug at freedesktop.org has been marked as a duplicate? Shouldn't this bug be marked as duplicate instead?

Timo Aaltonen (tjaalton) wrote :

the upstream bug was marked as invalid, not the ubuntu one. Updating the url.

Changed in xserver-xorg-video-intel:
status: Invalid → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
lannyboy (jincool) wrote :

i also encountered the same problem -> No Xv support for 82852/855GM. there is no luck i could just enable it even i tried lines at xorg.conf.

(WW) intel(0): Disabling Xv because no adaptors could be initialized.

i am a using fedora 11.

Bryce Harrington (bryce) on 2009-07-30
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Medium → Wishlist

I am really interested in the video overlay as I own a 865GM

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)

That works out of the box with KMS but no textured video so... no Xv...

I've posted my latest work on porting the overlay to kms to <email address hidden>. I'm really interested in test-reports because I have just a 855GM to develop on. I'll upload my latest patches against kernel and ddx on this bug report, too.

Thx for all reports, Daniel

Created an attachment (id=28587)
patch for ddx

Apply to latest xf86-video-intel git master. To compile you need the
new ioctl definitions from the kernel.

Created an attachment (id=28588)
patch for ddx

this time the actual patch, not just the log ...

Created an attachment (id=28589)
patch for kernel

patch is against latest -linus (I'm using 2.6.31-rc5-gitsomething).

To install the new userspace headers do:

$ make install

Then copy usr/include/drm/i915.h someplace where it can be included by the ddx
(quick&dirty: overwrite the system header in /usr/include/drm)

Download full text (3.3 KiB)

well... I just tested the patches and after that the video overlay is detected, I can play videos with mplayer using it, but can't put them in fullscreen, I just get a blue screen and mplayer spams this :

X11 error: BadAlloc (insufficient resources for operation)

so there might be a problem somewhere. There is no error nor warnings in the kernel, the Xorg.log or anywhere else than the output of mplayer.

xvinfo has a promising output:

X-Video Extension version 2.2
screen #0
  Adaptor #0: "Intel(R) Video Overlay"
    number of ports: 1
    port base: 72
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 5
      "XV_COLORKEY" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 66046)
      "XV_BRIGHTNESS" (range -128 to 127)
              client settable attribute
              client gettable attribute (current value is -19)
      "XV_CONTRAST" (range 0 to 255)
              client settable attribute
              client gettable attribute (current value is 75)
      "XV_SATURATION" (range 0 to 1023)
              client settable attribute
              client gettable attribute (current value is 146)
      "XV_PIPE" (range -1 to 1)
              client settable attribute
              client gettable attribute (current value is -1)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 5
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x434d5658 (XVMC)
        guid: 58564d43-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)

So I think there might be just a little thing missing to make it work, unfortunately I don't know anything about the intel driver to begin the debug. My card :

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company D530 sff(dc578av) [103c:12bc]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at fc400000 (32-bit, non-prefetchable) [size=512K]
        Region 2: I/O ports at 24e0 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power ...

Read more...

Created an attachment (id=28615)
patch for kernel

this should fix the fullscreen issue.

On Thu, Aug 13, 2009 at 02:35:30PM -0700, <email address hidden> wrote:
> --- Comment #13 from <email address hidden> 2009-08-13 14:35:29 PST ---
> well... I just tested the patches and after that the video overlay is detected,
> I can play videos with mplayer using it, but can't put them in fullscreen, I
> just get a blue screen and mplayer spams this :
>
> X11 error: BadAlloc (insufficient resources for operation)
>
> so there might be a problem somewhere. There is no error nor warnings in the
> kernel, the Xorg.log or anywhere else than the output of mplayer.

Thanks for testing. I've already fixed the fullscreen issue (it's a
over-eager test in the kernel due to a misconception on my side). I must
have sent out a stale version of the patches. I'll redo them.

One important question: Have you noticed any visual corruptions like
flickering (I have them here on my 855GM) on your 865G? That's the last
problem known to me and having a better picture of which chip revs are
affected may help.

Thanks, Daniel

Thanks for your fast work. Now fullscreen works ^^

I had seen pretty bad corruption (1/4 of the screen goes green or displays a part of the video it shouldn't) when I changed the resolution to a lower one, I get a slight one at native resolution (only some lines that appear and disappear, I didn't see it when the full screen wasn't there as it is very small, but now that I can go to fullscreen I can see it).

> --- Comment #16 from <email address hidden> 2009-08-14 02:37:00 PST ---
> Thanks for your fast work. Now fullscreen works ^^

Good, thanks for testing.

> I had seen pretty bad corruption (1/4 of the screen goes green or displays a
> part of the video it shouldn't) when I changed the resolution to a lower one, I
> get a slight one at native resolution (only some lines that appear and
> disappear, I didn't see it when the full screen wasn't there as it is very
> small, but now that I can go to fullscreen I can see it).

At native resolution, when you stop the video, do the corruptions (slowly)
disappear? Some mouse-moving moving around of other windows may help (does
at least here). Just to make sure we're seeing the same type of
corruption.

About the reduced resolution issue: You may be hitting the completely
untested one-line-mode code. Can you post the output of

$ xrandr

when this happens? Or does the corruption disappear, when you stop the
video (like above)?

-Daniel

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress

The corruption only affects the video nothing else.

Ah, the heavy corruption at lower resolution was probably the same issue as the missing fullscreen, it has disappeared.

Now the only remaining corruption are the lines that appear, and it seems dependent on the resolution of the video, the lesser the resolution it is the greater the number of lines. (I got a few lines with a 720p video and a lot with a 640x480 one), they appear and disappear just like if it were a refresh problem.

my xrandr output :

Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 2048 x 2048
VGA1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 410mm x 256mm
   1680x1050 59.9*+
   1280x1024 75.0
   1360x768 60.0
   1024x768 75.1 70.1 60.0
   800x600 72.2 75.0 60.3
   640x480 72.8 75.0 60.0
   720x400 70.1

I can confirm this issue with Karmic Alpha 4
VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
My workaround is to use "nomodeset" at grub boot in order to do not use KMS

Daniel, thanks for the patch.

Jesse, could you review and consider commit?

Changed in xserver-xorg-video-intel:
status: In Progress → Confirmed

On Mon, Aug 31, 2009 at 08:03:22PM -0700, <email address hidden> wrote:
> http://bugs.freedesktop.org/show_bug.cgi?id=20901
> --- Comment #19 from Gordon Jin <email address hidden> 2009-08-31 20:03:21 PST ---
> Daniel, thanks for the patch.
>
> Jesse, could you review and consider commit?
Just fyi, there's an ongoing discussion on dri-devel about the right
kernel-userspace interface of this whole thing.

-Daniel

Any progress?

Beni Cherniavsky (cben) on 2009-09-21
tags: added: apport-collected
Bryce Harrington (bryce) on 2009-10-02
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → New
tags: added: xorg-needs-kernel-fix
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: New → Triaged
Steve Langasek (vorlon) on 2009-10-28
Changed in ubuntu-release-notes:
status: New → Fix Released
Geir Ove Myhr (gomyhr) on 2010-02-02
description: updated
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
148 comments hidden view all 228 comments
ruegi (ruegi-k) wrote : GdmLog.txt
ruegi (ruegi-k) wrote : Lspci.txt
ruegi (ruegi-k) wrote : UdevDb.txt
ruegi (ruegi-k) wrote : UdevLog.txt
ruegi (ruegi-k) wrote : XorgLog.txt
ruegi (ruegi-k) wrote : Xrandr.txt
ruegi (ruegi-k) wrote : glxinfo.txt
ruegi (ruegi-k) wrote : xkbcomp.txt
Bryce Harrington (bryce) on 2010-02-09
description: updated

Is there any chance there will be a fix in time for lucid? Otherwise it will be critical considering the disabling of UMS in “xserver-xorg-video-intel” 2:2.9.1-1ubuntu4 *

* from the changelog here https://launchpad.net/ubuntu/lucid/+source/xserver-xorg-video-intel/2:2.9.1-1ubuntu4

Geir Ove Myhr (gomyhr) on 2010-02-16
description: updated
Bryce Harrington (bryce) on 2010-02-23
summary: - [i855] No Xv support for 82852/855GM (KMS bug)
+ [i855] (Needs 2.6.33 drm) No Xv support for 82852/855GM (KMS bug)
summary: - [i855] (Needs 2.6.33 drm) No Xv support for 82852/855GM (KMS bug)
+ [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for 82852/855GM
+ (KMS bug)
Changed in ubuntu-release-notes:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

alway no xv support for 82855/855GM with the alpha 3 of lucid and driver xserver-xorg-intel 2.9.1-1ubuntu6

Bryce Harrington (bryce) on 2010-03-02
summary: - [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for 82852/855GM
- (KMS bug)
+ [i855] [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for
+ 82852/855GM (KMS bug)
Bryce Harrington (bryce) on 2010-03-02
summary: - [i855] [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for
- 82852/855GM (KMS bug)
+ [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for 82852/855GM
+ (KMS bug)
Søren Holm (sgh) wrote :

I have Xv running fine here. But only in a single monitor configuration. As soon as I add a second monitor Xv stops working. It works again when going back to a single monitor though. My lspci looks like this.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 12)
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
08:03.0 CardBus bridge: O2 Micro, Inc. OZ711MP1/MS1 MemoryCardBus Controller (rev 21)
08:03.1 CardBus bridge: O2 Micro, Inc. OZ711MP1/MS1 MemoryCardBus Controller (rev 21)
08:03.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 01)
08:03.3 Bridge: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
08:03.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)

Robert Hooker (sarvatt) wrote :

We have kernel support now as of 2.6.32-16 with the .33 kernel drm backported. xserver-xorg-video-intel 2.10 is the last requirement.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
summary: - [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for 82852/855GM
- (KMS bug)
+ [i855] (Needs intel 2.10) No Xv support for 82852/855GM (KMS bug)

Will 2.10 be in Lucid?

On Sun, Mar 14, 2010 at 5:41 PM, Robert Hooker <email address hidden> wrote:

> We have kernel support now as of 2.6.32-16 with the .33 kernel drm
> backported. xserver-xorg-video-intel 2.10 is the last requirement.
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Fix Released
>
> ** Summary changed:
>
> - [i855] (Needs 2.6.33 drm and -intel 2.10) No Xv support for 82852/855GM
> (KMS bug)
> + [i855] (Needs intel 2.10) No Xv support for 82852/855GM (KMS bug)
>
> --
> [i855] (Needs intel 2.10) No Xv support for 82852/855GM (KMS bug)
> https://bugs.launchpad.net/bugs/395932
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in X.org xf86-video-intel: Fix Released
> Status in “linux” package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After upgrading to Karmic (alpha) my graphics driver is unable to provide
> Xv. The following line is printed in Xorg.0.log:
>
> (WW) intel(0): Disabling Xv because no adaptors could be initialized.
>
> I've tried various settings in xorg.conf, with no luck. (XvPreferOverlay,
> Tiling).
>
> [Update]
>
> >From the Q4 anouncment [1]:
> Video overlay support with KMS is now supported in xserver-xorg-video-intel
> 2.10.0. This currently requires Linux 2.6.33, but a backport to 2.6.32
> (Lucid version) is available from [2]. Daniel Vetter intends to support
> this backport which is intended for distros that use kernel 2.6.32 [3].
> Although the main code is in the kernel, intel driver 2.10.0 is apparently
> required [4].
>
> [1]: http://intellinuxgraphics.org/2009Q4.html
> [2]:
> http://gitorious.org/daniel-s-linux-stuff/linux-kernel/commits/intel-kms-overlay-for-2.6.32
> [3]:
> http://lists.freedesktop.org/archives/intel-gfx/2010-January/005372.html
> [4]: https://bugs.freedesktop.org/show_bug.cgi?id=20901#c42
>
> [lspci]
> 00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
> to I/O Controller (rev 02)
> Subsystem: Acer Incorporated [ALI] Device 0035
> 00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
> Graphics Device (rev 02)
> Subsystem: Acer Incorporated [ALI] Device 0035
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/395932/+subscribe
>

Robert Hooker (sarvatt) wrote :

Unfortunately it looks like 2.9.1 will be the final lucid version due to 2.10 only supporting kernel modesetting. 2.10 will be available in a PPA though, and it is available along with the rest of the X/Mesa stacks already in https://launchpad.net/~xorg-edgers/+archive/ppa

Bryce Harrington (bryce) on 2010-03-23
Changed in xserver-xorg-video-intel (Ubuntu Lucid):
assignee: nobody → Bryce Harrington (bryceharrington)
Bryce Harrington (bryce) wrote :

Well, there was a set of discrete Xv fixes which went in after 2.9.0 was cut but before the massive refactoring work for removing UMS hit. It comprised 17 patches total, which I've unified into the patch attached here.

$ diffstat debian/patches/102_xv-fix-8xx-video.patch
 drmmode_display.c | 9
 i830.h | 3
 i830_driver.c | 2
 i830_video.c | 1513 +++++++++++++++++++++++++-----------------------------
 i830_video.h | 20
 i915_video.c | 33 -
 i965_video.c | 48 -
 7 files changed, 755 insertions(+), 873 deletions(-)

This is mostly confined to the i8xx code, but there are some changes to the 9xx video code, which alter the algorithmic logic, so I can't say with 100% certainty that the changes are going to be regression-free for 9xx, which makes me reticent to pull this in for Lucid. There is also a lot of refactoring going on, which probably accounts for most of the size of the patch, and unfortunately also makes it tough to review in detail.

But... Since this backport was pretty straightforward, I've gone ahead and packaged and set up a PPA of this here:
https://edge.launchpad.net/~bryceharrington/+archive/white

If 8xx users can test this and say that it gives a perfect fix to Xv support (i.e. no secondary issues), AND we can get some 9xx users to verify it causes no regressions, then we can look at including this in Lucid. Otherwise, 8xx users can use this ppa or

daniel (bocardo+u) wrote :

I own a 855 laptop (an inspiron 700m) and can get ahold of a 950 one (a msi wind u100).
If you could give me a set of test to run, I'll test it and report back on both counts.

Søren Holm (sgh) wrote :

Hi pc contains this.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Xv works fine here, even with the current 2.9-driver

BUT whenre running a dual-screen configuration is does not work with any driver. Is that a separate issue?

Download full text (4.2 KiB)

Thank you for this patch but with my i855GM the messages :
"(==) intel(0): Intel XvMC decoder disabled
(WW) intel(0): Disabling Xv because no adaptors could be initialized."
are alway present.
for replace the driver of lucid, I open synaptic and i force the version
with the version of the ppa and I log out the session.
I do this with a live cd of lucid (daily of 26 march).
is what I have done well?
sorry for my english

2010/3/25 Bryce Harrington <email address hidden>

> Well, there was a set of discrete Xv fixes which went in after 2.9.0 was
> cut but before the massive refactoring work for removing UMS hit. It
> comprised 17 patches total, which I've unified into the patch attached
> here.
>
> $ diffstat debian/patches/102_xv-fix-8xx-video.patch
> drmmode_display.c | 9
> i830.h | 3
> i830_driver.c | 2
> i830_video.c | 1513
> +++++++++++++++++++++++++-----------------------------
> i830_video.h | 20
> i915_video.c | 33 -
> i965_video.c | 48 -
> 7 files changed, 755 insertions(+), 873 deletions(-)
>
> This is mostly confined to the i8xx code, but there are some changes to
> the 9xx video code, which alter the algorithmic logic, so I can't say
> with 100% certainty that the changes are going to be regression-free for
> 9xx, which makes me reticent to pull this in for Lucid. There is also a
> lot of refactoring going on, which probably accounts for most of the
> size of the patch, and unfortunately also makes it tough to review in
> detail.
>
> But... Since this backport was pretty straightforward, I've gone ahead and
> packaged and set up a PPA of this here:
> https://edge.launchpad.net/~bryceharrington/+archive/white<https://edge.launchpad.net/%7Ebryceharrington/+archive/white>
>
> If 8xx users can test this and say that it gives a perfect fix to Xv
> support (i.e. no secondary issues), AND we can get some 9xx users to
> verify it causes no regressions, then we can look at including this in
> Lucid. Otherwise, 8xx users can use this ppa or
>
> ** Patch added: "102_xv-fix-8xx-video.patch"
> http://launchpadlibrarian.net/42006303/102_xv-fix-8xx-video.patch
>
> --
> [i855] (Needs intel 2.10) No Xv support for 82852/855GM (KMS bug)
> https://bugs.launchpad.net/bugs/395932
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in X.org xf86-video-intel: Fix Released
> Status in “linux” package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
> Status in “linux” source package in Lucid: Fix Released
> Status in “xserver-xorg-video-intel” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After upgrading to Karmic (alpha) my graphics driver is unable to provide
> Xv. The following line is printed in Xorg.0.log:
>
> (WW) intel(0): Disabling Xv because no adaptors could be initialized.
>
> I've tried various settings in xorg.conf, with no luck. (XvPreferOverlay,
> Tiling).
>
> [Update]
>
> >From the Q4 anouncment [1]:
> Video overlay support with KMS is now supported in xserver-xorg-video-int...

Read more...

Mervin Beng (mervinb) wrote :

Bryce, I have been testing xorg-edgers PPA on an MSI Wind (i945), and I noticed that XvMC was disabled even though the XV and XVMC modules were loaded. This was with intel 2.10 and the 2.9 with patch from your PPA. Kernels tested were 2.6.32 with backports, and 2.6.33.

The Xorg.0.log shows the extensions loaded, but XvMC module appears disabled by default.

$ grep -i Xv /var/log/Xorg.0.log
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(==) intel(0): Intel XvMC decoder disabled

Is there some setting for XvMC that I have missed out?

$ lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

Thanks!

Robert Hooker (sarvatt) wrote :

Xv and XvMC are not the same things, KMS Xv overlay support is the only thing backported. To use XvMC with xorg-edgers you need to enable it in your xorg.conf like so because it is disabled by default (and is not applicable to 8xx series)

Section "Device"
        Identifier "intel"
        Driver "intel"
        Option "XvMC" "true"
EndSection

if you run man intel in a terminal you will see all of the options.

Robert Hooker (sarvatt) wrote :

braseb: try enabling the driver, then going to system - preferences - keyboard, pick layouts, then options, and enable the "key sequence to kill the X server" option, and finally press control+alt+backspace

braseb (braseb37) wrote :

Thank you Robert Hooker for your help but the issue is same the message is
alway present in xorg.0.log but with the 2.10.9xx the problem is resolved.

2010/3/29 Robert Hooker <email address hidden>

> braseb: try enabling the driver, then going to system - preferences -
> keyboard, pick layouts, then options, and enable the "key sequence to
> kill the X server" option, and finally press control+alt+backspace
>
> --
> [i855] (Needs intel 2.10) No Xv support for 82852/855GM (KMS bug)
> https://bugs.launchpad.net/bugs/395932
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in X.org xf86-video-intel: Fix Released
> Status in “linux” package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
> Status in “linux” source package in Lucid: Fix Released
> Status in “xserver-xorg-video-intel” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After upgrading to Karmic (alpha) my graphics driver is unable to provide
> Xv. The following line is printed in Xorg.0.log:
>
> (WW) intel(0): Disabling Xv because no adaptors could be initialized.
>
> I've tried various settings in xorg.conf, with no luck. (XvPreferOverlay,
> Tiling).
>
> [Update]
>
> >From the Q4 anouncment [1]:
> Video overlay support with KMS is now supported in xserver-xorg-video-intel
> 2.10.0. This currently requires Linux 2.6.33, but a backport to 2.6.32
> (Lucid version) is available from [2]. Daniel Vetter intends to support
> this backport which is intended for distros that use kernel 2.6.32 [3].
> Although the main code is in the kernel, intel driver 2.10.0 is apparently
> required [4].
>
> [1]: http://intellinuxgraphics.org/2009Q4.html
> [2]:
> http://gitorious.org/daniel-s-linux-stuff/linux-kernel/commits/intel-kms-overlay-for-2.6.32
> [3]:
> http://lists.freedesktop.org/archives/intel-gfx/2010-January/005372.html
> [4]: https://bugs.freedesktop.org/show_bug.cgi?id=20901#c42
>
> [lspci]
> 00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
> to I/O Controller (rev 02)
> Subsystem: Acer Incorporated [ALI] Device 0035
> 00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
> Graphics Device (rev 02)
> Subsystem: Acer Incorporated [ALI] Device 0035
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/395932/+subscribe
>

Mervin Beng (mervinb) wrote :

Thanks for the pointer Robert!

Götz Christ (g-christ) wrote :

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

With xserver-xorg-video-intel 2:2.9.1-1ubuntu17~bug395932~1 I still get the same message: (WW) intel(0): Disabling Xv because no adaptors could be initialized. Isn't some other update necesary?

Haven't tested with 2.10, I don''t know where to get a deb package for it.

With version 2.10.903+git20100327.df3b2684-0ubuntu0sarvatt Xv works but with the blue background when a window is in front of the video. I get also many Xserver restarts with that driver. For example opening kdiff3 make xserver crash. I haven't used all the xorg edgers repo packages, only the intel video driver.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.9.1-3ubuntu1

---------------
xserver-xorg-video-intel (2:2.9.1-3ubuntu1) lucid; urgency=low

  * Merge with Debian.
    - Backport KMS video overlay from upstream 2.10 (lp: #395932)
  * Remaining Ubuntu changes:
    - debian/apport-gpu-error-intel.py, debian/xserver-xorg-video-intel.udev:
      Add apport script to collect debug information on GPU hangs
    - rules: Install udev rule to run the script when the kernel detects hung GPU
    - control: Add intel-gpu-tools to Recommends for use by the above
    - 101_copy-fb.patch: Adds feature to driver so Xserver can draw
      root windows with no background. This enables smooth boot with
      Plymouth.
    - Drop xserver-xorg-video-intel-dbg.install: intel_reg_dumper is now
      provided by the intel-gpu-tools package.
    - apport-gpu-error-intel.py, xserver-xorg-video-intel.install,
      xserver-xorg-video-intel.udev: Add apport hook to catch X freeze bugs
    - 102_avoid_flushing_null.patch: Cherrypick from upstream to I830.
    - 103_check_for_overflow.patch: Cherrypick from upstream to I915.
    - 104_fail_when_prop_values_gone.patch: Cherrypick from upstream to
      drmmode_display.
  * Reduce libdrm-dev requirement to 2.6.18
  * Add 105_free_after_printing.patch: Cherrypick from upstream.
    Avoid printing a just-freed string if the DRM device could not be opened.
  * Add 106_initialize_drmmode_output.patch: Cherrypick from upstream.
    Clear mode_output during output destroy.
 -- Bryce Harrington <email address hidden> Wed, 31 Mar 2010 14:36:51 -0700

Changed in xserver-xorg-video-intel (Ubuntu Lucid):
status: Triaged → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Pedro Saraiva

Pedro Saraiva
Analyst / Programmer at Maisis - Information Systems, Lda.
Portugal

Confirm that you know Pedro Saraiva
https://www.linkedin.com/e/isd/1283606579/haMwGvir/

------
(c) 2010, LinkedIn Corporation

Changed in xserver-xorg-video-intel:
importance: Unknown → Wishlist
Changed in xserver-xorg-video-intel:
importance: Wishlist → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Wishlist
Displaying first 40 and last 40 comments. View all 228 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.