No video on resume from supend

Bug #395417 reported by koyakun
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Initiate suspend through GNOME GUI.
System suspends.
No video (blank screen) after resuming (by pressing power button).
Ctrl-Alt-F1 & Ctrl-Alt-F7 have no effect.
Hard reboot is required.
Had same problem on Dell Inspiron 9400.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=cc10a039-b236-45f3-8bef-f5fcfd2cfe90
MachineType: Dell Inc. Studio 1555
NonfreeKernelModules: fglrx
Package: linux-image-2.6.28-13-generic 2.6.28-13.45
ProcCmdLine: root=UUID=41d9c0fb-eab1-47e0-b660-5e7ef24dbbec ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-13.45-generic
SourcePackage: linux

Revision history for this message
koyakun (koyakun) wrote :
Revision history for this message
Alex Watson (alexfromapex) wrote :

I can confirm this on a Dell Studio 1535 with i386 architecture. I am running the 2.6.28-11-generic kernel on 32-bit Jaunty.

I have the Intel video card:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Please let me know what info I need to paste here.

Revision history for this message
Alex Watson (alexfromapex) wrote :

Okay two things I posted above are wrong. I am running an 1686 architecture and my computer is a 1555 also.

Revision history for this message
John Ferlito (johnf-inodes) wrote :

I'm seeing the same issue. Is there anything I can provide to help debug this?

koyakun (koyakun)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Andrew Chadwick (achadwick) wrote :

Video works fine for me after both hibernate and suspend on a Studio 1555 with the Intel graphics chipset: my hardware/configuration rundown is http://launchpadlibrarian.net/30055878/lspci2.txt . I'll do a compare/contrast with the other stuff when I have access later today.

tags: added: hibernate resume suspend
Revision history for this message
koyakun (koyakun) wrote :

There is still no video after suspend for me. Since Andrew Chadwick has an Intel graphics card and does not have problems, perhaps the ATI card is the culprit. What graphics cards do other users with the same problem have?

Revision history for this message
koyakun (koyakun) wrote :

I spoke too soon, I see that Alex Watson has the Intel graphics card as well, but has the same problem. Andrew, are you running 64-bit or 32?

Revision history for this message
Will Briggs (will-briggs) wrote :

Methinks this is fglrx. I have mildly different results if I update to xorg-driver-fglrx_8.632-0ubuntu1_amd64 using the instructions here: http://www.donotargue.com/page.php?id=1537

In that case after suspend it resumes to a screen that's turned on at least - you can see a mouse cursor - but everything is hanging. You can't even Alt-Ctrl-F1 to get a tty login.

I haven't tried hibernate yet.

Setup is as per OP (with fglrx). And in the interests of full disclosure I have "noapic" kernel option (which fixes other problems such as screen dimming buttons and eject button).

Revision history for this message
Will Briggs (will-briggs) wrote :

I take it back. I have tried suspend using the xorg-xserver-radeonhd 1.2.4-2 driver and suspend came back with a blank screen and then garbled graphics after Alt-Ctrl-f7

There is an ACPI warning on boot ACPI: EC: input buffer is not empty, aborting transaction - could that be related?

Revision history for this message
Nicholas Skehin (nicholas-skehin) wrote :

I also get this, I don't think it's X driver related though - I've tried suspending/resuming in single user recovery mode and I still don't get any video output. I also tried the debugging instructions on the wiki for tracing suspend and ended up with this:

[ 3.968296] Magic number: 0:81:363
[ 3.968373] hash matches /build/buildd/linux-2.6.28/drivers/base/power/main.c:390

Not really too sure what that indicates.

Will: You can fix the multimedia buttons/ACPI related stuff using a kernel patch on the forums without using that option; I've heard it does bad things with power management if you turn it on

Revision history for this message
ir0nman (iornman) wrote :

Has anyone been working on this? If not is there something one of us can do to help, I'm sure that any one of us would be willing to help since there is little use for a laptop that doesn't suspend/hibernate. Has anyone tried in Karmac yet? Is there an improvement?

Thanks,
-Rick

Revision history for this message
Renato Golin (rengolin) wrote :

I'm having this too, but I have more information on the matter.

The 1555 graphic card is ATI 4500 series. When I installed the 32-bit version on it, the suspend worked out of the box, but not with the 64-bit version. As I have 4GB of RAM, there is no way I'll use the 32-bit version.

The black-screen problem happens with both free and proprietary drivers.

I'm having other problems (xinerama, multi screen) with the proprietary drivers as well, but that's a completely different matter entirely. ;) I wish it was NVidia... :(

I've set "noapic" on the kernel line, in Grub, and after that brightness works but the lid doesn't. Oh dear... :(

Let me know what information you need me to gather.

Revision history for this message
xrado (radovan-lozej) wrote :

same here 32-bit works, 64-bit don't (Dell 1555)
running latest karmic with opensource drivers from git

my bug report https://bugs.launchpad.net/ubuntu/+source/linux/+bug/448000

Revision history for this message
Renato Golin (rengolin) wrote :

Just tested with the new kernel, same issue.

2.6.28-16-generic #55-Ubuntu SMP Tue Oct 20 19:48:32 UTC 2009 x86_64 GNU/Linux

Revision history for this message
Renato Golin (rengolin) wrote :

My syslog at the time it happens.

21:14:08 - suspended
21:14:30 - last attempt to resurrect
21:15:10 - forced shutdown
21:15:30 - restart with dmesg output

I guess you can figure out the hardware I have from the final part...

Revision history for this message
Renato Golin (rengolin) wrote :

Just tested with Karmic Koala and worked out-of-the-box.

Revision history for this message
Renato Golin (rengolin) wrote :

Kernel option noapic to solve bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/392812 still doesn't spoil suspend.

Now, everything is working perfectly on my new laptop, thanks for the hard work!!

Revision history for this message
koyakun (koyakun) wrote :

In Kosmic 9.10, as far as I can tell, I am able to resume from suspend and perform normal functions. For some reason, however, a crash report is created each time. Looks like many others are having the same issue: Bug# 417842: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/417842

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
daveStyle (davestyle) wrote :

I have the same on Dell Studio 1537

Linux Argon 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers