Microphone doesn't work on dell mini 10v

Bug #394793 reported by spenco on 2009-07-02
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned

Bug Description

SRU Justification:

Impact: Microphone does not work under Jaunty for the Dell Mini 10V netbook.

Fix: Backported patch (from 2.6.30) that addes the proper ALC272 codec quirk to enable to internal microphone.

Testcase: After booting with the patch applied, sound can be recorded and played back using sound recorder.

---

Binary package hint: alsa-utils

I have installed 9.04 netbook remix on my dell mini 10v.

Since then the microphone hasn't worked. I can find lots of forums discussing this, but no solutions.

This document suggests that there is a problem, but I can't find a solution any where.

https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Dell%20Mini%2010v

A bug, or am I being dumb? I'm a linux novice, but no one else seems willing to raise a bug for this, so here I am!

Michael Frey (mfrey) wrote :

I just submitted a patch to the kernel team asking for an SRU to jaunty. The attached patch fixes the microphone.

Stefan Bader (smb) wrote :

That bug was fixed in the 2.6.30 timeframe.

affects: alsa-utils (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
status: In Progress → Fix Released
Stefan Bader (smb) wrote :

Fix has been committed to the main Jaunty repo.

Changed in linux (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Fix Committed
description: updated

Excellent! Thanks for doing this.

How do I get the patch? or will I get it with the automatic updates?

On Thu, 16 Jul 2009 08:23 +0000, "Stefan Bader"
<email address hidden> wrote:
> Fix has been committed to the main Jaunty repo.
>
> ** Changed in: linux (Ubuntu Jaunty)
> Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu Jaunty)
> Status: New => Fix Committed
>
> ** Description changed:
>
> + SRU Justification:
> +
> + Impact: Microphone does not work under Jaunty for the Dell Mini 10V
> + netbook.
> +
> + Fix: Backported patch (from 2.6.30) that addes the proper ALC272 codec
> + quirk to enable to internal microphone.
> +
> + Testcase: After booting with the patch applied, sound can be recorded
> + and played back using sound recorder.
> +
> + ---
> +
> +
> Binary package hint: alsa-utils
>
> I have installed 9.04 netbook remix on my dell mini 10v.
>
> Since then the microphone hasn't worked. I can find lots of forums
> discussing this, but no solutions.
>
> This document suggests that there is a problem, but I can't find a
> solution any where.
>
> https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Dell%20Mini%2010v
>
> A bug, or am I being dumb? I'm a linux novice, but no one else seems
> willing to raise a bug for this, so here I am!
>
> --
> Microphone doesn't work on dell mini 10v
> https://bugs.launchpad.net/bugs/394793
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Fix Released
> Status in linux in Ubuntu Jaunty: Fix Committed
>
> Bug description:
> SRU Justification:
>
> Impact: Microphone does not work under Jaunty for the Dell Mini 10V
> netbook.
>
> Fix: Backported patch (from 2.6.30) that addes the proper ALC272 codec
> quirk to enable to internal microphone.
>
> Testcase: After booting with the patch applied, sound can be recorded and
> played back using sound recorder.
>
> ---
>
>
> Binary package hint: alsa-utils
>
> I have installed 9.04 netbook remix on my dell mini 10v.
>
> Since then the microphone hasn't worked. I can find lots of forums
> discussing this, but no solutions.
>
> This document suggests that there is a problem, but I can't find a
> solution any where.
>
> https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Dell%20Mini%2010v
>
> A bug, or am I being dumb? I'm a linux novice, but no one else seems
> willing to raise a bug for this, so here I am!

--
http://www.fastmail.fm - mmm... Fastmail...

shclim (shclim) wrote :

Can anyone confirm if this patch has been included in the automatic updates yet? And if not how I might add the patch manually?

makeitwork (whysayso) wrote :

How do I get this patch installed on my machine?? Please help, this is the only nagging bit left to get my dell mini 10v working perfectly with Skype, etc!

Stratus (bakerterence) on 2009-08-17
Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Stratus (bakerterence) wrote :

I am also curious how to install this patch. Im going mad trying to fix this and my wifi card.
im a complete newbie to linux so could really use a hand how to install this

thanks

similarly. where can it be found?

Andre (ajx) wrote :

I guess from the status that the fix is so far only "commited", but not "released" for Jaunty yet. It will definitely be fixed in Karmic. I'm hoping for a quick release for Jaunty, too.

Martin Pitt (pitti) wrote :

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
rasto1968 (rob-a-stone) wrote :

Installed on our Mini 10V and the microphone now works. Thanks :)

Rob

Martin Pitt (pitti) on 2009-09-03
tags: added: verification-done
removed: verification-needed
Tom (t-gilissen) wrote :

The same here. After update, mic works fine. Thanks!

Tom

vahnx (fishfishstinks) wrote :

How do you apply the patch? This is what I get when I attempted:

patch -p1 < micpatch
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
|index a4422e5..db91cf8 100644
|--- a/sound/pci/hda/patch_realtek.c
|+++ b/sound/pci/hda/patch_realtek.c
--------------------------
File to patch:
Skip this patch? [y] n
File to patch: patch_realtek.c
patch_realtek.c: No such file or directory
Skip this patch? [y]

Stratus (bakerterence) wrote :

Hi Vahnx
I've installed the patch by going into the update manager and changing the options so that the manager will also detect proposed updates (its a lil checkbox)
Then just run the updater it should then find the update.
Sorry its not more detailed I'm on my windows PC at the moment so cannot write the precise names. Any more trouble post on here and I'll write something more detailed.
Thankyou to everyone who helped create/release the update
All working my end :) very happy

toogreen (toogreen-hotmail) wrote :

I can also confirm adding the "proposed" repositories and updating/upgrading did the trick, it now works great! Sincerely, thank you to all the developers working on this.

I am now wondering tho: Do I need to keep the proposed repositories enabled or can I tick them off now and keep the working/patched kernel? I guess so, but just making sure.

Dustin Kirkland  (kirkland) wrote :

jaunty-proposed kernel fix confirmed.

:-Dustin

makeitwork (whysayso) wrote :

It works!! It works!! Wooooohooo!

I can also confirm adding the "proposed" repositories and updating/upgrading did the trick, it now works great! Sincerely, thank you to all the developers working on this. This is the first time I get to see a bug getting reported and fixed, much better than the experience with windows

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-15.52

---------------
linux (2.6.28-15.52) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: ACPI: Populate DIDL before registering ACPI video device
    on Intel"
    - LP: #423296
  * SAUCE: Allow less restrictive acpi video detection
    - LP: #333386

  [ Upstream Kernel Changes ]

  * include drivers/pci/hotplug/* in -virtual package
    - LP: #364916
  * ext4: don't call jbd2_journal_force_commit_nested without journal
    - LP: #418197
  * ext4: fix ext4_free_inode() vs. ext4_claim_inode() race
    - LP: #418197
  * ext4: fix bogus BUG_ONs in in mballoc code
    - LP: #418197
  * ext4: fix typo which causes a memory leak on error path
    - LP: #418197
  * ext4: Fix softlockup caused by illegal i_file_acl value in on-disk
    inode
    - LP: #418197
  * ext4: Fix sub-block zeroing for writes into preallocated extents
    - LP: #418197
  * jbd2: Call journal commit callback without holding j_list_lock
    - LP: #418197
  * ext4: Print the find_group_flex() warning only once
    - LP: #367065
  * ext4: really print the find_group_flex fallback warning only once
    - LP: #367065

linux (2.6.28-15.51) jaunty-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: wireless: hostap, fix oops due to early probing interrupt
    - LP: #254837

  [ Leann Ogasawara ]

  * Add the atl1c driver to support Atheros AR8132
    - LP: #415358
  * Updating configs to enable the atl1c driver
    - LP: #415358

  [ Stefan Bader ]

  * Revert "SAUCE: input: Blacklist digitizers from joydev.c"
    - LP: #300143
  * SAUCE: Fix the exported name for e1000e-next
    - LP: #402890
  * SAUCE: Fix incorrect stable backport to bas_gigaset
    - LP: #417732
  * SAUCE: Remove the atl2 driver from the ubuntu subdirectory
    - LP: #419438

linux (2.6.28-15.50) jaunty-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: radio-maestro: fix panics on probe failure
    - LP: #357724
  * SAUCE: HDA Intel, sigmatel: Enable speakers on HP Mini 1000
    - LP: #318942

  [ Jerone Young ]

  * SAUCE: Fix Soltech TA12 volume hotkeys not sending key release in
    Jaunty
    - LP: #397499

  [ John Johansen ]

  * SAUCE: remove AppArmor debug check for calls from interrupt context
    - LP: #350789

  [ Manoj Iyer ]

  * SAUCE: Fix kernel panic when SELinux is enabled.
    - LP: #395219

  [ Matthew Garrett ]

  * SAUCE: ACPI: Populate DIDL before registering ACPI video device on
    Intel

  [ Michael Frey (Senior Manager, MID ]

  * SAUCE: Fix for internal microphone for Dell Mini10V
    - LP: #394793

  [ Tim Gardner ]

  * SAUCE: Added e1000e from sourceforge.
    - LP: #402890

  [ Upstream Kernel Changes ]

  * Input: synaptics - report multi-taps only if supported by the device
    - LP: #399787
  * ftdi_sio: fix kref leak
    - LP: #396930, #376128
  * IPv6: add "disable" module parameter support to ipv6.ko
    - LP: #351656

 -- Stefan Bader <email address hidden> Thu, 27 Aug 2009 15:09:06 +0200

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
Victor Vargas (kamus) wrote :

it's looks like this issue re appears again in Karmic according to bug 469346.

merc (merc) wrote :

Hi,

Yep the same bug is in Karmic... is anybody able to work on a port for karmic...?

Merc.

Roman Polach (rpolach) wrote :

Still (or again?) problem in jaunty - kernel 2.6.28.18.59,
please reopen!

Roman Polach (rpolach) wrote :

Sorry I was wrong - 2.6.28.18.59 is ok,
it only needs to switch mic on in settings.

Changed in linux (Ubuntu):
assignee: nobody → Talalkhoury85 (talalkhoury85)
Changed in linux (Ubuntu Jaunty):
status: Fix Released → In Progress
Steve Langasek (vorlon) on 2010-03-02
Changed in linux (Ubuntu Jaunty):
status: In Progress → Fix Released
Changed in linux (Ubuntu):
assignee: Talalkhoury85 (talalkhoury85) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers