[i855] Resolution change breaks graphics in Intel 855GM

Bug #393031 reported by Benedikt Kristinsson on 2009-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

When i try to change the resolution on intel 855GM it breaks. If I try to change it, everything gets blurry, the image itself shrinks but if i move the mouse to the right upper corner and click, it happens in the right upper corner in the shrunken image.

The same thing happens when i try to rotate the sceen with xrandr. I have attached a screenshot of this.

Note that this only happens on an external monitor connected through VGA.

If i plug in the screen with a running X Session and start up the display applet, and move the session to the VGA display, the same thing happens. This did not happen in intrepid.

I have rolled back xserver-xorg-video-intel to 2.4 (interpid version) but no change. The graphic performance increased but this problem stayed.

Geir Ove Myhr (gomyhr) wrote :

Thank you for reporting this bug. Could you pleaser run `apport-collect 393031` to upload relevant xorg-related files to this bug report?

Bryce Harrington (bryce) on 2009-07-06
summary: - Resolution change breaks graphics in Intel 855GM
+ [i855] Resolution change breaks graphics in Intel 855GM

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel None
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersion: Linux version 2.6.28-13-generic (buildd@vernadsky) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #45-Ubuntu SMP Tue Jun 30 19:49:51 UTC 2009
Uname: Linux 2.6.28-13-generic i686
UserGroups:

Bryce Harrington (bryce) on 2009-07-13
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

New info. I tried reverting xserver-xorg-video-intel to 2.4 according to this wiki: https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4 and experienced minor enchaced performance.

I rolled those changes back, and tried another suggested method involding upagrading the kernel to 2.6.30 with the X Updates PPA repository and enabling UXA, all according to this form post (Optimal configuration, http://ubuntuforums.org/showthread.php?t=1130582) and i still only experince minor fixes. I can now play Flash fullscreen. The the resolution still brakes.

Bryce Harrington (bryce) on 2009-07-15
tags: added: jaunty
Bryce Harrington (bryce) wrote :

Well, next I'd like to forward this issue upstream, but first it must be retested on latest development version of Karmic to make sure the issue still happens there with the latest code. ISO images are available at http://cdimages.ubuntu.com/releases/karmic/. If you can reproduce it in the LiveCD environment, you shouldn't need to modify your installed system. Also please attach a fresh Xorg.0.log and dmesg from this testing.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

I could reproduce it with Karmic. Attached are Xorg.0.log and a screenshot.

The procedure was: boot karmic, disable laptop minotor with gnome-display-properties and enable 1600x1200 on VGA connected monitor. I also tried to boot with montor unplugged and plug it in. Unsurprisingly both yielded the same result.

Bryce Harrington (bryce) on 2009-07-16
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-07-16
tags: added: karmic
Geir Ove Myhr (gomyhr) on 2009-07-26
tags: added: 855gm
Bryce Harrington (bryce) wrote :

Hi Benedikt, I've forwarded your bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=22977 - please subscribe to this report in case upstream needs further information or wishes you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
yakuizhao (yakui-zhao) wrote :

Hi, Benedikt
     Will you please confirm whether the corruption happens on the LVdS or external monitor?
     Please attach the xorg.log with the modedebug option enabled in xorg.conf and vbios dump.
    Thanks.

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
Bryce Harrington (bryce) wrote :

Benedikt, that is good to hear the issue is resolved with xorg-edgers, however we may not be shipping that version in Karmic. Are you satisfied that this bug is fixed by updating to xorg-edgers, or would you also like to see it fixed in Karmic? If so, there are some additional steps I will need you to do in order to find what patch actually fixed the issue. (I have reviewed the changelog for -intel and did not spot an obvious entry that sounds like it fixed this issue.)

To start with, can you indicate what versions of packages from xorg-edgers that you installed? If you installed other packages besides xserver-xorg-video-intel, please revert each back to the stock Karmic version and isolate which package update(s) brought the fix for you.

If we don't hear from you, I'll assume the issue to be fixed if we do update the driver before Karmic is released.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

I have myself read the changelog and man pages and I have not found out why xorg-xedgers fixed this problem.

However, I would like to see this problem being fixed in Karmic since edgers is causing big problems for me. I am not sure what package from edgers is causing these problemes. X windows are very slow to render, best way to explain this is to imagine running Gnome on a old computer, ~400mhz/~128mb ram. Please note I have only tried edgers on Jaunty.

However I have seen edgers on a laptop with Intel 955, wich had problems with the shipped version of xserver-xorg-video-intel, and it worked beautifully.

I am on vacation right now, without access to my laptop, but I will be back in a few days and I'll fire up the newest alpha of Karmic and report back. I will also try to isolate what package is causing my slow X and see if it is -intel or some dependency for it.

Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid

Testing with Karmic Alpha 4

Boots up in dock (port replicator) with laptop screen blinking between green, blue
and red. Screen is connected to VGA through dock. Loading bar is shown, but with
strange artifacts. X loads with the wrong (1024x768) resolution instead of the right
(1600x1200) and laptop screen continues to flash the colors.

I disable the laptop screen with the display tool. After that, resolution change
to 1600x1200 works fine. Trying to move the display to the laptop screen with
the display applet results in the same color madness. Waiting 15 seconds makes
the applet switch back to the external monitor.

man intel shows xf86-video-intel 2.8.0. Shouldn't this be xorg?

Booting with the screen disconnected results in the color madness during boot.
X doesnt come up and the other tty's are inaccessible. Tried twice, waited for
~10 minues. Then plugged the laptop into the port replicator with the screen and
works like described before (color madness on laptop screen, loads on external
with artifacts). Est loading time 3-4 minutes.

This behavior is nothing like jaunty or alpha2 of karmic. Attached is the Xorg
log file for the successful boot.

Why did the manpage say xf86 at the bottom. The rest of the man page talks
about XOrg.

Changed in xserver-xorg-video-intel:
status: Invalid → Confirmed
Bryce Harrington (bryce) on 2009-09-04
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Bryce Harrington (bryce) wrote :

[Upstream has shipped a patch against the kernel to fix this issue, so I'm reassigning to the kernel team.]

Changed in xserver-xorg-video-intel:
status: Invalid → Unknown
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → New
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Jeremy Foshee (jeremyfoshee) wrote :

Hi Benedikt,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 393031

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.