[karmic] laptop overheats and shuts off -- fans at low speed

Bug #387620 reported by Asif Youssuff on 2009-06-16
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Acer Aspire 4530.

This started after I started using the Karmic alpha -- the Jaunty alphas and betas were fine for me -- so it may be a regression.

Attaching various files, hopefully they can help track down the issue.

ProblemType: Bug
Architecture: i386
Date: Tue Jun 16 00:10:18 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=7e952a90-7f16-4f75-a2c3-ae8d6a7011d9
MachineType: Acer, inc. Aspire 4530
NonfreeKernelModules: nvidia
Package: linux-image-2.6.30-9-generic 2.6.30-9.10
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.30-9-generic root=UUID=581f131b-5c8b-4036-991f-396605f85828 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
RelatedPackageVersions: linux-backports-modules-2.6.30-9-generic N/A
SourcePackage: linux
Uname: Linux 2.6.30-9-generic i686
dmi.bios.date: 09/18/2008
dmi.bios.vendor: Acer
dmi.bios.version: v1.3334
dmi.board.name: Grasmoor
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3334:bd09/18/2008:svnAcer,inc.:pnAspire4530:pvrNotApplicable:rvnAcer,Inc.:rnGrasmoor:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 4530
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :

cat /proc/acpi/thermal_zone/THRM/trip_points
critical (S5): 105 C
passive: 99 C: tc1=2 tc2=3 tsp=40 devices=CPU0

cat /proc/acpi/thermal_zone/THRM/cooling_mode
<setting not supported>

cat /proc/acpi/thermal_zone/THRM/polling_frequency
<polling disabled>

cat /proc/acpi/thermal_zone/THRM/state
state: ok

My hardware supports throttling, but it doesn't seem to be enabled -- although when checking /proc/cpuinfo, I see the cpu speed change.

Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :

This is still an issue on Linux ubuntu-asif 2.6.31-3-generic #18-Ubuntu SMP Tue Jul 14 04:13:09 UTC 2009 x86_64 GNU/Linux.

Any ideas on helping find a fix would be very helpful -- this is extremely annoying behavior!

Asif Youssuff (yoasif) wrote :

Is this related to #370173 ?

Asif Youssuff (yoasif) wrote :

Talked to ogasawara -- she says it "sounds like" 370173 and 396718.

Will try the mainline kernel builds:

https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

and also will try to install Jaunty final to see if the issue was present there.

Hi yoasif,

As you mentioned, this looks like it might be a dup of bug 370173. And as I mentioned in IRC, I'd also maybe take a look at bug 396718. For now lets keep this bug separate but I'd encourage you to subscribe to those other bugs as well. We can mark this as a duplicate later on if necessary. Thanks.

Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
Asif Youssuff (yoasif) wrote :

I ran:

stress --cpu 16 --vm 2 --vm-bytes 128M

and the machine cut off after about two minutes.

This was on the mainline linux kernel:

2.6.31-020631rc3-generic #020631rc3 SMP Tue Jul 14 09:06:10 UTC 2009 x86_64 GNU/Linux

attaching

    sudo acpidump -o acpidump.txt
    sudo dmidecode >dmidecode.txt

Asif Youssuff (yoasif) wrote :
Simo L (mohlam12) on 2009-09-28
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Jeff (jeffxmora) wrote :

Same situation on Acer 5720z, after 20-30 minutes system crashdown. this never happenend with Jaunty or Intrepid

alex (alex-2048) on 2009-12-01
Changed in linux (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → In Progress
Asif Youssuff (yoasif) wrote :

Just wanted to note that I am running the latest Lucid kernel Linux ubuntu-asif 2.6.32-9-generic #13-Ubuntu -- and I am still seeing this issue when playing high res videos in totem, or carrying on high cpu loads for periods longer than say 15 minutes.

Flávio Etrusco (etrusco) wrote :

I'm having a similar problem on "generic" notebook with a Pegatron motherboard. The notebook/motherboard seems similar to the BenQ Joybook S57.
The fan works on the Mandriva 2009.0 that came installed with it and (!) with linuX-games-live 0.9.4. Booting Ubuntu with acpi=off seems to keep the fan on/reasonably fast for some time.
Any files I could post from these system which could be useful for comparison?
One thing I noticed is that Mandriva show lower temperatures _and_ trip points.
Right after a cold boot:

Mandriva:
coretemp-isa-0000
Core 0: +33°C (high = +85°C)
coretemp-isa-0001
Core 1: +32°C (high = +85°C)

Ubuntu, something like(had to erase the instalation, and also lost the saved log :-/ ):
thermal
Virtual: +70ºC (high=90ºC, critical=90ºC)
coretemp-isa-0000
Core 0: +67ºC (high=90ºC, critical=90ºC)
coretemp-isa-0001
Core 1: +64ºC (high=90ºC, critical=90ºC)

Flávio Etrusco (etrusco) wrote :

Asif: I see no reason to believe Ubuntu isn't using throtling in you system. What's not using however is the option to override trip_points - that's the reason for the <setting not supported> and <polling disabled> results in thermal zone. I've learnt that unfortunately the option to override trip points were removed from the kernel because it was unsafe (the cpu had to poll the temperate and in the event of a failure you could fry it...).

cosimix (cosimix) wrote :

Same problem with an Acer Aspire 5000, Turion 64 Processor (shit), 2 GB RAM.

I cannot watch at a streaming video for more than 3 minutes than the computer crashes down for overheating.

Now, overheating was always a problem of this computer, but seems to be has been exasperate by Xubuntu 9.10

Harel Malka (harel-harelmalka) wrote :

I see a similar problem on my Thinkpad T61p. It keeps shutting down due to extreme heat.
However, come to think about it - I don't hear the fan kicking in recently.
All this started since I upgraded to 9.10. Never was an issue before that.

Sanal Krishnan (santechz) wrote :

HP Laptop DV5200 TX. currently running Lucid Lynx (10.04) Beta
Auto shutdowns when viewing Flash heavy sites

Is there anyway to ensure that fan can cool the processor, or throttle the processor to reduce auto shutdowns???

Problem since Ubuntu 9.04

sanal@sanal-laptop:~$ cd /proc/acpi/fan/
sanal@sanal-laptop:/proc/acpi/fan$ ls
sanal@sanal-laptop:/proc/acpi/fan$

sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ01/trip_points
critical (S5): 85 C
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ01/temperature
temperature: 55 C
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ01/state
state: ok
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ01/polling_frequency
<polling disabled>
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ01/cooling_mode
<setting not supported>
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ02/trip_points
critical (S5): 105 C
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ02/temperature
temperature: 27 C
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ02/state
state: ok
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ02/polling_frequency
<polling disabled>
sanal@sanal-laptop:~$ cat /proc/acpi/thermal_zone/TZ02/cooling_mode
<setting not supported>

Flávio Etrusco (etrusco) wrote :

Weird that one thing is that is mentioned in several similar/related problems and is not mentioned here (and worked for me): use kernel boot parameters "acpi.power_nocheck=1 acpi_osi=linux".
Several previous kernels (from 1~2 years ago) don't have this problem in my notebook, so yes, it's a regression to me.
Sanal: you can control the throttling either with "CPUfrequency scaling monitor" panel applet or in the terminal (google for it), but I don't think it'll alleviate your problem just a little bit. I suggest you try the kernel parameters above.

Hi Flavio,
I used the kernel parameter you suggested, and now its allowing me to view
flash heavy sites for a bit longer. But it still shuts down after 10 mins. I
can hear the fan really loud on sites like youtube.
I installed lmsensors,and through the applet on the panel I can see the
temperature rise to ~79 C while viewing youtube. and then it goes to
80...and then later initiates a shutdown !!!
I tried throttlling the cpu with the cpu scaling applet, but even
this doesn't help. May be I should open up the laptop and clean it out. Dust
on the fan is one issue i read about.

Thanks for the help!

Sanal Krishnan

2010/4/1 Flávio Etrusco <email address hidden>

> Weird that one thing is that is mentioned in several similar/related
> problems and is not mentioned here (and worked for me): use kernel boot
> parameters "acpi.power_nocheck=1 acpi_osi=linux".
> Several previous kernels (from 1~2 years ago) don't have this problem in my
> notebook, so yes, it's a regression to me.
> Sanal: you can control the throttling either with "CPUfrequency scaling
> monitor" panel applet or in the terminal (google for it), but I don't think
> it'll alleviate your problem just a little bit. I suggest you try the kernel
> parameters above.
>
> --
> [karmic] laptop overheats and shuts off -- fans at low speed
> https://bugs.launchpad.net/bugs/387620
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Regards,

Sanal Krishnan

Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
status: In Progress → Triaged
assignee: Andy Whitcroft (apw) → nobody
Flavio Capobianco (norkov) wrote :

A similar thing is happening to me, on my Acer Aspire 5542, running Lucid:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/595335

I have the same problem with my Acer Aspire 5542 Ubuntu 10.10. The same problem with the open source driver as fglrx. I tried dynpm and various other profiles in /sys/class/drm/card0/device/power_method & /sys/class/drm/card0/device/power_profile.

The worst part is that I keep losing data after restarting!

I want to confirm that I still have this problem after a fresh 10.10 RC install.

Gary M (garym) on 2010-10-01
tags: added: karmic lucid maverick
tags: added: regression-release

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers