DQ45CB: DVI not working, reported as HDMI

Bug #386700 reported by Casandro on 2009-06-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Unknown
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

As you can seen on the automatically generated bug report, xrandr lists 3 outputs, one VGA which works perfectly, plus 2 HDMI outputs. This board however only has 2 DVI outputs. One is DVI-I which I use with a VGA adaptor. The other one is a DVI-D which was connected to another monitor with DVI-D input.

Only the analog output of the first DVI-output works, the rest doesn't seem to work. To be fair it might be a problem with my monitor as it neither works on the BIOS setup screens. The monitor is fairly old, but once worked with an old ATI card.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu9
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-11-generic x86_64
XorgConf:

Casandro (casandro-lion) wrote :
Bryce Harrington (bryce) on 2009-06-26
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Casandro (casandro-lion) wrote :

This is the xorg.0.log from the mentioned live CD. The bug is still present.

Bryce Harrington (bryce) wrote :

Thanks for testing

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Bryce Harrington (bryce) on 2009-07-10
tags: added: karmic
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

Hi Casandro, I've reported your bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=22717 - please subscribe to this bug report in case upstream needs further information or wishes you to test something. Thanks ahead of time.

Bryce Harrington (bryce) on 2009-07-14
Changed in xserver-xorg-video-intel:
status: Confirmed → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Geir Ove Myhr (gomyhr) on 2009-07-26
tags: added: jaunty q45
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

moving to the kernel, the fix is in drm-intel-next branch

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → New
tags: added: xorg-needs-kernel-patch

Marking this as a duplicate of bug 384660 as it seems they will be resolved by the same kernel patch. Please continue to track this issue at that report. Thanks.

tags: added: xorg-needs-kernel-fix
removed: xorg-needs-kernel-patch
Casandro (casandro-lion) wrote :

I think the duplicate status is wrong. The fix doesn't fix my problem, it only changes it. Now xrandr reports:
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 337mm x 270mm
   1280x1024 60.0*+ 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
DVI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DVI2 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)

Geir Ove Myhr (gomyhr) wrote :

Casandro, please report your findings to the upstream bug report, https://bugs.freedesktop.org/show_bug.cgi?id=22717 .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.