Computer won't boot without acpi=off option

Bug #386272 reported by Jerry on 2009-06-12
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

This is an old Motion Computing model M1300 which worked perfectly fine in Intrepid, but since Jaunty it hasn't been able to boot (either from the live CD or and installation) if the acpi=off is not specified. The newest Karmic Alpha 2 hasn't fixed this regression (I have only tried the live cd), and as I'm sure you understand, in a laptop/tablet pc living without acpi controls is not an option. I'll attach a picture of what the screen shows if I remove "quiet splash --" from the boot parameters at the point where the boot process halts.

Jerry (priegog) wrote :

This is what the screen shows when the boot process halts

rrwood (roy-wood) wrote :

Same problems here-- I have an M1300 which displays the same ACPI problems Jerry describes. Brightness control is broken, and I can't shut down via software (it eventually hangs during shutdown and I have to manual hit the power switch to shut down).

will (waterbucket) wrote :

I'm experiencing the same problem on a Motion Computing M1400. Boot halts unless acpi=off is used. These are the only legible screenshots extracted from a video recording of the boot.

Ken Baldwin (kenneth-baldwin) wrote :

I'm having the same problem with my M1300.

Gareth (gmccumskey) wrote :

I am having the same problem but I have a modern motherboard. If I turn ACPI off in BIOS or if I add the acpi=off boot parameter, I can boot Jaunty but without one of the two it freezes at startup.

My motherboard is a Biostar TP35D2-A7 with an Intel Core 2 Duo E4500. I have attached a CPU-Z report on my hardware specs if that helps.

Gareth (gmccumskey) wrote :

Pretty obvious this so thought I'd get it the right people

Changed in ubuntu:
assignee: nobody → Ubuntu Kernel ACPI Team (ubuntu-kernel-acpi)
tags: added: acpi
Rosty (rosty-pol) wrote :

Reproduced on Motion Computing m1400 on the same place without acpi=off.
Boots and runs OK with acpi=ht.

Andrew Keyes (akeyes) wrote :

Confirmed on the m1300 as well running Ubuntu 9.04.

Changed in ubuntu:
status: New → Confirmed
Gareth (gmccumskey) wrote :

I am also experiencing this issue on the HP EliteBook 8530p. Works fine in Intrepid but upgrade to Jaunty breaks ACPI compatibility.

Luke Faraone (lfaraone) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested at https://wiki.ubuntu.com/DebuggingACPI as separate attachments.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Luke Faraone (lfaraone) on 2009-10-08
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Gareth (gmccumskey) wrote :

Tested with all parameters as mentioned in the wiki page on the HP EliteBook 8530p as follows:

- acpi=off: boots but no acpi functions
- acpi=ht: boots and screen now dims when unplugged but no other acpi functions and battery not detected
- All other options did not work.

I am attaching the various files as mentioned except for tarball of /proc/acpi as that directory does not exist on my box

Gareth (gmccumskey) wrote :

Output of lspci command from wiki page for HP EliteBook 8530p

Gareth (gmccumskey) wrote :

Output of uname -a for HP EliteBook 8530p

Gareth (gmccumskey) wrote :

kern.log.0 after attempting a hibernate that failed to resume

John Dandison (jdandison) wrote :

I attempted to install 9.04 via Wubi on a Motion M1400. I too am seeing this error when the machine reboots into the ubuntu installation after the Windows portion completes. I can prevent the hang using acpi=off or acpi=ht, which leaves me with an installation with virtually no power management - no sleep, no hibernate, no battery, etc.

In verbose mode, the installation hangs at this point:
switched to high resolution mode on cpu 0

I'll post the required logs post-installation.

Luke Faraone (lfaraone) wrote :

Can you also confirm that this bug occurs in the mainline (unmodified
upstream) kernel? See https://wiki.ubuntu.com/KernelTeam/MainlineBuilds
for more information on how to test this out. If this issue still occurs
on that kernel, then it is also an upstream bug.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
tags: added: needs-upstream-testing
John Dandison (jdandison) wrote :

You'll have to forgive my ignorance, but if I ran the installer without ACPI support (acpi=ht), is there anyway I can install and run the mainline kernel with ACPI support to attempt to troubleshoot?

Thanks,

Luke Faraone (lfaraone) wrote :

Per https://help.ubuntu.com/community/BootOptions#Kernel%20Options, I'd suspect you would use "acpi=on" or "acpi=force".

Jerry (priegog) wrote :

I can confirm that the same problem persists with the mainline kernel (v2.6.32-rc5).

aldebarn (aldebarn42) wrote :

Same problem for me on an M1400 with the latest 9.10

Luke Faraone (lfaraone) on 2009-11-01
Changed in linux (Ubuntu):
status: Confirmed → Triaged
jawmoret (jawmoret) wrote :

I Found the same issue for me, currently running 9.10 x64 on a Toshiba sat Pro P200 just installed kernel 2.6.31.16.
computer will not boot, unless I add ACPI=off to the grub-loader.

cihanozgen (cihanozgen) wrote :

Same problem here. It was perfectly working in previous Ubuntu releases. Problem started after Karmic.
I can not even boot up machine without setting "acpi=off" in grub configuration

Short Info:
Hardware:
Toshiba X200-15K

uname -a
Linux pulsar 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 17:01:44 UTC 2009 x86_64 GNU/Linux

BIOS Information
 Vendor: TOSHIBA
 Version: V2.50
 Release Date: 06/11/2008
 Address: 0xE5650
 Runtime Size: 108976 bytes
 ROM Size: 64 kB
 Characteristics:
  ISA is supported
  PCI is supported
  PC Card (PCMCIA) is supported
  PNP is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  ESCD support is available
  Boot from CD is supported
  ACPI is supported
  USB legacy is supported
  AGP is supported
  BIOS boot specification is supported
  Targeted content distribution is supported
 BIOS Revision: 2.80
 Firmware Revision: 2.80

Motion M1400 here; does anyone have an idea when this was broken by upstream?

Andrew Keyes (akeyes) wrote :

Not sure about upstream, but I'm pretty sure it's been broken in Ubuntu since at least 9.04.

jlac (jlacvdr) wrote :

as you, I had this problem with previous version (9.04/9.10) but now with lucid lynx (10.04) this problem no longer occurs.

Andrew Keyes (akeyes) wrote :

jlac: Which system do you have? I've been unable to get 10.04 to boot at all on my M1300 (previous ones all booted, and still do after reinstalling).

jlac (jlacvdr) wrote :

sorry for missing this detail: I have a Motion Computing model M1400 (bios version A04)

tip: On lucid lynx/10.04 and intel motherboard, enable KMS (Kernel Mode Setting) helps Xorg to start. try to add i915.modeset=1 in grub

Andrew Keyes (akeyes) wrote :

After only a little hassle, I was able to boot the live cd using i915.modeset=1, install, adjust grub on boot to boot, and then add in i915.modeset=1 to grub permanently. It would be nice if it grabbed it automatically from the live cd boot settings, but that's for another bug.

acpi=off was not needed.

Side note to M1300 owners (and probably M1400 as well), the stylus worked out of the box after booting into the installed system.

Curtis Hovey (sinzui) on 2011-07-18
Changed in linux (Ubuntu):
assignee: Registry Administrators (registry) → nobody

Jerry, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Jerry (priegog) wrote :

Hi Christopher, I'm terribly sorry, but since this was posted I no longer own an M1300.
I do not know what the process for an active bug under these circumstances should be.
I hope some of these guys who had the same problem can perform the required tests for you.
Cheers.

Jerry, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/386272/comments/31 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu):
status: Invalid → Fix Committed

ubuntu (kees-van-barneveld), please do not adjust the Status of this report, as it is closed.

Changed in linux (Ubuntu):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments