libata: Jmicron eSATA/PATA controller error

Bug #377633 reported by Kor-Skarn on 2009-05-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The error is continually reported to my log for unattached SATA link:

[ 396.840962] ata2: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[ 396.840966] ata2: irq_stat 0x00000040, connection status changed
[ 396.840969] ata2: SError: { CommWake DevExch }
[ 396.840973] ata2: hard resetting link
[ 397.628026] ata2: SATA link down (SStatus 0 SControl 300)
[ 397.628033] ata2: EH complete

That renders some text modes (e.g. failsafe mode) and overfilled system log unusable.

I have ASUS P5KC motherboard, which has 4 regular SATA ports (with 3 drives on them that work fine) and extra SATA port for RAID setup (unused). It also has 1 PATA port for connecting CD/DVD drives. I tracked down that the extra SATA port is causing the error and apparently it is controlled by Jmicron eSATA/PATA controller, which also controls PATA devices. I disabled the Jmicron controller in BIOS and error disappeared, but I couldn't use my DVD drive - nor in Jaunty, nor in Windows XP - it wasn't detected. So I tried setting the controller to different modes in BIOS: IDE (default), AHCI and RAID; none helped.

I've stumbled on some posts relating it to NCQ and HotPlug support. NCQ on my drives (which work fine) is off. I also tried booting with kernel parameter libata.force=noncq to no avail.

So, can anyone help? Any advice on what I should try to make the error go away (and keep my DVD drive operational)? Is it bug in Jmicron firmware or Linux kernel / libsata?

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=8768e97b-03ee-44ab-9406-7e50b054812f
MachineType: System manufacturer P5KC
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
ProcCmdLine: root=UUID=32caef82-51c0-481d-a73c-dc043aadb0bc libata.force=noncq ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
SourcePackage: linux

Kor-Skarn (commonmail) wrote :
Kor-Skarn (commonmail) wrote :

Jmicron controller's signature in BIOS:

JMicron PCIE-to-SATAII/IDE RAID Controller BIOS v1.06.69

Kor-Skarn (commonmail) wrote :

Motherboard specification says:

JMicron JMB363 PATA and SATA controller

Giuseppe Pennisi (giupenni78) wrote :

I have your same JMicron controller and I have similar problems:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/403649
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/400751

I think can be confirmed this bug.

giuseppe

Changed in linux (Ubuntu):
status: New → Confirmed
Giuseppe Pennisi (giupenni78) wrote :

I solved some problem to pass at grub libata.ignore_hpa=0

The problem persist in karmic.

giuseppe

Hugh O'Byrne (hobyrne) wrote :

I have experienced the same bug with a Hitachi hard drive (HTS545050B9A300).

In reading the specification of my drive, I came across this interesting paragraph relating to NCQ:

The host shall not issue a legacy ATA command while a native queued command is outstanding.
Upon receiving a legacy ATA command while a native queued command is outstanding, the device
aborts the command and halts command processing of outstanding native queued commands.

It seems to me the kind of thing that might be responsible.

Hugh.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers