Ubuntu

Keyboard quirk is required for Mitac 8050QDA Fn Volume keys to function.

Reported by klerfayt on 2009-05-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
udev (Ubuntu)
Undecided
Kamal Mostafa

Bug Description

Fn keys VolumeUp[F3], VolumeDown[F4] and Mute[F10] do not report KEY_UP then released on this notebook, this makes volume go respectively all the way Up, Down or Mute/UnMute endlessly.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=/dev/sda9
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 002: ID 046d:c03f Logitech, Inc. UltraX Optical Mouse
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MTC
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
ProcCmdLine: root=UUID=03ae90e6-f1cf-4a33-bfaa-90aacc911853 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
SourcePackage: linux
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kristjanlynx 1392 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with ALC655 at irq 17'
   Mixer name : 'Realtek ALC655 rev 0'
   Components : 'AC97a:414c4760'
   Controls : 41
   Simple ctrls : 26
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=3f015923-c99d-45c6-8061-0405a53a2cf5
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
Package: udev 151-8~kamal~volkeys0
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=362f6d39-03df-41ed-b4fa-e1fb3eef7f6f ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Regression: No
RelatedPackageVersions: linux-firmware 1.33
Reproducible: Yes
RfKill:

Tags: lucid needs-upstream-testing lucid
Uname: Linux 2.6.32-19-generic i686
UnreportableReason: This is not a genuine Ubuntu package
UserGroups:

dmi.bios.date: 09/15/2005
dmi.bios.vendor: Insyde Software Corporation
dmi.bios.version: R1.02
dmi.board.vendor: MTC
dmi.board.version: A0
dmi.chassis.asset.tag: 12345678
dmi.chassis.type: 10
dmi.chassis.vendor: MTC
dmi.chassis.version: A0
dmi.modalias: dmi:bvnInsydeSoftwareCorporation:bvrR1.02:bd09/15/2005:svnMTC:pn:pvrA0:rvnMTC:rn:rvrA0:cvnMTC:ct10:cvrA0:
dmi.product.version: A0
dmi.sys.vendor: MTC

Jeremy Foshee (jeremyfoshee) wrote :

Hi klerfayt,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 374884

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Yes, this is still a problem in Lucid. But I can't give you any more information because the given command to collect more data gives me an error. I am not sure what I am doing wrong:

$ sudo apport-collect -p linux 374884
Usage: apport-gtk <report number>

apport-gtk: error: no such option: -p

MillenniumBug (millenniumbug) wrote :

Have you tried without the -p ?

Changed in linux (Ubuntu):
status: Incomplete → New

$ sudo apport-collect linux 374884
Usage: apport-gtk <report number>

apport-gtk: error: You need to specify a report number to update

Kamal Mostafa (kamalmostafa) wrote :

@klerfayt: Would it be possible for you to test the PPA fix below under 10.04, and confirm that it fixes the problem on your Mitac laptop? Thanks very much. -Kamal.

Ubuntu 10.04 Beta users can install a test fix for this problem from this PPA:
  https://launchpad.net/~kamalmostafa/+archive/lucid-volume-keys

Feedback to this bug report will be appreciated.

Changed in udev (Ubuntu):
status: New → Incomplete

Enabled PPA, ran system update and rebooted
Fn volume up/down/mute still excibit same problem

Kamal Mostafa (kamalmostafa) wrote :

@klerfayt: Thanks for testing the PPA -- next steps:

1. Lets try apport-collect again -- the proper syntax should be: sudo apport-collect 374884 (no "-p" or "linux").

2. Please verify that the the PPA actually got installed: apt-cache policy udev (should include "Installed: 151-8~kamal~volkeys0")

3. Please follow this procedure, which will help me identify the key codes associated with the problematic keys on your laptop:

$ dmesg | grep keyboard
[ 1.095041] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
(Note the number N in "inputN" at the very end of the line, where mine above says 5)

$ sudo /lib/udev/keymap -i input/event5 <--- replace the "5" with whatever your N was above.
(Now press each of these keys once: mute, volumedown, volumeup, and finally "Esc" to finish -- paste the resulting output here).

Changed in udev (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

2. apt-cache policy udev

udev:
  Installed: 151-8~kamal~volkeys0
  Candidate: 151-8~kamal~volkeys0
  Version table:
 *** 151-8~kamal~volkeys0 0
        500 http://ppa.launchpad.net/kamalmostafa/lucid-volume-keys/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     151-7 0
        500 http://ee.archive.ubuntu.com/ubuntu/ lucid/main Packages

3. dmesg | grep keyboard

[ 0.823820] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input4

4. sudo /lib/udev/keymap -i input/event4

Press ESC to finish
scan code: 0xAE key code: volumedown
scan code: 0xB0 key code: volumeup
scan code: 0xA0 key code: mute
scan code: 0x01 key code: esc

Kamal Mostafa (kamalmostafa) wrote :

@klerfayt: Thank you for posting the information. I have modified the PPA test fix (from comment #7). Please update again, verify that "apt-cache policy udev" shows the updated version (Installed: 151-8~kamal~volkeys1), reboot, and then check the volume keys behavior once again.

apt-cache policy udev
udev:
  Installed: 151-8~kamal~volkeys1
  Candidate: 151-8~kamal~volkeys1
  Version table:
 *** 151-8~kamal~volkeys1 0
        500 http://ppa.launchpad.net/kamalmostafa/lucid-volume-keys/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     151-7 0
        500 http://ee.archive.ubuntu.com/ubuntu/ lucid/main Packages

Fn + Volume up/down/mute work correctly now

Kamal Mostafa (kamalmostafa) wrote :

@klerfayt: Excellent. Thanks for the confirmation that the PPA fix worked. Note however, that earlier today a new version of udev was released (not including this fix) which supersedes the PPA (and will therefore break your volume keys again). I have now updated the PPA version again to deal with that. You should check that "apt-cache policy udev" indicates that you now have "Installed: 151-9~kamal~volkeys1" and update again if not.

I am working on getting this fix permanently committed upstream.

Changed in udev (Ubuntu):
status: Incomplete → In Progress

apt-cache policy udev
udev:
  Installed: 151-9~kamal~volkeys1
  Candidate: 151-9~kamal~volkeys1
  Version table:
 *** 151-9~kamal~volkeys1 0
        500 http://ppa.launchpad.net/kamalmostafa/lucid-volume-keys/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     151-8 0
        500 http://mirrors.se.eu.kernel.org/ubuntu/ lucid/main Packages

Confirming that Fn + volume up/down/mute keys still work without any problems after updating and rebooting.
Thanks.

Kamal Mostafa (kamalmostafa) wrote :

Attached patch adds this model (MTC/product_version=="A0") to the common-volume-keys release quirk.
Prerequisite patches:
  common-volume-keys.patch from LP: #565459
  udev-151-12~kamal~volkeys1.patch from LP: #420473 (for diff context)

Kamal Mostafa (kamalmostafa) wrote :

@klerfayt: Note that I have updated the PPA test fix once more. Please update and confirm that version udev (151-12~kamal~volkeys2) still fixes the problem on your Mitac laptop. Again, thank you very much for reporting the problem and for your continued help testing the fix while we work towards getting it merged.

Ubuntu 10.04 Beta users can install a test fix for this problem from this PPA:
  https://launchpad.net/~kamalmostafa/+archive/lucid-volume-keys

Changed in udev (Ubuntu):
status: In Progress → Confirmed

apt-cache policy udev
udev:
  Installed: 151-12~kamal~volkeys2
  Candidate: 151-12~kamal~volkeys2
  Version table:
 *** 151-12~kamal~volkeys2 0
        500 http://ppa.launchpad.net/kamalmostafa/lucid-volume-keys/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     151-11 0
        500 http://mirrors.se.eu.kernel.org/ubuntu/ lucid/main Packages

all fn volume keys - volumeup/down/mute - are still working without issues

Martin Pitt (pitti) wrote :
Changed in linux (Ubuntu):
status: New → Invalid
Changed in udev (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 151-12

---------------
udev (151-12) lucid; urgency=low

  * Cherrypick keymap fixes from trunk:
    - Unite laptop models needing common volume-key release quirk. Many laptop
      models need the same volume-key release quirk. Currently, two models
      have identical force-release-maps/ keymap files (dell-studio-1557 and
      fujitsu-amilo-si1848) and two more need to be added (Mitac and Coolbox
      QBook). This replaces the identical force-release-maps files with one
      'common-volume-keys' file to make adding new models easier.
      (LP: #565459)
    - Add force-release quirk for Coolbox QBook 270-02 (LP: #420473)
    - Add force-release quirk for Mitac 8050QDA (LP: #374884)
 -- Martin Pitt <email address hidden> Mon, 19 Apr 2010 10:58:13 +0200

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.