Jaunty Upgrade: Really REALLY sucky performance with rt kernel

Bug #374284 reported by teledyn on 2009-05-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This is nebulous, all purvasive and exceptionally annoying, and I don't even know where to begin to debug this, so I'm appealing to those of you who know more about the internals of the specific components.

I upgraded my Dell Inspiron 1521 laptop to 9.04 and the performance is abysmal; this is a dual-core AMD Turion(tm) 64 X2 Mobile Technology TL-60 1795.601MHz, and it is now SLOWER than a P3/300Mhz.

Now here is the kicker: the Live-CD session using the Jaunty Desktop CD is fine, it is quite zippy and enjoyable. So SOMETHING has gone horribly wrong with the upgrade.

but I don't know where to begin to look. Here's what I do know:

Both the Live CD and the upgrade session use the Radeon driver at 1440x900. The chipset is X1200 no longer supported by ATI (I have ranted at them elsewhere) so there is no fglrx installed. The upgrade initially chose the RadeonHD driver, but when I noticed the LiveCD performance was so much better and that it used the plain Radeon, I removed RadeonHD to force the Radeon choice. It didn't make any difference.

Very curiously, the LiveCD session lsmod includes both the radeon and the drm kernel modules whereas the upgraded session does not; when I try to modprobe these modules I get the same error on both:

FATAL: Error inserting radeon (/lib/modules/2.6.24-23-rt/kernel/drivers/char/drm/radeon.ko): Cannot allocate memory

also curious, 'free' reports zero shared memory

$ free
             total used free shared buffers cached
Mem: 1932460 839556 1092904 0 43236 472764
-/+ buffers/cache: 323556 1608904
Swap: 4088500 0 4088500

in top, Xorg is constantly at the top on an idle machine:
 5845 root 20 0 229m 26m 8184 R 78 1.4 13:55.12 Xorg

load average is 1.23 on a session that is only running 'top' and filling in this form
Firefox performance is excruciatingly slow, making the typing into this form very tedious to do :)

one difference: the upgraded machine was Ubuntu Studio, so it is running RT
Linux uhuru 2.6.24-23-rt #1 SMP PREEMPT RT Wed Apr 1 23:40:34 UTC 2009

the liveCD runs
Linux ubuntu 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009

lsmod and Xorg.0.log comparisons attached.

teledyn (garym-teledyn) wrote :
teledyn (garym-teledyn) wrote :
teledyn (garym-teledyn) wrote :
teledyn (garym-teledyn) wrote :
teledyn (garym-teledyn) wrote :
teledyn (garym-teledyn) wrote :
teledyn (garym-teledyn) wrote :

one culprit was the RT kernel installed by Ubuntu-Studio

Linux uhuru 2.6.24-23-rt #1 SMP PREEMPT RT Wed Apr 1 23:40:34 UTC 2009

I removed this and installed Linux uhuru 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 and performance is immediately much improved, Xorg shows drm now installs and radeon and drm are now both in the lsmod listing.

the upgrade apparently misses replacing the RT kernel, which makes sense (in retrospect) since Cannonical does not support the RT kernel images.

teledyn (garym-teledyn) wrote :

24 hrs later and the machine has been performing perfectly since switching to the generic kernel.

perhaps the subject of this bug should be changed to: Where do we get a working RT kernel for Jaunty? and maybe a side bug to report that the upgrade fails to recognize that the RT support will result in an unstable machine.

teledyn (garym-teledyn) wrote :

purged the machine of all RT kernel images and modules, then reinstalled using "aptitude install linux-rt" and it seemed to work, the machine rebooted and was reasonably speedy until I tried to enter text into this form, then it started to slow down dramatically; I tried to test the playback of a youtube page, but didn't get very far -- on entering text into the firefox location bar, the CPU halted, no ctrl-alt-del, no response from the off switch.

so something is desperately wrong with the RT kernel in the Jaunty environment. don't know if drm or the radeon modules were loaded, but I think they must have been to have given the good performance for the first few minutes of us (in the situation that started this ticket, performance was bad right from the login and even in svga mode)

affects: ubuntu → linux (Ubuntu)
summary: - Jaunty Upgrade: Really REALLY sucky performance
+ Jaunty Upgrade: Really REALLY sucky performance with rt kernel
teledyn (garym-teledyn) wrote :

thanks for the rename ;)

a possible cause: the Dell Inspiron 1521 uses the Radeon X1200 graphics for which the geniuses at AMD just clipped support in the fglrx driver, so that means the only acceptable performance is with the radeon driver (I haven't yet tried radeonhd with a non-RT kernel) and the radeon is unable to move bits fast enough to play full-screen AVI files and keep the sound synchronized. Perhaps that situation is made worse with a RT kernel?

Jeremy Foshee (jeremyfoshee) wrote :

Hi teledyn,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 374284

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers