Kernel oops when starting xserver-xorg-video-intel

Bug #372473 reported by Bobbi Manners on 2009-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Release: Jaunty 09.04

xserver-xorg-video-intel 2:2.6.3-0ubuntu9

bob@gecko2:~$ uname -a
Linux gecko2 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686GNU/Linux

I restarted xserver-xorg-video-intel and got a kernel oops. The X server appeared to start and run OK. I am not sure whether to report this to the kernel guys on the guys who look after the Intel X-server.

I have UXA acceleration enabled. I will post my xorg.conf.

Normally the X server starts without an oops. On this occasion I performed a restart to clear the swap space leak that appears to be caused by xserver-xorg-video-intel. Looks like a GEM bug perhaps ...

[186910.996123] ------------[ cut here ]------------
[186910.996130] WARNING: at /build/buildd/linux-2.6.28/drivers/gpu/drm/i915/i915_gem.c:2475 i915_gem_idle+0x3a8/0x3d0 [i915]()
[186910.996135] Modules linked in: nls_iso8859_1 nls_cp437 vfat fat mmc_block sha1_generic ppp_mppe ppp_async crc_ccitt aes_i586 aes_generic xt_limit ipt_LOG xt_DSCP nf_conntrack_irc nf_conntrack_ftp i915 drm ppdev bnep ipt_MASQUERADE xt_state ipt_REJECT xt_tcpudp bridge stp kvm_intel kvm input_polldev sbp2 lp parport snd_hda_intel arc4 snd_pcm_oss iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack snd_mixer_oss ecb nf_defrag_ipv4 snd_pcm iptable_mangle snd_seq_dummy snd_seq_oss iwl3945 iptable_filter snd_seq_midi snd_rawmidi ip_tables iTCO_wdt iTCO_vendor_support snd_seq_midi_event mac80211 x_tables psmouse intel_agp agpgart snd_seq snd_timer snd_seq_device video led_class serio_raw ricoh_mmc sdhci_pci sdhci pcspkr joydev snd soundcore snd_page_alloc output cfg80211 btusb hid_logitech ff_memless usbhid usb_storage ohci1394 ieee1394 e100 mii fbcon tileblit font bitblit softcursor
[186910.996279] Pid: 3057, comm: Xorg Tainted: G W 2.6.28-11-generic #42-Ubuntu
[186910.996284] Call Trace:
[186910.996296] [<c0500ac6>] ? printk+0x18/0x1a
[186910.996304] [<c0139b24>] warn_on_slowpath+0x54/0x80
[186910.996321] [<c0144271>] ? del_timer_sync+0x11/0x20
[186910.996328] [<c05016e6>] ? schedule_timeout+0x86/0xe0
[186910.996335] [<c014b57a>] ? __cancel_work_timer+0x6a/0x190
[186910.996349] [<f81ab629>] ? i915_gem_retire_requests+0xf9/0x150 [i915]
[186910.996361] [<f81ab629>] ? i915_gem_retire_requests+0xf9/0x150 [i915]
[186910.996374] [<f81ad688>] i915_gem_idle+0x3a8/0x3d0 [i915]
[186910.996396] [<f821d6eb>] ? drm_gem_object_lookup+0x3b/0x50 [drm]
[186910.996409] [<f81ad6f4>] i915_gem_leavevt_ioctl+0x14/0x30 [i915]
[186910.996427] [<f821c170>] drm_ioctl+0xe0/0x2e0 [drm]
[186910.996440] [<f81ad6e0>] ? i915_gem_leavevt_ioctl+0x0/0x30 [i915]
[186910.996460] [<c01ca209>] vfs_ioctl+0x79/0x90
[186910.996466] [<c01ca69e>] do_vfs_ioctl+0x5e/0x200
[186910.996473] [<c01ca8a3>] sys_ioctl+0x63/0x70
[186910.996480] [<c0103f6b>] sysenter_do_call+0x12/0x2f
[186910.996485] ---[ end trace daf188d8a2ccf96c ]---
[186911.209087] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[186911.229595] mtrr: no MTRR for c0000000,10000000 found
[186916.034652] [drm:i915_setparam] *ERROR* unknown parameter 4
[186916.034675] [drm:i915_getparam] *ERROR* Unknown parameter 6
[186917.313887] [drm:i915_getparam] *ERROR* Unknown parameter 6
[186921.944092] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

Bobbi Manners (bobbi.manners) wrote :
affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) wrote :

The kernel is the appropriate target for filing kernel oops bugs.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Hi Bob,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 372473

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Bobbi Manners (bobbi.manners) wrote :

Problem appears to be resolved in Karmic (kernel 2.6.31-20). This ticket may be closed.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers