Ubuntu

ath5k : disconnection / slow network - "unsupported jumbo" error

Reported by David Jobet on 2009-04-29
178
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

jaunty ubuntu 9.04
linux-backports-modules-jaunty installed (same behaviour with or without)

was working fine in intrepid (with ath_pci/ath_hal)

only things I can find in /var/log/messages are repeating lines like :
ath5k phy0: unsupported jumbo

when I do /etc/init.d/networking restart, the connection is fine for about 1min, then the connection becomes very slow (sometimes < 1ko/sec) then dies.

other details follow

thanks for any help

lspci -v
06:02.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
        Subsystem: D-Link System Inc Device 3a18
        Flags: bus master, medium devsel, latency 168, IRQ 18
        Memory at e0000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath5k
        Kernel modules: ath5k

uname -a
Linux vador 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

apt-cache showpkg linux-backports-modules-jaunty
Package: linux-backports-modules-jaunty
Versions:
2.6.28.11.15 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_jaunty_main_binary-i386_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_jaunty_main_binary-i386_Packages
                  MD5: 38c0a1e32af36ac7d0d14b1e9989b240

Reverse Depends:
Dependencies:
2.6.28.11.15 - linux-backports-modules-jaunty-generic (5 2.6.28.11.15)
Provides:
2.6.28.11.15 -
Reverse Provides:

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=cffc8d20-76d9-43e1-b832-f3f454687c0b
MachineType:

Package: linux-image-2.6.28-11-generic 2.6.28-11.42
ProcCmdLine: root=UUID=18bd44fe-fe0a-4be2-af9a-982ce499ae43 ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
SourcePackage: linux

David Jobet (david-jobet) wrote :

I can confirm this. I WLAN does work, but is definitely way too slow. dmesg lists the same “unsupported jumbo” errors.

My card:

02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
        Subsystem: AMBIT Microsystem Corp. Device 0428
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d0200000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath5k
        Kernel modules: ath5k, ath_pci

Changed in linux (Ubuntu):
status: New → Confirmed
David Jobet (david-jobet) wrote :

Is there any thing I can do to help debug this problem ? (like testing kernels, testing patches, ...)
I'm not a kernel programmer, but I do programming for a living (mostly c++), so I should be able to do basic things if necessary.

Timo Karhu (nalle-karhulitos) wrote :

I confirm the same behavior.

ath5k phy0: unsupported jumbo
ath5k phy0: noise floor calibration timeout (2412MHz)
ath5k phy0: noise floor calibration failed (2417MHz)
ath5k phy0: noise floor calibration timeout (2422MHz)

What is odd for me here at home is that in my kitchen where this laptop mostly is, the connection is stable most of the times.
If I carry the laptop just few meters away to living room, wlan sometimes gets even disconnected but at least the speed is slow all the time.

Card:
05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
 Subsystem: AMBIT Microsystem Corp. Device 0428
 Flags: bus master, fast devsel, latency 0, IRQ 19
 Memory at d0400000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 2
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Virtual Channel <?>
 Kernel driver in use: ath5k
 Kernel modules: ath5k, ath_pci

David Jobet (david-jobet) wrote :

Installed linux-backports-modules and now using ath_pci : working fine.

mercutio22 (macabro22) wrote :

same here

L.D. Paniak (ldpaniak) wrote :

I am seeing the same errors (unsupported jumbo) and poor wifi performance on a good network with
Karmic/Mythbuntu Alpha 6. The hardware is Acer Revo 3600

lspci -vv

05:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
 Subsystem: Foxconn International, Inc. Device e008
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 19
 Region 0: Memory at febf0000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: ath5k
 Kernel modules: ath5k

Julius Thor (joolli) wrote :

Same messages here:

ath5k phy0: unsupported jumbo

I also get this message sometimes:

ath5k phy0: noise floor calibration failed

I'm on jaunty and initially I couldn't even connect to my AP at home. It wasn't until I changed to a free channel I could connect. Now I have a full connection but it's not fast at all. I also lose the connection once every minute or two without being de-associated. Sometimes I do get de-associated though.

When in the University library I usually can't associate at all and when I do I lose the connection after a few seconds.

This is when I'm using the ath5k driver. To be able to get wireless in the Library I have to unload ath5k and use ath_pci. That driver keeps a more stable connection, however it causes random kernel panics and I hate losing my work!

DavidM (david-maciejak) wrote :

Nothing new ? i also experiencing the same trouble with kernel 2.6.28-15, on jaunty.
My card is a dlink dwl-g520+, chip atheros ar5001x+
Using linux-backports-modules does not solved my issues :S
Got a infinite loop of connection/deconnection, so using the wifi is impractical !

I’m still experiencing these problems after the upgrade to the Karmic RC. Wifi is slow and the „unsupported jumbo“ errors show up in the log.

Julius Thor (joolli) wrote :

I'm on Karmic and this seems to have been improved a lot over recent days. I have linux-backports-modules-karmic installed and I'm downloading at 300-700KB/s in my university where I would only get 2-15KB/s a week or two ago.

Vruchteloos (info-g-start) wrote :

On Karmic, I've got the same problems.

The first message in dmesg is:
ath5k phy0: unsupported jumbo

Followed by a long list of:
ath5k phy0: noise floor calibration timeout (2437MHz)

Also, I noticed when running the command 'top' a process called 'phy' pops up for only a few miliseconds, using at least 30% CPU.

I use this wirelesscard:
AR2413 802.11bg

On an Acer Aspire 5101AWMLi.

Thanx in advance for helping us out! :)

Alendit (alendit) wrote :

Same here with fully updated Lucid and Dlink DWL-G520.

jellytree (jellytree) wrote :

Same here with with Karmic on an Acer Aspire 7520 which sports an AR5007EG which is currently incorrectly identified as an AR5001?

Symptoms: Wireless is up and running essentially out of the box, however on transfers, performance is very poor (500KB/s). Samba stalls every time with larger files (100mb+). IRC and FTP are similarly affected although they don't stall like Samba. Haven't tested much else, NFS is next.

        lspci -vv:

        Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
        Subsystem: AMBIT Microsystem Corp. Device 0428
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at d0400000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath5k
        Kernel modules: ath5k

     dmesg | grep ath:

     [ 2.338089] device-mapper: multipath: version 1.1.0 loaded
     [ 2.338092] device-mapper: multipath round-robin: version 1.0.0 loaded
     [ 13.525606] ath5k 0000:05:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, low) -> IRQ 19
     [ 13.525615] ath5k 0000:05:00.0: setting latency timer to 64
     [ 13.525666] ath5k 0000:05:00.0: registered as 'phy0'
     [ 13.738762] ath: EEPROM regdomain: 0x65
     [ 13.738765] ath: EEPROM indicates we should expect a direct regpair map
     [ 13.738770] ath: Country alpha2 being used: 00
     [ 13.738772] ath: Regpair used: 0x65
     [ 14.057992] Registered led device: ath5k-phy0::rx
     [ 14.058015] Registered led device: ath5k-phy0::tx
     [ 14.058019] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
     [ 344.125243] ath5k phy0: unsupported jumbo
     [ 357.824179] ath5k phy0: unsupported jumbo
     [ 513.273487] ath5k phy0: unsupported jumbo
     [ 1052.001365] ath5k phy0: unsupported jumbo
     [ 1092.851174] ath5k phy0: unsupported jumbo

Fabián Rodríguez (magicfab) wrote :

I am marking as "HIgh" importance. From https://wiki.ubuntu.com/Bugs/Importance:

High: A bug which fulfills one of the following criteria:

    * Has a severe impact on a small portion of Ubuntu users (estimated)
    * Makes a default Ubuntu installation generally unusable for some users
          o For example, if the system fails to boot, or X fails to start, on a certain make and model of computer
    * A problem with an essential hardware component (disk controller, laptop built-in wireless, video card, keyboard, mouse)
    * Has a moderate impact on a large portion of Ubuntu users (estimated)

I've also changed the title as this now spans over 3 releases including the current one.

summary: - juanty ath5k : disconnection / slow network
+ ath5k : disconnection / slow network - "unsupported jumbo" error
Changed in linux (Ubuntu):
importance: Undecided → High
Gilbert Dion (diong) wrote :

Same problem here running on Acer Aspire 5050 with Atheros AR5001 Wireless Network Adaptor.
Everything was fine on Karmic until I upgraded to Lucid.
Curiously, there is no problem with my Acer Aspire One (also running on Lucid), wich has the same wireless adaptor.

Graham Hawkins (grahamhawkins) wrote :

Just tried Wireless Compat bleeding edge tarball compat-wireless-2010-05-29.tar.bz2. Connection drops with high downlink loading. AAO A150 with AR5001.

Graham Hawkins (grahamhawkins) wrote :

Continued from #17 above.
Sorry, should have said this is Ubuntu NBR 10.04.
Standard & linux-backports-modules-wireless-2.6.32.22 ath5k drivers (from 10.04 repository) show loss of connection, so I tried the bleeding edge versions built from source.
BTW, I'm not totally convinced the jumbo packet reports are linked. If I throttle the wireless rate on my AP right down to 1Mbps, I get much more data through before the disconnection (but _very_ slowly!). I still see jumbo packet reports though, and scattered throughout the transfer (this is with the repository drivers, didn't try this with bleeding edge one).

Graham Hawkins (grahamhawkins) wrote :

Don't see jumbo packet warnings with the ath5k build from the bleeding edge tarball.
Probably this is why:
http://article.gmane.org/gmane.linux.kernel.wireless.general/50642
Seems the jumbo warning has been disabled recently.

Graham Hawkins (grahamhawkins) wrote :

Looks like a fix is in the pipline:
https://bugzilla.kernel.org/show_bug.cgi?id=13892
Will give it a try when I have time to patch the source & rebuild.

Graham Hawkins (grahamhawkins) wrote :

Applied Jussi Kivilinna's patch (see #20 above) to compat-wireless-2010-05-29, and compiled against 2.6.32-22-generic. Had to change calls to pci_pcie_cap() in the patch to calls to pci_find_capability():

From:
pos = pci_pcie_cap(pdev);

 pos = pci_find_capability(pdev, PCI_CAP_ID_EXP);

 (I think the newer API is not in 2.6.32-22).

The connection drop due to large transfers is gone - I moved ~1GB of files up & down without failure.

I did notice that the new driver seems slow to connect from cold boot. Might be something I did... not sure.

Peter Feuerer (peter-feuerer) wrote :

Jussi Kivilinna's patch (see #20) is working great for me too. Please push the patch mainline.

Thank you very much for the good work!

Maxim Levitsky (maximlevitsky) wrote :

In fact I found out that at least AR5001 ASPM will be disabled automatically if kernel is compiled with
CONFIG_PCIEASPM it will be disabled.

Maveric kernel *is* compiled with CONFIG_PCIEASPM, therefore the card should work out of box.

To see if ASPM is disabled on your wireless card do 'sudo lspci -vvv', find there the wireless card, and look at
LnkCtl field.
It should say, 'LnkCtl: ASPM Disabled....'

Also, if you see that your device is
'Capabilities: [e0] Express (v1) Legacy Endpoint, MSI 00'

It is important to see the 'Legacy' word, then ASPM will be automatically disabled by Maveric kernel.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Maxim Levitsky (maximlevitsky) wrote :

This is pretty much understood and fixed.

GenericAnimeBoy (souletech) wrote :

@23: Unfortunately, that fix hasn't been backported to Lucid yet. lspci -vvv on my Acer Aspire One running 10.04 shows ASPM L0s L1 Enabled. Log attached.

Joao Verissimo (joniv) wrote :

Confirm that disabling CONFIG_PCIEASPM and recompiling the Lucid kernel fixes the disconnection problems. On an Aspire One 110, "sudo lspci -vv" reads:

03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
 Subsystem: Foxconn International, Inc. Device e008
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at 55200000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr+ UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
  Vector table: BAR=0 offset=00000000
  PBA: BAR=0 offset=00000000
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Virtual Channel <?>
 Kernel driver in use: ath5k
 Kernel modules: ath5k

GenericAnimeBoy (souletech) wrote :

I hope I'm not coming across as whiny here, but is there a way to fix this that doesn't involve me recompiling the kernel?

Joao Verissimo (joniv) wrote :

So far, I think the options are: (1) Compile/install madwifi; (2) Install a kernel from the kernel ppa; the Maverick ones got it right; (3) Recompile the Ubuntu kernel; (4) Wait for Maverick's release or use another distribution (both the latest Fedora and OpenSuse do not have this problem).

GenericAnimeBoy (souletech) wrote :

Fair enough. I'll give the kernel ppa a shot. Thanks for the quick response.

GenericAnimeBoy (souletech) wrote :

Alright, it's working for me now, after installing a backported maverick kernel from the kernel ppa. For those of you who don't feel comfortable with recompiling the kernel this seems to be the way to go:
1) Add deb http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu lucid main to your package sources
2) Install linux-lts-backport-maverick
3) Restart.

Graham Hawkins (grahamhawkins) wrote :

Confirmed that linux-lts-backport-maverick fixes the problem on my Aspire One A150. Thanks.

vo.one (vo-on3z) wrote :

There is a hardware bug on some adapters, such as Atheros 5007EG on Acer Aspire One netbook. Connection may drop suddenly or work instable, dmesg shows: ath5k: unsupported jumbo. The reason is a result of poor hardware ASPM support. It is a hardware bug that is worked around in windows driver by disabling PCIE ASPM L0S.

There's a solution - turn ASPM L0S off manually for this device.

1. Download enable-aspm
http://kernel.org/pub/linux/kernel/people/mcgrof/aspm/enable-aspm

2. Get your root complex:

$ lspci -tv
0000:00
...
+-1c.2-[0000:03]----00.0 Atheros Communications Inc. AR5001 Wireless Network
Adapter
...
So root complex is 00:1c.2

3. Get your endpoint:

$ lspci
...
03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network
Adapter (rev 01)
...
The endpoint is 03:00.0

4. Now you need to edit your enable-aspm

# You just need to modify these three values:

ROOT_COMPLEX="00:1c.2"
ENDPOINT="03:00.0"

ASPM_SETTING=2
5. Now executing:

vo-one <at> acerone:~$ sudo bash enable-aspm
[sudo] password for vo-one:
Root complex:
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev
02)
0x50 : 0x43 --> 0x42 ... [SUCCESS]]
L1 only

Endpoint:
03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network
Adapter (rev 01)
0x70 : 0x4B --> 0x4A ... [SUCCESS]]
L1 only
6. Making the script executed at system startup:

sudo chmod +x enable-aspm
sudo cp enable-aspm /usr/bin
Then add a line "enable-aspm" into your /etc/rc.conf before the line "exit 0;" to make the script executed at the system startup.

I've added your script to /etc/network/if-pre-up.d/ and it seems to fix the bug. Many thanks!

Works for me as well. IMO this is a nicer solution that using a
backport kernel. I mean, I can use this together with the official LTS
kernels :)

Roman Yepishev (rye) wrote :

https://lists.ath5k.org/pipermail/ath5k-devel/2010-August/004028.html

Atheros PCIe wireless cards handled by ath5k, don't work well with PCIe
ASPM L0s enabled.

For example, Acer Aspire One (AOA150, Atheros Communications Inc. AR5001
Wireless Network Adapter [168c:001c] (rev 01)) doesn't work well with ASPM
enabled. With ASPM ath5k will eventually stall on heavy traffic with often
'unsupported jumbo' warnings appearing. Disabling ASPM L0s in ath5k fixes
these problems.

Also card sends a storm of RXORN interrupts even though medium is idle.
According to vendor, all PCIe ath5k supported cards should have L0s disabled.
Also, its safe to reenable L1, even if device is pre 1.1 PCIe device, in which case
kernel ASPM code unconditionaly disables L0s/L1.

you must have CONFIG_PCIEASPM enabled, or otherwise this patch reduces to no-op.
Note that usually this patch will do nothing anyway, because as soon as CONFIG_PCIEASPM
is enabled, Linux will usualy disable ASPM on this device due to it beeing a 'Legacy' PCIE
device. This patch ensures that L0s is always disabled regardless of that 'Legacy' setting

All credit for finding and fixing that bug,
goes to Jussi Kivilinna <jussi.kivilinna at mbnet.fi>

Signed-off-by: Maxim Levitsky <maximlevitsky at gmail.com>
---
 drivers/net/wireless/ath/ath5k/base.c | 13 +++++++++++++
 1 files changed, 13 insertions(+), 0 deletions(-)

diff --git a/drivers/net/wireless/ath/ath5k/base.c b/drivers/net/wireless/ath/ath5k/base.c
index 648972d..d691325 100644
--- a/drivers/net/wireless/ath/ath5k/base.c
+++ b/drivers/net/wireless/ath/ath5k/base.c
@@ -48,6 +48,7 @@
 #include <linux/netdevice.h>
 #include <linux/cache.h>
 #include <linux/pci.h>
+#include <linux/pci-aspm.h>
 #include <linux/ethtool.h>
 #include <linux/uaccess.h>
 #include <linux/slab.h>
@@ -472,6 +473,18 @@ ath5k_pci_probe(struct pci_dev *pdev,
  int ret;
  u8 csz;

+ /*
+ * Disable PCIE ASPM L0S on the card.
+ * ASPM triggers hardware bug, that makes card stall transmission
+ * untill reset, and even that doesn't always help.
+ * This happens on meduim to heavy transmit utilization.
+ * In addition to stall, hardware usually gives a storm of
+ * RXORN interrupts, despite idle channel, and otherwise doesn't work.
+ * According to vendor, indeed L0s must be disabled.
+ * Note: to benefit from this fix, please _enable_ CONFIG_PCIEASPM
+ */
+ pci_disable_link_state(pdev, PCIE_LINK_STATE_L0S);
+
  ret = pci_enable_device(pdev);
  if (ret) {
   dev_err(&pdev->dev, "can't enable device\n");
--
1.7.0.4

Roman Yepishev (rye) wrote :
tags: added: patch
elmar.hinz (elmar-hinz) wrote :

Workaround:

Just want to mention that they have published a workaround, which is done in 5 minutes:

http://wireless.kernel.org/en/users/Drivers/ath5k#Eliminating_.60ath5k:_unsupported_jumbo.60_bug

It works well for me with AR5001 and 10.4.

The precise ASPM setting is the point:

   ASPM_SETTING=2

You are in danger to miss it, in all the description of the workaround.

Download full text (4.3 KiB)

I have the same defect in my laptop ACER Apire 5610Z with Atheros AR2413 802.11bg.

I try to use the script to eliminate the Jombo problem but without succes:

Bureau$ sudo bash enable-aspm
Root complex:
Long loop while looking for ASPM word for 00:1e.0

Endpoint:
Long loop while looking for ASPM word for 06:02.0

Here my Lspci:

Bureau$ lspci -tv
-[0000:00]-+-00.0 Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
           +-02.0 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
           +-02.1 Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
           +-1b.0 Intel Corporation N10/ICH 7 Family High Definition Audio Controller
           +-1c.0-[0000:02]--
           +-1c.1-[0000:03]--
           +-1c.2-[0000:04]--
           +-1c.3-[0000:05]--
           +-1d.0 Intel Corporation N10/ICH7 Family USB UHCI Controller #1
           +-1d.1 Intel Corporation N10/ICH 7 Family USB UHCI Controller #2
           +-1d.2 Intel Corporation N10/ICH 7 Family USB UHCI Controller #3
           +-1d.3 Intel Corporation N10/ICH 7 Family USB UHCI Controller #4
           +-1d.7 Intel Corporation N10/ICH 7 Family USB2 EHCI Controller
           +-1e.0-[0000:06-0a]--+-01.0 Broadcom Corporation BCM4401-B0 100Base-TX
           | +-02.0 Atheros Communications Inc. AR2413 802.11bg NIC
           | +-04.0 ENE Technology Inc CB-712/4 Cardbus Controller
           | +-04.1 ENE Technology Inc ENE PCI Memory Stick Card Reader Controller
           | +-04.2 ENE Technology Inc ENE PCI Secure Digital Card Reader Controller
           | +-04.3 ENE Technology Inc FLASH memory: ENE Technology Inc:
           | \-04.4 ENE Technology Inc SD/MMC Card Reader Controller
           +-1f.0 Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
           +-1f.2 Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller
           \-1f.3 Intel Corporation N10/ICH 7 Family SMBus Controller

Bureau$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7...

Read more...

Roman Yepishev (rye) wrote :

By the way, Maxim Levitsky wrote that in order for ASPM L0s to be disabled for legacy PCI-E cards (our ath5k ones) the kernel should be built with CONFIG_PCIE_ASPM. No additional call to pci_disable_link_state() is requred.

Roman Yepishev (rye) wrote :

Ubuntu Maverick Meerkat kernels are compiled with CONFIG_PCIE_ASPM enabled so they are not suffering from this problem.

Using Linux 2.6.35-19-generic #25~lucid1-Ubuntu SMP Wed Aug 25 04:24:28 UTC 2010 i686 GNU/Linux Kernel solves the problem.

Maxim Levitsky (maximlevitsky) wrote :

This is really fixed in maveric

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Vince McIntyre (vmcintyr) wrote :

I'm still seeing occasional "unsupported jumbo" messages, but the card does appear to work fairly reliably,
I have not seen it fall over in days. Thanks Maxim. I haven't made speed tests but it's not irritatingly slow.
Not seeing any "noise floor" messages.

$ uptime
 21:17:49 up 2 days, 11:48, 7 users, load average: 0.04, 0.15, 0.15

$ dmesg | grep jumbo
[37027.685432] ath5k phy0: unsupported jumbo
[38462.863102] ath5k phy0: unsupported jumbo
[44390.762941] ath5k phy0: unsupported jumbo
[49163.566162] ath5k phy0: unsupported jumbo
[72370.910940] ath5k phy0: unsupported jumbo
[76083.488713] ath5k phy0: unsupported jumbo
[168572.002078] ath5k phy0: unsupported jumbo
[192528.656123] ath5k phy0: unsupported jumbo

$ uname -a
Linux ubuntu 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08 UTC 2010 i686 GNU/Linux

Note that this kernel doesn't have PCIEASPM enabled
$ grep PCIEASPM /boot/config-2.6.32-25-generic
# CONFIG_PCIEASPM is not set

$ lspci -knn
...
04:02.0 Ethernet controller [0200]: Atheros Communications Inc. AR5007G Wireless Network Adapter [168c:001d] (rev 01)
        Kernel driver in use: ath5k
        Kernel modules: ath5k

$ sudo lspci -vvv
...
04:02.0 Ethernet controller: Atheros Communications Inc. AR5007G Wireless Network Adapter (rev 01)
        Subsystem: Atheros Communications Inc. Device 2055
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 18
        Region 0: Memory at dcdf0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath5k
        Kernel modules: ath5k

Vince McIntyre (vmcintyr) wrote :

PS. this host is running 'lucid'.

Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.