Asus laptop hangs on TFT/VGA video switch (Fn-F8)

Bug #36885 reported by Nicolò Chieffo on 2006-03-27
28
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
High
Unassigned
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

ASUSTeK Computer Inc.
M6Ne
1.0

function hotkey ATKD 00000060

if I press that hotkey (fn + F8) the system hangs up with no debug message. this hotkey should switch between LCD/external monitor

Matthew Garrett (mjg59) wrote :

1) hotkey-setup doesn't handle ACPI hotkeys
2) a hang isn't something that can be fixed in acpi-support

What graphics driver are you using, and does this happen at the text console as well as in X?

Nicolò Chieffo (yelo3) wrote :

I'm using radeon driver (the default) and I have a radeon mobility 9700.
wait a minute and I'll tell you what happens.

Nicolò Chieffo (yelo3) wrote :

unfirtunately this is not an X issue, because the system hangs even without X running... :(

Paul Sladen (sladen) wrote :

Could you describe the hang in more detail?

Does:

  Caps-lock work (eg. change the LED)

  Alt-SysRq-s Alt-SysRq-u Alt-SysRq-b reboot the machine?

  Pressing Fn-F8 again (once/twice) solve the issue.

  Ctrl-Alt-Delete do a controlled reboot (eg. about ~60seconds)

  Removing and reinserting the power-cable.

  Closing the lid, suspending or hibernating do anything?

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info
Nicolò Chieffo (yelo3) wrote :

NOTHING is working! (except I don't know what "Alt-SysRq-s Alt-SysRq-u Alt-SysRq-b" is)

removing the power cable I realized that the LCD brightness doesn't dim. this is bad because LCD dim is a bios feature (this means that it works even if I'm at groob menu)
so this hangup is a very big hangup! next time I'll try if the cd ejects!

Nicolò Chieffo (yelo3) wrote :

I tried it with a monitod connected to my VGA connector.
Unfortunately I got the same results. (and the monitor was always black, after starting X and again after pressing the hotkey)

Nicolò Chieffo (yelo3) wrote :

is there anything else I can try? I've noticed that someone else is having the same problem (using debian, but the vanilla kernel seems not influenced by this bug)!
http://www.openlaptops.org/index.php/topic,89.0.html

Brad Pitcher (bradpitcher) wrote :

this might not be in the least related, but I reproduced the symptoms by renaming an event in /etc/acpi/events then pressing the hotkey for that event

Nicolò Chieffo (yelo3) wrote :

But no event is defined for video-switch hotkey!

Paul Sladen (sladen) wrote :

  Alt-SysRq-s Alt-SysRq-u Alt-SysRq-b

is Sync, Unmount, reBoot and is the lowest-level commands you can send to the kernel when it has crashed.

There is no event defined for video-switching, but the BIOS is still trying to perform the switch.

Can you drop to a console with:

  Ctrl-Alt-F1

and then run:

  sudo tail -f /var/log/messages

whilst trying to pressing the Fn-F8 key combination. Does anything get displayed on the console?

wait: I don't know if brad has my problem...
ths hotkey still completly blok my pc and I can't do anything! I will
try to see if logfile iss populated with something at the reboot...

Brad Pitcher (bradpitcher) wrote :

Yes, sorry for not being more clear. I do not experience the Fn-F8 bug. I just thought that what happened to me could have something to do with this bug since my symptoms seem to match exactly the ones Nicolò is experiencing.

Nicolò Chieffo (yelo3) wrote :

in my opinio this bug has to go back to major....

Nicolò Chieffo (yelo3) wrote :

this bug is in Edgy too!
I can't get any debug messages even after redirecting syslog *.* to /var/log/messages

Caspar Adriani (thecas) wrote :

Exact same problem here with the Asus M6n (M6000)

To get this bug back into rotation here are some more tests.
"tail -f messages" shows nothing when the combination is pressed.
Numlock or Capslock are not working
CD Drive can still opens (seems like the only thing that is still working)
Unplugged power cable does do nothing (no systembeep, no dimmed LCD)
special buttons aswell all function key combinations ain't working (e.g. wifi key(normally LED switches on press, dim LCD, suspend).
No keycombination seems to work (like ctrl+alt+del for a long time).
All that reboots the system again is pressing the power button for a couple of seconds.

This bug did not happened in Dapper only in Edgy (on this laptop)

Let me know if there is anything else to test

Nicolò Chieffo (yelo3) wrote :

I really don't know how to add further infos... I would be interested to see if using another distro will change the situation!

O.T.: Cas, are you having also this bug? https://launchpad.net/malone/29695

Nicolò Chieffo (yelo3) on 2006-11-18
Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
Nicolò Chieffo (yelo3) wrote :

This is not an acpi-support bug. It is a kernel one

Changed in acpi-support:
status: Needs Info → Rejected
Nicolò Chieffo (yelo3) wrote :

This bug affects ubuntu even if asus_acpi kernel module is unloaded. I'm testing it with feisty now, kernel 2.6.19

Nicolò Chieffo (yelo3) wrote :

Well, I tried to compile linux-source-2.6.19 with slax .config, which I include, and it works!!!!! The following step is to identify which component is causing the crash...
Can you help me?

Nicolò Chieffo (yelo3) wrote :

PARTIALLY RESOLVED!
Ok I've found which is the EVIL option which causes this issue: the local APIC support!
in fact if I boot with "nolapic" option the issue is definitely gone!

Changed in linux-source-2.6.19:
status: Unconfirmed → Confirmed
Changed in linux-source-2.6.17:
importance: Undecided → Medium
Changed in linux-source-2.6.19:
importance: Undecided → Medium
assignee: nobody → ubuntu-kernel-team
Nicolò Chieffo (yelo3) wrote :

Thank you Ben, I hope this bug will be fixed soon

Ben Collins (ben-collins) wrote :

Please retest against 2.6.20-2 when it is available in the feisty archive.

Changed in linux-source-2.6.19:
assignee: ubuntu-kernel-team → nobody
status: Confirmed → Needs Info
Nicolò Chieffo (yelo3) wrote :

2.6.20-1 has the same issue. I will wait for the version you told.

On 12/16/06, Ben Collins <email address hidden> wrote:
> Please retest against 2.6.20-2 when it is available in the feisty
> archive.
>
> ** Changed in: linux-source-2.6.19 (Ubuntu)
> Sourcepackagename: linux-source-2.6.19 => linux-source-2.6.20
> Assignee: Ubuntu Kernel Team => (unassigned)
> Status: Confirmed => Needs Info
>
> --
> Asus laptop hangs on TFT/VGA video switch (Fn-F8)
> https://launchpad.net/bugs/36885
>

Nicolò Chieffo (yelo3) wrote :

just tested it against 2.6.20-2 but the bug is still here

Changed in linux-source-2.6.20:
status: Needs Info → Confirmed
Ben Collins (ben-collins) wrote :

Please attach the output (do not paste into comment) of dmidecode so I can add nolapic by default for this system.

Thanks

Changed in linux-source-2.6.20:
status: Confirmed → Needs Info
Nicolò Chieffo (yelo3) wrote :

Thank you Ben, I can tell you that other models are affected by this bug such as the old asus M6N. And other new models might be affected too.
here you are

Nicolò Chieffo (yelo3) wrote :

Have you already uploaded the tweak for asus laptops?

Changed in linux-source-2.6.20:
importance: Medium → High
status: Needs Info → Confirmed
Nicolò Chieffo (yelo3) wrote :

also in dapper!

Changed in acpi-support:
status: Rejected → Confirmed
Changed in linux-source-2.6.20:
assignee: nobody → kyle
status: Confirmed → In Progress
Matthew Garrett (mjg59) wrote :

Does the problem happen if you unload the video module? If so, please attach the /proc/acpi/dsdt file.

Nicolò Chieffo (yelo3) wrote :

I was only able to remove the "radeon" module and "vesafb". No
"intel-agp" or "agpgart". I tried it from the recovery boot. Anyway
the problem persists without the "nolapic" boot parameter.

Matthew Garrett (mjg59) wrote :

No, can you try without the module called "video"?

Nicolò Chieffo (yelo3) wrote :

Oh! anyway it locks the same way :(

Nicolò Chieffo (yelo3) wrote :

this problem is also known here
http://acpi4asus.sourceforge.net/README

"Debugging:
  1) Check whether the Fn+F8 key:
     a) does not lock the laptop (try disabling CONFIG_X86_UP_APIC or boot with
        noapic / nolapic if it does)"

maybe you can try to contact the acpi4asus maintainer to have additional information...

Nicolò Chieffo (yelo3) wrote :

so I think there will be no fix for feisty...
Is it at least possible to disable lapic specifically for asus laptops?

Henrik Nilsen Omma (henrik) wrote :

Nicolò, could you please test this in Gutsy?

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Incomplete
Henrik Nilsen Omma (henrik) wrote :

At this point, we'll only fix this in Gutsy.

Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.17:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.20:
status: In Progress → Won't Fix
Nicolò Chieffo (yelo3) wrote :

I still need "nolapic"

Nicolò Chieffo (yelo3) wrote :

I have the same problems in fedora 8, with kernel 2.6.23 git

Changed in linux:
status: Unknown → In Progress
Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Incomplete → Confirmed
Changed in linux:
status: Confirmed → Incomplete
dencamp (denniscampbell73) wrote :

I am having the same problem. System is Gutsy. Kernel 2.6.22-14-generic. Asus M6700N. Alt-SysRq-s Alt-SysRq-u Alt-SysRq-b does not work.

dencamp (denniscampbell73) wrote :

Another thing: when using kernel parameter nolapic, Fn-F8 (hotkey ATKD 0000006x) does not show up using acpi_listen.

dencamp (denniscampbell73) wrote :

After playing around a bit I got the following:
When the radeon driver is being used and nolapic the Fn-F8 hotkey can be seen using acpi_listen.
Using nolapic, fglrx Fn-F8 has no effect when pressed and using acpi_listen.
So it seems to be also an issue with the fglrx driver (Version used is 8.42.3)

Changed in linux:
status: Incomplete → Confirmed
Changed in linux:
status: Confirmed → Incomplete

Hi Nicolo,

Care to test with the latest Hardy Alpha release and let us know your results? We'll keep this report open against the actively developed kernel but it will be closed against 2.6.22. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: Incomplete → Won't Fix
Nicolò Chieffo (yelo3) wrote :

It still happens

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in linux:
status: Incomplete → Invalid
Changed in linux:
status: Invalid → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → Invalid

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

mach6 (3384900078-tim) wrote :

[PARTIALLY RESOLVED]

I am running Ubuntu 8.04 with up-to-date 2.6.24.23-generic SMP kernel, on an Asus W7J.

I' ve found a partial solution for Fn+F8 key that works for me, but I need more help to close definitively the problem.

After some searches (over nights)....the solution for me is to disable "video" module :

sudo rmmod video

and then

sudo su

echo 5 > /sys/devices/platform/asus-laptop/display

EUREKA!!!

My Desktop is on TV screen with wonderful colors and simultaneously on my laptop-display.

But that's not the real solution.... : - (((

When I did in console:

(as root) echo 1 > /sys/devices/platform/asus-laptop/display ---> ONLY laptop-display at correct resolution working!!!

(as root) echo 5 > /sys/devices/platform/asus-laptop/display --> not LCD+TV with correct resolution as I expected, but LCD at correct resolution and TV in BLACK and WHITE at little resolution (I think 640x480)

Notes: After restart of X the problem is solved....but only for the first time I pass "echo 5 > /sys/devices/platform/asus-laptop/display"
...then the same situation descripted above.

I hope my step over is useful for someone, but I need help to completly correct this bug.

Thanks all for consideration.

I'm sorry for my bad english

Good day

Jeremy Foshee (jeremyfoshee) wrote :

Marking this Invalid for the linux package. Please report issues with this in Karmic /Lucid via a new bug with apport data attached.

-JFo

Changed in linux-source-2.6.20 (Ubuntu):
assignee: Kyle McMartin (kyle) → nobody
Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.