missing quirk entry for DELL Vostro A90

Bug #368629 reported by MaxScali on 2009-04-28
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Daniel T Chen

Bug Description

PC: DELL Vostro A90 (business version of mini9)
Tried everything form only forums, no solutions.
I hear NO sound at all, in any way. I tried pulse, padevchooser, gnome mixer, strings about alsa, everything....
In fact in sound > volume control I DO NOT SEE "speakers" column, and neither can't activate it.

It seems this to be the same issue as Bug 361878.
As like there, I'm running Jaunty with the latest updates as of today and with linux-restricted-modules and gstreamer doesn't seem to produce any sound. I tried running the gstreamer audio test with the following command but I can't hear any sound:

gst-launch-0.10 'audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink'

Here's what I already did:

what do you see in system -->prefrences -->sound
all devices set to pulseaudio, mixer set to playback hda intel
now is paddevchooser running, in the top right corner wher its running click on it and go to volume control
click on output devices
now you should see many things in there is the shield icon selected on all devices
I see only one thing: hda intel - alc268 analog
now leave that open and play an mp3 or some son file and just keep it on repeat
in the volume control for pulse clikc on playback
new module: totem movie player
do you see a little thing bounching also
nothing bounching. move stream > had intel alc-268 analog, nothing more
open a terminal
type in alsamixer
make sure every channel is unmuted use the m key to do that when your dont press esc
master, headphone, front, beep = 00
pcm, front mic, mic boost = nothing, not editable with m
in system-->administration--> sounds chnage the first one from pulse back to your intel alc one and press the test button
with hda intel alc268 analog (alsa): "audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback."
I have other options: oss, etc
same with hda intel alc268 analog (oss)
with ALSA no errors, but no sounds too
with OSS, same error as before
Stop

ap (apeee) on 2009-04-29
affects: ubuntu → linux (Ubuntu)
barney_1 (szczys) wrote :

I can confirm, no sound on my Dell Vostro A90 with a clean install of the Ubuntu Netbook Remix 9.04.

Here is an out put of lscpi -vnn

http://pastebin.ubuntu.com/165830/

Changed in linux (Ubuntu):
status: New → Confirmed
barney_1 (szczys) wrote :

I'm following the sound bug reporting procedure described at:
https://wiki.ubuntu.com/DebuggingSoundProblems

Here is the link generated from the sound hardware info gathering script:
http://www.alsa-project.org/db/?f=fc42f0b91287334d56ad2cb454f9ae2202eed904

further info:

When checking sound permissions my user account was NOT set to allow use of audio hardware. Adding these permissions did not solve the problem.

When trying different sound servers I get the following error when I click the test button with "HDA Intel ALC268 Analog (ALSA)" selected:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback.

Other options produce no error. Instead the testing window with an ok button appears as if the test sound were actually playing.

Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Audio Team (ubuntu-audio)
summary: - no sound in 9.04 on DELL mini9
+ no sound in 9.04 on DELL Vostro A90

This is the lspci -vnn output, about audio device:

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
 Subsystem: Dell Device [1028:02b2]
 Flags: bus master, fast devsel, latency 0, IRQ 22
 Memory at f0540000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

The problem is that "access denied" after "capabilities". THIS is the sole difference between this output and the Mini9 output, found on the web.

Maybe this helps?

Max

barney_1 (szczys) wrote :

If I run lscpci using sudo I get reports on the capabilities... is this a permissions issue? I am a member of the sound group.

sudo lspci -vnn

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
 Subsystem: Dell Device [1028:02b2]
 Flags: bus master, fast devsel, latency 0, IRQ 22
 Memory at f0540000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

John Keith Hohm (john-hohm) wrote :

I fixed the sound on my Vostro A90! The volume control now has a Speaker track and sound comes out of the speakers.

I tried "sudo apt-get install padevchooser ubuntu-restricted-extras", adding my user to pulse, pulse-access, and pulse-rt groups, and fiddling with the PulseAudio Device Chooser, but I'm pretty sure that didn't matter and what actually fixed it was:

sudo nano /etc/modprobe.d/alsa-base.conf

Add a line at the bottom "options snd-hda-intel model=dell" and reboot. No Ubuntu startup sound, but Rhythmbox plays music through the speakers (or headphones instead if I plug them into the jack).

I can confirm that the suggestion given by John Keith Hohm to add the line:

     options snd-hda-intel model=dell

To:

     /etc/modprobe.d/alsa-base.conf

Does improve the situation on Ubuntu 9.0.4 remix. After doing this I also have the "Speaker" option in the mixer.

I do not have any system sounds, however.

I did not do any of the pulse steps he mentioned.

barney_1 (szczys) wrote :

The alsa-base trick worked for me as well.

If I go to preferences/sounds and change from auto to OSS I can get some system sounds. If I try to test alsa in this window I get the same error as before.

This is a temporary workaround but certainly not a fix.

MaxScali (maxscali) wrote :

The alsa-based trick worked for me too, but simply rebooting I heard the system startup sound, and all sounds (system and music) were automatically enabled.....
Great!

In fact my installation is fresh, and I added no pulse nor other software: simply addede that line.

The alsa-base trick works for me too. It works in both Ubuntu 9.04 and Xubuntu 9.04. I can get the startup sound in Ubuntu 9.04. I don't have system sounds enabled in Xubuntu 9.04. My install is also fresh, no other sound related software has been installed.

Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
tasmarc (marcbeyer) wrote :

I've reported this bug too. Today the automatic update solved all my problems:) I'm a linux newbie, so I cant say what happened with my system. It seems like a "reset" of all audio drivers. However, sound = lucky:)

tasmarc (marcbeyer) wrote :

additional: In /etc/modprobe.d/alsa-base.conf I added this: options snd-hda-intel model=dell-m42. This works.

MaxScali (maxscali) wrote :

tasmarc, what do you mean with "solved"? In fact I do have sound since May, but it is not perfect yet: the system beeps while shutting down, and the volume is too sensible to the volume bar (system nearly silent with volume up to 50%, suddensly lound over 60%), and, third, if I leave volume over 60% I continously hear a kind of bzzzzz noise from the speakers.
With "solved" you speak about similar problems, or simply about the presence of sound?
Moreover, I have the followinf line added to /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel model=dell
and nt:
options snd-hda-intel model=dell-m42

Which is the difference?
Anyone more skilled than me (I'm quite new in Ubuntu too) can explain?
Tnx

Leo Milano (lmilano) wrote :

Same here with latest karmic. A couple comments/questions:

* Shouldn't this bug be moved to alsa-driver?
* There must be a config file for alsa where the different known cards are listed and assigned the proper driver, so the kernel loads the proper driver with the proper options at boot time. Evidently, autodetection is failing for this netbook, which is why we need to add "options snd-hda-intel model=dell". A

Leo Milano (lmilano) wrote :

I added alsa-driver as affected (and we should flag this as confirmed). This really belongs to Alsa:

http://www.alsa-project.org/main/index.php/Matrix:Module-hda-intel#The_module_options_for_snd-hda-intel

Leo Milano (lmilano) on 2009-10-14
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
M James RD (entropicgenesis) wrote :

confirmed for 9.10 unr in live mode.

Confirned in 9.10 Desktop.

The workaround mentioned above works.

Which quirk are you all using, and what're the contents of
/proc/asound/card0/codec#0 ? Please add as attachments.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Won't Fix
Changed in linux (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Daniel T Chen (crimsun)
summary: - no sound in 9.04 on DELL Vostro A90
+ missing quirk entry for DELL Vostro A90

What do you mean by a quirk? What we've done is add:

options snd-hda-intel model=dell

to /etc/modprobe.d/alsa-base.conf

tags: added: dell-vostro-a90
Daniel T Chen (crimsun) wrote :
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
el arya (n4ck0) on 2009-11-24
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers