Asus Eee wifi LED always on.

Bug #367690 reported by precision on 2009-04-27
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I've got the standard Ubuntu 9.04 desktop version installed on an Asus eee pc 900 netbook. This machine has 2 gigs of ram and a 16gb solid state drive.

(I Couldn't use the netbook version of ubuntu 9.04 because that requires an atom cpu, and I've got a celeron cpu.)

There is a blue wifi LED on the bottom-right corner of this machine. This light always stays on. This suggests that wireless is always enabled.

When I had desktop Ubuntu 8.10 installed in this machine, the blue LED turned off when wireless was not in use.

I've turned wifi off in the bios, and Ubuntu then turns it back on.

Pushing fn-f2 is supposed to turn off wireless, but it doesn't.

I've tried many software-based techniques to disable wireless support and thus shut off the blue LED. None of them has worked. The machine says wireless is turned off, but the blue LED stays on.

Hopefully someone will come up with a fix!

precision (algorithm13) on 2009-04-27
visibility: private → public
Marc Deslauriers (mdeslaur) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

security vulnerability: yes → no

rmmod ath5k && rmmod eeepc_laptop turns the WiFi LED off.

Add the following lines to /etc/modprobe.d/blacklist.conf to make it stick::

blacklist ath5k

blacklist eeepc_laptop

Hopefully this actually disables the wifi, since leaving the radio on is a potential security and privacy issue.

Live long and prosper

gcb (descartavel1) wrote :

eeepc 1000. 9.04 NBR.

after install, Fn+F2 does nothing.

I will not even try the rmmod now because I do not have another machine to check if radio is still up, so now way to confirm it it works or simply makes the kernel not see a hardware that is still on wasting battery.

I googled and found an acpi package specific to eeepc, but:
[code]
The following packages have unmet dependencies:
  eeepc-acpi-scripts: Depends: acpi-support-base but it is not installable
E: Broken packages
[/code]

Workaround:
when you are going to power up the laptop, enter bios with F2, disable wifi. No workaround to turn on again without another reboot.

On my system the eeepc_laptop kernel module was re-activating the WiFi in the BIOS and turning the WiFi LED on even though I had manually deactivated it in the BIOS on every boot.

Once I removed and blacklisted those two kernel modules it stopped activating the WiFi in the BIOS and WiFi LED.

If you modprobe eeepc_laptop then the WiFi LED should come on, and presumably the WiFi will be re-enabled, at least it seems to on my system.

Hope this helps.

Martin Emrich (emme) wrote :

I am also running 9.04 (Netbook Remix) on an Eee PC 900). Fn+F2 does nothing.

I can disable the wireless with (as root):
   echo 0 > /sys/class/rfkill/rfkill0/state
and reenable with
   echo 1 > /sys/class/rfkill/rfkill0/state

But after that, the wireless card will no longer work (reloading ath5k does not help either), and I get these in my dmesg:

[14699.454354] ath5k phy2: failed to wakeup the MAC Chip
[14699.454384] ath5k_pci 0000:01:00.0: PCI INT A disabled
[14699.462145] ath5k_pci: probe of 0000:01:00.0 failed with error -5

Changed in ubuntu:
status: New → Confirmed
Martin Emrich (emme) wrote :

I found the solution here:

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/182490

I had to add "pciehp_force=1" to my kernel options, note that this is advanced stuff, doing something wrong might leave your Ubuntu installation unbootable!

1. Edit your GRUB menu list:
   sudo gedit /boot/grub/menu.lst
2. Add the option: Search for "defoptions" and add the entry. the line should look like this (with the #):
   # defoptions=quiet splash pciehp_force=1
3. Save and exit the editor
4. Run
   sudo update-grub
5. Reboot

After that, you can enable/disable wireless as described above, or with eee-control (http://greg.geekmind.org/eee-control/ , Thanks to algorithm13 for the link!)

Philip Muškovac (yofel) wrote :

This is still broken on Lucid for me. Asus eeePC 1000H

summary: - In Ubuntu 9.04: Asus Eee wifi LED always on.
+ Asus Eee wifi LED always on.
Philip Muškovac (yofel) wrote :

This should be a kernel issue.

affects: ubuntu → linux (Ubuntu)
gcb (descartavel1) wrote :

eeepc 1000. ubuntu 10.10

fixed.

racecar56 (racecar56) wrote :

I notice this occasionally on my ASUS Eee PC 1201T. It could be that after suspend, it breaks, but I haven't confirmed that. Usually I suspend my netbook when I'm done with it.

madbiologist (me-again) wrote :

Racecar56: What version of Ubuntu are you using? Comment #10 seems to indicate this is fixed in Ubuntu 10.10 "Maverick Meerkat".

tags: added: jaunty lucid

precision, thank you for reporting this and helping make Ubuntu better. Jaunty reached EOL on October 23, 2010.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

tags: added: needs-upstream-testing
removed: asus eee light ubuntu wifi
tags: added: regression-release
tags: removed: lucid
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
rAtze (dankansuniversum) wrote :

i have a small solution!

i have the same problem with the lightning blue wlan led when the wlan is off and die led is still on
with fn+f2 i could on/off the wlan perfectly
the blue led is still on why the bluetooth is on!

the problem is the blurtooth keep on and also the blue led
disable also the bluetooth and the led goes off:

rfkill block bluetooth

rAtze (dankansuniversum) wrote :

but why the bluetooth dont goes also off when i press fn+f2 ?

rAtze, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers