Option 3g card wont work in 9.04

Bug #367597 reported by Nick Frost on 2009-04-26
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.28-11-generic

My 3g card wont work with this kernel. It is visible in network mananger applet, but it wont connect to the network.
After i changed to kernel 2.6.28-6-386 the problem was solved. Wireless network wont work with 2.6.28-6-386.

Can you please fix this?

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: linux-image-2.6.28-6-386 2.6.28-6.20
ProcEnviron:
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-ports
Uname: Linux 2.6.28-6-386 i686

Nick Frost (nick-frost) wrote :

Hi Kenneth.

Is this still an issue for you? If so, please attach the following information when running the 2.6.28-11 kernel:

sudo lspci -vnvn > lspci-vnvn.log
dmesg > dmesg.log

It would be best to wait to capture the dmesg output until after you've failed to connect to the network. Thanks.

Changed in linux (Ubuntu):
status: New → Incomplete

It might also be helpful to attach the dmesg output from the 2.6.28-6 kernel where this was working.

madbiologist (me-again) wrote :

If this is still not working in Ubuntu 9.10 "Karmic Koala" and also not working in Ubuntu 10.04 "Lucid Lynx" alpha 3 (you can try a Live CD of the latter), kernel 2.6.34-rc1 may assist you.

From the changelog:

commit 46216e4fbe8c62059b5440dec0b236f386248a41
Author: Jan Dumon
Date: Tue Jan 5 15:53:26 2010 +0100

    USB: unusual_devs: Add support for multiple Option 3G sticks

    Enable the SD-Card interface on multiple Option 3G sticks.
    The unusual_devs.h entry is necessary because the device descriptor is
    vendor-specific. That prevents usb-storage from binding to it as an interface
    driver.

    Signed-off-by: Jan Dumon
    Signed-off-by: Phil Dibowitz
    Cc: stable
    Signed-off-by: Greg Kroah-Hartman

There is a PPA with this kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Note that this has been cc'd to stable, so it might turn up in a 2.6.32.x kernel eventually.

madbiologist (me-again) wrote :

The abovementioned patch was included in Ubuntu kernel 2.6.32-17.26. After unmounting the usb storage part of the device hopefully you can connect to the network.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers