[HP nx9010] laptop won't resume from suspend

Bug #367184 reported by cocjh1 on 2009-04-26
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Never successfully managed to get suspend or hibernation working with my laptop whilst host O/S is Ubuntu. Recently installed 9.04 (Jaunty) and noticed this wiki page:
[url]https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting[/url]

Followed the instructions for starting Apport and then ran:
> sudo bash /usr/share/checkbox/scripts/suspend_test --full

First test was a 20 sec suspend:
1) My laptop suspended ok, but failed to wake-up/resume.
2) It is very repeatable, failing at the same point.
3) Both suspend and hibernate have worked with MS Windows but never Ubuntu.
4) No flashing caps lock. Once resume started fans came on, hard drive light flickered once, but no display.
5) Battery was about 60% full, but for first test AC cord was attached.

Let me know if you need any more info from my setup. Hopefully the Apport report gets attached here...

ProblemType: KernelOops
Annotation: This occured during a previous suspend and prevented it from resuming properly.
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=727783a0-92c4-4471-b6f4-8314ec1b57bb
InterpreterPath: /usr/bin/python2.6
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Hewlett-Packard HP nx9010 (DJ347A)
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
ProcAttrCurrent: unconfined
ProcCmdLine: root=UUID=5b4dc8a2-8266-4def-aa6c-a1472775749d ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
SourcePackage: linux
Tags: resume suspend
Title: [Hewlett-Packard HP nx9010 (DJ347A)] suspend/resume failure
UserGroups:

cocjh1 (chris-harpley) wrote :
affects: ubuntu → linux (Ubuntu)
Andy Whitcroft (apw) wrote :

Could you please follow the triage and debugging guide (https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume) and report back here. From the logs attached it seems we got all the way to suspend and never came back at all, so you can probabally skip to the more detailed debugging later in the page. Thanks!

summary: - HP nx9010 laptop won't resume from suspend
+ [HP nx9010] laptop won't resume from suspend
Changed in linux (Ubuntu):
status: New → Incomplete
cocjh1 (chris-harpley) wrote :

1) Enbled pm_trace and enter suspend by issuing pm-suspend
2) Laptop suspended nicely
3) Pressed power button to resume. CPU fan came on, hard disk light did not light, no video back light.
4) Held down power button to switch off laptop.

Attached here is the output of dmesg following a restart.

cocjh1 (chris-harpley) wrote :

For some reason I've never tried hibernation but yesterday noticed this actually works! Computer shuts down and happily restarts when I request it. One minor problem is the PCMCIA wireless card doesn't automatically re-initialise, but I can live with that.

Vish (vish) wrote :

Thanks for following up. This bug report is being closed due to your last comment regarding this being a non-issue. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid

Quit losing money in the stock market.
Last year our penny stock picks returned over 600% combined!
Time to make a change in your investment strategies.

Totally Free Newsletter.

--->>> www.awesomebeststocksnow.com

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers