[Jaunty] Upgrade to Jaunty => HDA Intel (ICH7) sound broken

Bug #366805 reported by Swâmi Petaramesh on 2009-04-25
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by tak

Bug Description

Machine : Asus EeePC 1002HA

Sound Chipset:

root@xtro:/etc/modprobe.d# lspci -s 00:1b.0 -v

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: ASUSTeK Computer Inc. Device 834a
[...]
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Symptom :

- Worked perfectly in Intrepid without any configuration pain

- Doesn't work anymore after upgrade to Jaunty - NO SOUND.

- Almost all mixer controls have disappeared from Alsa mixer, except for "PCM" and "LineOut", but they don't allow producing any sound.

- No more "Master" "Front", etc, controls.

(Addl Information : I also have a Dell XPS M1330 With Intel ICH8. On this one sound works after Jaunty upgrade, however the "PCM" slider control has no effect anymore (moving it is ignored), but PCM sound is there.)

affects: ubuntu → linux (Ubuntu)

After exploring a bit the available models choices in kernel source's Alsa source code (a pity it seems undocumented besides the available models listed in the source code), I tried in /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=eeepc-p901

Which seemed to be the closest hardware to what I have, but it didn't help. Still no sound and few useless cursors in the mixer...

I could in the end get some sound out by:

- Enabling a so-called "iSpeaker" switch
- Pushing up "Line-out" control

However on this machine my mixer only shows the following controls :

- PCM (Volume slider)
- LineOut (Volume slider + mute switch)
- iSpeaker (mute switch only)
- Capture (Volume slider + active switch)

It seems I can get sound only if everything is unmuted, and the actual output volume is the sum of LineOut + PCM.

No more "Master volume" control, no more "Front" volume control, and the "LineOut" that acts on volume where I woulnd't have expected it to.

Okay I can produce sound, but the controls are both very poor and surprising...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers