no sound Intel Corporation 82801G (ICH7 Family)

Bug #366626 reported by Maarten Vandebroek on 2009-04-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

There is no sound with any application. Also no systemsounds.
I have installed ubuntu 9.04

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Wistron Corp. Device 4071
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at d8440000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

affects: ubuntu → alsa-lib (Ubuntu)
Ivan Ivanoff (spammeroff) wrote :

I added in /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel model=fujitsu
sudo /etc/init.d/alsa-utils restart
...
PROFIT!

Though it must work automatically, you can put Your model or other options there - in model=.
I have Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02) at my fujitsu siemens amilo xi1546.

schnupfy (schnupfy) wrote :

Had the same issue with my amilo xi1546, please add into ubuntu installer.

Cheers,
Marcus

Pascal Terjan (pterjan42) wrote :

Please give the output of the following command on the machines needing this parameter

grep -E '^(Codec|Subsystem Id)' /proc/asound/card*/codec#*

This is the output of the command.

/proc/asound/card0/codec#0:Codec: Realtek ALC883
/proc/asound/card0/codec#0:Subsystem Id: 0x17c04080
/proc/asound/card0/codec#1:Codec: Motorola Si3054
/proc/asound/card0/codec#1:Subsystem Id: 0x10573055

-----Oorspronkelijke bericht-----
Van: Pascal Terjan <email address hidden>
Reply-to: Bug 366626 <email address hidden>
Aan: <email address hidden>
Onderwerp: [Bug 366626] Re: no sound Intel Corporation 82801G (ICH7
Family)
Datum: Fri, 18 Sep 2009 09:28:11 -0000

grep -E '^(Codec|Subsystem Id)' /proc/asound/card*/codec#*

Pascal Terjan (pterjan42) wrote :

Thanks marteen but then the other comments don't apply, your card can not need this parameter and it does not enter into the "machines needing this parameter" list I need, sorry.

Can you try with other model ?
Like model=medion or model=medion-md2 or model=lenovo-ms7195-dig ?

The full list is :

3stack-2ch-dig
3stack-6ch-dig
3stack-6ch
alc883-6stack-dig
targa-dig
targa-2ch-dig
targa-8ch-dig
acer
acer-aspire
medion
medion-md2
laptop-eapd
lenovo-101e
lenovo-nb0763
haier-w66
mitac
clevo-m720
fujitsu-pi2515
3stack-6ch-intel

If one of them work completly please report which, and the name of your computer

mcsd (matthias-a-johnson) wrote :

Codec: Realtek ALC269
Subsystem Id: 0x1043831a

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: ASUSTeK Computer Inc. Device 831a
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f7eb8000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

on Eeepc 1000H

Daniel T Chen (crimsun) on 2010-01-31
affects: alsa-lib (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers