PS/2 Keyboard stops working after soft reset

Bug #366473 reported by Julian Lam on 2009-04-25
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
xserver-xorg-input-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Running an old computer here, with a standard IBM KB-7353 PS/2 Keyboard. The keyboard input stops working after a soft reset (and only after a soft reset)! Hard resets configure the keyboard properly.

Problem also occurs on a different Compaq PS/2 keyboard. Have not tried using a USB keyboard, but I´d expect it to work properly.

I tried toggling numlock on and off during boot to see exactly when it stops working (as the keyboard works in the BIOS and during the GRUB bootloader), and the keyboard stops responding right after the xubuntu usplash pops up, and the OS starts loading.

Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xorg 1:7.4~5ubuntu18
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xorg
Uname: Linux 2.6.28-11-generic i686
XorgConf:

Julian Lam (julian-lam) wrote :
Julian Lam (julian-lam) wrote :

Of note: Please note that XorgLog.txt shows the keyboard being set-up properly after a hard reset.

Also, XorgLogOld.txt refers to a bootup after a soft reset. Note that the keyboard setup is absent.

Timo Aaltonen (tjaalton) wrote :

that's a kernel bug.

Changed in xserver-xorg-input-keyboard (Ubuntu):
status: New → Invalid
affects: xorg (Ubuntu) → linux (Ubuntu)
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

from the XorgLog.txt (almost at the end of the log):

(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) AT Translated Set 2 keyboard: xkb_model: "pc105"
(**) Option "xkb_layout" "us"
(**) AT Translated Set 2 keyboard: xkb_layout: "us"
(**) Option "xkb_variant" "intl"
(**) AT Translated Set 2 keyboard: xkb_variant: "intl"
(**) Option "xkb_options" "lv3:ralt_switch"
(**) AT Translated Set 2 keyboard: xkb_options: "lv3:ralt_switch"

Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: linux

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers