[SAMSUNG ELECTRONICS CO.,LTD R50/R51] suspend/resume failure (ati x700)

Bug #366060 reported by Mario Hock on 2009-04-24
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I'm pretty sure, it's about the ati driver.
In Intrepid I had the same issue, but at that time there still existed the fglrx driver which worked fine.

ProblemType: KernelOops
Annotation: This occured during a previous suspend and prevented it from resuming properly.
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
InterpreterPath: /usr/bin/python2.6
MachineType: SAMSUNG ELECTRONICS CO.,LTD R50/R51
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
ProcAttrCurrent: unconfined
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.gz quiet splash -- debian-installer/language=de console-setup/layoutcode?=de
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
SourcePackage: linux
Tags: resume suspend
Title: [SAMSUNG ELECTRONICS CO.,LTD R50/R51] suspend/resume failure
UserGroups:

Mario Hock (mariohock) wrote :

Hi all,

Can you please fill a little form, with questions contained in this wiki? https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume

It will definitely help developers to find the fix or help you to detect that you don't really have real bug. Please, pay special attention to the "Encrypted Home-Swap" issue and the flashing caps-lock.

Information below, will also help you

https://wiki.ubuntu.com/UnderstandingSuspend

I'd also encourage you to try this tests https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting to gather more information to developers

Thank you in advance.

tags: added: jaunty
Changed in linux (Ubuntu):
status: New → Incomplete
Mario Hock (mariohock) wrote :

At first, I'm using Karmic now.
Hibernate works fine. The problems occurs only when wake up from suspend (to ram).

Did the machine break while going to sleep or waking up?
 - On wakeup. The Display remains black. (Lights-Off) The kernel seems not to hang or panic.

Is it reproducible?
 - 100% :-(

Did it work before?
- As said, when using fglrx instead of the open source ati driver, suspension worked fine.

Do you end up with flashing caps-lock or similar?
- sometimes <Alt> - <Ctrl> - [Del] or even reboot [enter] worked

Please ask if you need more information.
Thank you for working on this bug report.

Can you please, try a last test before Triaging the bug?

Can you try with last kernel version, (Lucid upstream) which is located on http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32/?

Thanks in advance.

tags: added: karmic
Mario Hock (mariohock) wrote :

Can I just add the kernel into my Ubuntu Karmic, or do I need the Lucid Alpha?
If I need Lucid, is it possible to add the Kernel into a live-usb-stick?

Thank you.

Mario,

You can safely donwload your .deb's (x64 or i386) from this page, and just install them on your Karmic system with a double click. gDebi will take care of dependencies, and all will manage to add a new (really two) new GRUB options, where you can run your tests.

After this, you can start with a 2.6.31-xx kernel, and delete all 2.6.32 reference from Synaptic.

Thats all.

Thanks in advance for help making Ubuntu better.

Mario Hock (mariohock) wrote :

Still the same on the new kernel.

By the way: If I suspendet from Console (Alt-Ctrl-F1) I can (blind) type "sudo reboot" and it reboots. But the display stays black (until I'm back in the bios). Suspend from X11 seems to hang the system on wakeup.

If you need further information or testing, please ask.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers