upgrade ->9.04 (2.6.28-11) breaks video capture

Bug #365979 reported by Earl on 2009-04-24
2
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

adding newest info at the top
-----------------------------------------
update 24 April 16h38
1- a friend says:
"the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm."

2- my test computer is a DELL Mini-9

3- cheese works ok and shows video

4- result of v4l-info

# v4l-info

### v4l2 device info [/dev/video0] ###
general info
    VIDIOC_QUERYCAP
 driver : "uvcvideo"
 card : "Laptop_Integrated_Webcam_0.3M"
 bus_info : "0000:00:1d.7"
 version : 0.1.0
 capabilities : 0x4000001 [VIDEO_CAPTURE,STREAMING]

standards

inputs
    VIDIOC_ENUMINPUT(0)
 index : 0
 name : "Camera 1"
 type : CAMERA
 audioset : 0
 tuner : 0
 std : 0x0 []
 status : 0x0 []

video capture
    VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
 index : 0
 type : VIDEO_CAPTURE
 flags : 0
 description : "YUV 4:2:2 (YUYV)"
 pixelformat : 0x56595559 [YUYV]
    VIDIOC_G_FMT(VIDEO_CAPTURE)
 type : VIDEO_CAPTURE
 fmt.pix.width : 352
 fmt.pix.height : 288
 fmt.pix.pixelformat : 0x56595559 [YUYV]
 fmt.pix.field : NONE
 fmt.pix.bytesperline : 704
 fmt.pix.sizeimage : 202752
 fmt.pix.colorspace : SRGB
 fmt.pix.priv : 0

controls
    VIDIOC_QUERYCTRL(BASE+0)
 id : 9963776
 type : INTEGER
 name : "Brightness"
 minimum : -64
 maximum : 64
 step : 1
 default_value : 0
 flags : 0
    VIDIOC_QUERYCTRL(BASE+1)
 id : 9963777
 type : INTEGER
 name : "Contrast"
 minimum : 0
 maximum : 95
 step : 1
 default_value : 0
 flags : 0
    VIDIOC_QUERYCTRL(BASE+2)
 id : 9963778
 type : INTEGER
 name : "Saturation"
 minimum : 0
 maximum : 100
 step : 1
 default_value : 64
 flags : 0
    VIDIOC_QUERYCTRL(BASE+3)
 id : 9963779
 type : INTEGER
 name : "Hue"
 minimum : -2000
 maximum : 2000
 step : 1
 default_value : 0
 flags : 0

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
 name : "Laptop_Integrated_Webcam_0.3M"
 type : 0x1 [CAPTURE]
 channels : 1
 audios : 0
 maxwidth : 640
 maxheight : 480
 minwidth : 48
 minheight : 32

channels
ioctl VIDIOCGCHAN: Invalid argument

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
    VIDIOCGPICT
 brightness : 32768
 hue : 32768
 colour : 41942
 contrast : 0
 whiteness : 0
 depth : 16
 palette : YUYV

buffer
ioctl VIDIOCGFBUF: Invalid argument

window
    VIDIOCGWIN
 x : 0
 y : 0
 width : 352
 height : 288
 chromakey : 0
 flags : 0

root@EL-Mini-9:~#

===================================
TEST: using SIP-COMMUNICATOR build 1864
with kernel 2.6.27-11-generic, as SIP-COMMUNICATOR loads into memory, it searches for a video device which causes the Webcam LED to flash quickly. Later under options, clicking on the media tab will activate the Webcam and show local video in a window while Webcam LED lights continuously.

Upgrading to 9.04 results in kernel 2.6.28-11-generic breaking the video capture. The Webcam LED does not flash on loading, nor does the Webcam work after loading the program.

For both kernels, I have extracted all lines with the word civil from the log files.
SIP-COMMUNICATOR is written in java and the video device is found at civil:/dev/video0:0.
===================
log with kernel 2.6.28-11-generic #42 Ubuntu 9.04 updated+upgraded to 24 March 2009
this kernel breaks java video capture, kernel 2.6.27-11-generic works ok

FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added civil:/dev/video0
10:19:40.816 FINEST: impl.media.device.JmfDeviceDetector.setupJMF().368 [exit] setupJMF
10:19:40.817 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().106 Scanning for configured Audio Devices.
10:19:40.819 FINE: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().118 Found 1 capture devices: [Ljavax.media.CaptureDeviceInfo;@16f3619
10:19:40.820 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().137 Found JavaSound audio capture as an audio capture device.
10:19:40.820 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145 Scanning for configured Video Devices.
10:19:40.822 INFO: impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186 Found civil:/dev/video0:0 as an RGB Video Device.

10:19:41.481 INFO: impl.media.MediaControl.createDataSource().582 Creating datasource for:civil:/dev/video0
10:19:41.497 FINE: fmj.connect() civil: connect
10:19:41.500 FINE: fmj.connect() Opening /dev/video0

10:19:42.154 FINE: fmj.connect() civil: connect

10:19:43.261 FINE: fmj.start() civil: start
10:19:43.265 FINE: lti-civil.run() NativeCaptureStreamThread running
10:19:43.272 FINE: fmj.stop() civil: stop
10:19:43.282 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.protocol.sip.acc1240265069692.PROXY_PORT( oldValue=5060, newValue=5060.
10:19:43.284 SEVERE: lti-civil.run() com.lti.civil.CaptureException: fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
 at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
 at com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)
10:19:43.285 FINE: lti-civil.run() NativeCaptureStreamThread exiting

10:20:04.094 FINE: fmj.connect() civil: connect
10:20:04.097 FINE: fmj.connect() Opening /dev/video0
10:20:04.212 FINE: fmj.start() civil: start
10:20:04.234 FINE: lti-civil.run() NativeCaptureStreamThread running
10:20:04.236 SEVERE: lti-civil.run() com.lti.civil.CaptureException: fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
 at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
 at com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)
10:20:04.237 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:20:04.239 FINE: fmj.stop() civil: stop
10:20:04.456 FINE: fmj.stop() civil: stop
10:20:04.458 FINE: fmj.start() civil: start
10:20:11.627 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.width( oldValue=653, newValue=653.
10:20:11.646 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.height( oldValue=550, newValue=550.
10:20:11.662 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.x( oldValue=367, newValue=367.
10:20:11.678 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.y( oldValue=25, newValue=25.
10:20:11.695 FINE: fmj.stop() civil: stop
10:20:11.699 FINE: fmj.stop() civil: stop
10:20:11.710 FINE: fmj.stop() civil: stop
10:20:11.712 FINE: fmj.disconnect() civil: disconnect
10:20:11.714 FINE: fmj.stop() civil: stop

10:20:20.329 FINE: fmj.stop() civil: stop

=====================================
log with 2.6.27-11-generic #42 Ubuntu 9.04 updated+upgraded to 24 March 2009

10:38:19.370 FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added civil:/dev/video0
10:38:19.377 INFO: impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186 Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.375 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145 Scanning for configured Video Devices.
10:38:19.377 INFO: impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186 Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.630 INFO: impl.media.MediaControl.createDataSource().582 Creating datasource for:civil:/dev/video0
10:38:19.645 FINE: fmj.connect() civil: connect
10:38:19.649 FINE: fmj.connect() Opening /dev/video0
10:38:20.092 FINE: fmj.connect() civil: connect
10:38:20.783 FINE: fmj.start() civil: start
10:38:20.800 FINE: impl.protocol.sip.OperationSetPresenceSipImpl.<init>().272 presence initialized with :true, true, 30, 3600 for null
10:38:20.818 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:20.842 FINE: fmj.stop() civil: stop
10:38:42.506 FINE: fmj.connect() civil: connect
10:38:42.508 FINE: fmj.connect() Opening /dev/video0
10:38:42.533 FINE: fmj.start() civil: start
10:38:42.536 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:42.537 FINE: fmj.stop() civil: stop
10:38:42.830 FINE: fmj.stop() civil: stop
10:38:42.832 FINE: fmj.start() civil: start
10:38:50.585 FINE: fmj.stop() civil: stop
10:38:50.610 FINE: fmj.stop() civil: stop
10:38:50.611 FINE: fmj.stop() civil: stop
10:38:50.613 FINE: fmj.disconnect() civil: disconnect
10:38:50.614 FINE: fmj.stop() civil: stop
10:38:50.728 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:38:59.435 FINE: fmj.stop() civil: stop

Michael Vogt (mvo) on 2009-04-24
affects: ubuntu → linux (Ubuntu)
Earl (large-files) on 2009-04-24
description: updated
Jeremy Foshee (jeremyfoshee) wrote :

Hi Earl,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 365979

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers