keyboard doesn't not work on resume from suspend

Bug #365896 reported by Ebben Feagan on 2009-04-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Using Jaunty on i386, Laptop is Compaq Evo N800c. Keyboard doesn't respond after suspend. Didn't test integrated touchpad, USB mouse works.

affects: ubuntu → xserver-xorg-input-keyboard (Ubuntu)
Samee (samee-zahur) wrote :

As noted, I reported a possible duplicate as bug#367823. I have the same problem on my Compaq C300 laptop. I might, however, add that Hibernate never seems to fail. If you need any other info to reproduce/track this bug, please do let me know.

Samee (samee-zahur) wrote :

I tried a little experiment on this:
> sudo /etc/init.d/gdm stop

Then, from another virtual terminal (switching with CTRL-ALT-F1)
> sudo pm-suspend

As was previously the case, the system went to the suspend state. Hitting the power button started waking it up. The screen came back, along with the usual command prompt, blinking cursor and all that. But the keyboard/touchpad still stayed frozen. No CAPS LOCK led response. Nothing. In short, the problem stays even in text-mode

Now, since the 'gdm stop' is there, doesn't this mean this problem has nothing to do with X-server?

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Samee (samee-zahur) wrote :

Ok,
So I updated to Karmic Koala, and the problem still persists. Today I tried another experiment: when it resumes and displays the password dialog, I tried attaching a USB mouse to the laptop. And it worked! The pointer started moving in response to the USB mouse, even though the touchpad stayed non-responsive. I'm guessing a USB keyboard would have worked just as well.

The keyboard/mouse initialization on resume isn't working like it is supposed to.

Timo Aaltonen (tjaalton) wrote :

Try lucid alpha1 livecd.

affects: xserver-xorg-input-keyboard (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Incomplete
Samee (samee-zahur) wrote :

Finally, somebody answering!
Anyway, while I will get to downloading that CD image, the thing is I have a 10KB/s unstable internet connection on which download takes a while. If there is any particular package/driver that I you think I should upgrade, I could just download that one instead.

To summarize my problem:
Resume from suspend/hibernate both causes keyboard/touchpad to become non-responsive (previously I thought hibernate is not a problem, but now I realize it is). However, I can still press the power button for a clean shutdown, or attach a USB mouse, which works fine; but the keyboard/touchpad attached to the laptop stays unresponsive till a restart. I tested it with x-server shut down (see above), and the problem still exists, meaning it probably has nothing to do with x-server.

Likely culprit in my view: something in the device re-initialization codes. But don't have enough knowhow about hardware issues to zero it down any further. Since I am a programmer, any pointer to where I might find the sources for the likely packages involved and the docs for API, I might be able to help myself here.

Bryce Harrington (bryce) wrote :

Well, more likely to be a kernel issue

affects: xserver-xorg-input-evdev (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New

I have similar Problem with my HP Pavilion dv6-1160eg. Resume from hibernate, everything is OK. Resuming from suspend, touchpad is working but the keyboard is not responsive.

Sorry my Notebook is a dv7-1160eg.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Ebben,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command from a Terminal (Applications->Accessories->Terminal) it will automatically gather and attach updated debug information to this report.

apport-collect -p linux 365896

Also, please be sure to take a look at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume . If you can provide any additional information outlined there it would be much appreciated.

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers