Add support for newer Novatel devices to airprime driver

Bug #365291 reported by Jeremy Zimmer on 2009-04-22
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Tim Gardner
Nominated for Intrepid by Mike Grundy
Nominated for Jaunty by Mike Grundy
Hardy
Medium
Brad Figg
Karmic
Low
Tim Gardner

Bug Description

SRU Justification:

Impact: Addition of new device signatures should have no impact to existing devices.

Fix: Simple addition of two device signatures to the device id table.

Testcase: See bug report

---

Binary package hint: linux-image-2.6.24-23-generic

I'm pretty sure the older U727 is correctly recognized by airprime:

     { USB_DEVICE(0x1410, 0x4100) }, /* Novatel Wireless U727 */

I've found a later revision of the U727 with a different product string, and the U760 has yet another different string. Support is enabled by adding the following lines to airprime.c and recompiling the module.

   { USB_DEVICE(0x1410, 0x5100) }, /* Novatel Wireless U727 newer */
   { USB_DEVICE(0x1410, 0x6000) }, /* Novatel Wireless U760 */

Patched airprime.c attached

Thanks,
 Jeremy

Brad Figg (brad-figg) wrote :

SRU Justification:

Impact: Addition of new device signatures should have no impact to existing
devices.

Fix: Simple addition of two device signatures to the device id table.

Testcase: See bug report

Changed in linux (Ubuntu):
assignee: nobody → brad-figg
status: New → In Progress
Stefan Bader (smb) on 2009-06-03
Changed in linux (Ubuntu Hardy):
assignee: nobody → Brad Figg (brad-figg)
importance: Undecided → Medium
status: New → Fix Committed
description: updated
Steve Beattie (sbeattie) on 2009-06-30
tags: added: hw-specific verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-24.56

---------------
linux (2.6.24-24.56) hardy-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.24-24.54 with 2.6.24-24.55 security release applied

linux (2.6.24-24.54) hardy-proposed; urgency=low

  [Andy Whitcroft]

  * SAUCE: do not make sysdev links for processors which are not booted
    - LP: #295091

  [Brad Figg]

  * SAUCE: Add information to recognize Toshiba Satellite Pro M10 Alps Touchpad
    - LP: #330885
  * SAUCE: Add signatures to airprime driver to support newer Novatel devices
    - LP: #365291

  [Stefan Bader]

  * SAUCE: vgacon: Return the upper half of 512 character fonts
    - LP: #355057

  [Upstream Kernel Changes]

  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #341783, #212485
  * Input: atkbd - mark keyboard as disabled when suspending/unloading
    - LP: #213988
  * x86: mtrr: don't modify RdDram/WrDram bits of fixed MTRRs
    - LP: #292619
  * sis190: add identifier for Atheros AR8021 PHY
    - LP: #247889
  * bluetooth hid: enable quirk handling for Apple Wireless Keyboards in
    2.6.24
    - LP: #227501
  * nfsd: move callback rpc_client creation into separate thread
    - LP: #253004
  * nfsd4: probe callback channel only once
    - LP: #253004

 -- Stefan Bader <email address hidden> Sat, 20 Jun 2009 00:14:36 +0200

Changed in linux (Ubuntu Hardy):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
assignee: Brad Figg (brad-figg) → Tim Gardner (timg-tpi)
importance: Undecided → Low
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-4.20

---------------
linux (2.6.31-4.20) karmic; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: iscsitarget -- update to SVN revision r214
  * SAUCE: iscsitarget -- renable driver
  * [Config] consolidate lpia/lpia and i386/generic configs
  * [Config] enable CRYPTO modules for all architectures
  * [Config] enable cryptoloop
  * [Config] enable various filesystems for armel
  * [Config] sync i386 generic and generic-pae
  * [Config] add the 386 (486 processors and above) flavour
  * [Config] re-set DEFAULT_MMAP_MIN_ADDR
    - LP: #399914
  * add genconfigs/genportsconfigs to extract the built configs
  * updateconfigs -- alter concatenation order allow easier updates
  * intelfb -- INTELFB now conflicts with DRM_I915
  * printchanges -- rebase tree does not have stable tags use changelog
  * AppArmor: fix argument size missmatch on 64 bit builds

  [ Ike Panhc ]

  * Ship bnx2x firmware in nic-modules udeb
    - LP: #360966

  [ Jeff Mahoney ]

  * AppArmor: fix build failure on ia64

  [ John Johansen ]

  * AppArmour: ensure apparmor enabled parmater is off if AppArmor fails to
    initialize.
  * AppArmour: fix auditing of domain transitions to include target profile
    information
  * AppArmor: fix C99 violation
  * AppArmor: revert reporting of create to write permission.
  * SAUCE: Add config option to set a default LSM
  * [Config] enable AppArmor by default
  * AppArmor: Fix NULL pointer dereference oops in profile attachment.

  [ Keith Packard ]

  * SAUCE: drm/i915: Allow frame buffers up to 4096x4096 on 915/945 class
    hardware
    - LP: #351756

  [ Luke Yelavich ]

  * [Config] add .o files found in arch/powerpc/lib to all powerpc kernel
    header packages
    - LP: #355344

  [ Michael Casadevall ]

  * [Config] update SPARC config files to allow success build

  [ Scott James Remnant ]

  * SAUCE: trace: add trace_event for the open() syscall

  [ Stefan Bader ]

  * SAUCE: jfs: Fix early release of acl in jfs_get_acl
    - LP: #396780

  [ Tim Gardner ]

  * [Upstream] Fix Soltech TA12 volume hotkeys not sending key release
    - LP: #397499
  * [Upstream] USB Option driver - Add USB ID for Novatel MC727/U727/USB727
    refresh
    - LP: #365291
  * [Config] SSB/B44 are common across all arches/flavours.

  [ Upstream ]

  * Rebased to 2.6.31-rc4

 -- Andy Whitcroft <email address hidden> Thu, 23 Jul 2009 08:41:39 +0100

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
zertz (zertz) wrote :

i have no useful information regarding whether this device works in karmic however i was wondering if anyone would confirm the addition to the "fix released" status means that this device would be functional under karmic alpha 4?

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers