LAN does not function with Acer Aspire One D250

Bug #363691 reported by bb on 2009-04-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The wired network interface does not function with the following configuration:
Hardware:
Acer Aspire One D250,
Internal network interface is Atheros AR8132 (vendor id 0x1969, device id 0x1062)
Software:
Ubuntu Netbook Remix from jaunty nightly builds, linux kernel 2.6.28

I have build the Ubuntu kernel 2.6.29 and 2.6.30 from source with the experimental atl1c driver module. The network device is detected but it does not function.
The command ifconfig shows the eth0 interface but there are many errors and collisions detected. If I remove the driver and do a second modprobe atl1c, the system hangs.
The drivers are described here: http://www.hogchain.net/attansic/attansic.html
Drivers from the vendor can be find here: http://partner.atheros.com/Drivers.aspx

bb (bjoern-kiefer) on 2009-04-19
description: updated
summary: - LAN does not function with Acer Acpire One D250
+ LAN does not function with Acer Aspire One D250
bb (bjoern-kiefer) wrote :

I got a new driver atl1e from atheros that works perfectly. The patch will be added to the next kernel versions.

James Hunt (jamesodhunt) wrote :

I have the same symptoms (no ethernet when cable plugged into D250). I'm running 2.6.28-13-generic.

Please can you provide an approximate ETA for this new kernel?

Thanks.

bb (bjoern-kiefer) wrote :

This problem is solved by the drivers which can be downloaded on the vendor's website:
http://partner.atheros.com/Drivers.aspx

Please download one of the AR81Family Linux Drivers:
[459]AR813X-linux-v1.0.0.9.tar.gz
Or:
AR81Family-linux-v1.0.1.0.tar.gz

It is easy to build and install the driver. The installation procedure is described in a readme file.
Yet, I cannot say, which Ubuntu kernel version will contain the fix.

Risto H. Kurppa (risto.kurppa) wrote :

Confirm here, on D250 didn't work on UNR out of the box, after installing the new [459]AR813X it worked smoothly. I wish someone created a .deb for this driver (well of course kernel support would be nicer :)

Andres Alonso (andresalonso-a) wrote :

The wired network still with problems in karmic beta. ifconfig not show eth0.

mac (amartin83) wrote :

Have the same with MSI WIND U100 in Karmic, like Andreas Alonso, ifconfig shows nothing with eth0. It happen since 2 weeks, earlier works perfectly

affects: ubuntu → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Hi bb,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 363691

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Risto H. Kurppa (risto.kurppa) wrote :

I'm not able to help with this bug any more, the laptop is on another continent :/

bb (bjoern-kiefer) wrote :

I submitted this bug and for me the problem is solved with Ubuntu Karmic.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers