[Jaunty] Volume wheel causes notification to go crazy and disables keyboard on a Toshiba Satellite U300

Bug #361840 reported by Marc Tardif on 2009-04-15
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fedora
In Progress
Unknown
linux (Ubuntu)
Medium
Canonical Kernel Team

Bug Description

I'm running Jaunty with the latest updates as of today and the volume wheel is causing problems on a Toshiba Satellite U300. First, if I just move the wheel a little bit, everything seems to work as expected. However, if I move it more, the notification window keeps blinking as if an event was continuously being sent to it. Furthermore, the keyboard is then disabled and I seem to need to reboot in order to regain use of my keyboard.

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3716 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0700000 irq 22'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,1179ff50,00100003 HDA:11c11040,11790001,00100200'
   Controls : 15
   Simple ctrls : 10
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Uname: Linux 2.6.28-11-generic i686

Marc Tardif (cr3) wrote :
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Marc Tardif (cr3) on 2009-04-15
tags: added: regression-potential

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Marc Tardif (cr3) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.04
MachineType: TOSHIBA Satellite Pro U300
Package: linux-image-2.6.28-11-generic 2.6.28-11.41
PackageArchitecture: i386
ProcCmdLine: root=UUID=690de47e-599c-473d-a03b-a42f562f5757 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-11.41-generic
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

After you trigger this issue, are you able to ssh into the machine? If so, anything interesting in dmesg or syslog?

Changed in linux (Ubuntu):
status: New → Incomplete
Marc Tardif (cr3) wrote :

Yes, I can still ssh into the machine. Attaching the requested information in a bit...

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Marc Tardif (cr3) wrote :

I seem to have been missing a few updates since beta. After installing the latest updates as of today, I still experience the same problem as before. However, the slight difference is that I could now ctrl-alt-f* to another terminal and then return to vt7, at which point the keyboard would start working again. I think I saw some xorg updates recently, so maybe this bug should be retargeted from linux to xorg.

By the way, I have heard of other people around the neighbourhood who experienced the same problem. One of these people actually has a System76 laptop, but I don't know of any bugs reported against this problem.

Ronald McCollam (fader) on 2009-04-20
Changed in linux (Ubuntu):
assignee: nobody → canonical-kernel-team
molecule-eye (niburu1) wrote :

I have a similar problem when using volume controls on my Gateway NX100X laptop. In particular, volume up gives the problem described in the original bug report. My keyboard is rendered useless and I have to log out (if I can manage) in order to get control back. Oddly volume down continues to work ok, but volume up doesn't. I'm suspicious that it might be caused by the new notification system.

molecule-eye (niburu1) wrote :

The same thing happens when I press the mute button (and also volume up as I described in previous post). I notice others are having the same or similar problems: http://ubuntuforums.org/showthread.php?t=1107788

Steve Beattie (sbeattie) on 2009-04-28
tags: added: jaunty regression-release
removed: regression-potential
Mehmet Gençer (mimhack) wrote :

I have the same issue with volume button, also running on Toshiba Satellite U300. Here's what I see in the output of dmesg:

    [17897.941134] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 1

Defcon1 (brentonhaven) wrote :

Same issue on a Toshiba Satellite u305
It has been happening for the past 2 distributions.

molecule-eye (niburu1) wrote :

Replacing pulseaudio with esound has slightly helped. Volume up still causes a blinking notification (which eventually goes away) but the keyboard is at least not rendered useless.

Also I've this problem, with toshiba u200. I think the problem is related to the new toshiba_acpi support for this kernel. Anyone can help us?

Andrea Gottardo (gozzi) wrote :

I'm on a Toshiba Satellite U300 running Fedora 10.
Same issue in this distro too.
Please fix this!

Thanks

Changed in fedora:
status: Unknown → In Progress
Changed in fedora:
status: In Progress → Won't Fix
Changed in fedora:
status: Won't Fix → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.