regression in xt_limit kernel module

Bug #361226 reported by Victor Julien on 2009-04-14
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I noticed that in the Jaunty beta (i386), if I load the xt_limit kernel
module, the proc 'file' /proc/net/ip_tables_matches isn't updated with
it like it should.

On Intrepid:

$ sudo modprobe xt_limit
$ sudo cat /proc/net/ip_tables_matches
limit
state
udplite
udp
tcp
icmp

On Jaunty:

$ sudo modprobe xt_limit
$ sudo cat /proc/net/ip_tables_matches
state
udplite
udp
tcp
icmp

My Vuurmuur iptables frontend (in Jaunty universe) depends on this to
determine what functionality iptables supports.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: VMware, Inc. VMware Virtual Platform
Package: linux-image-2.6.28-11-generic 2.6.28-11.37
ProcCmdLine: root=UUID=79026ad6-f6d1-4500-b199-f646d08630c4 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.37-generic
SourcePackage: linux

Victor Julien (victor-vuurmuur) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Manoj Iyer (manjo) wrote :

Can you please confirm if this is broken in the released version of Jaunty ?

Victor Julien (victor-vuurmuur) wrote :

I can confirm it's still broken in my up to date Janty installation:

$ uname -a
Linux xw4400 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

iptables package version 1.4.1.1-4ubuntu3

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Victor Julien (victor-vuurmuur) wrote :

The issue is no longer present in up2date Karmic.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers