RTL8187SE driver lacks Multicast Support

Bug #360926 reported by Christian Berg on 2009-04-14
48
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Expired
Medium
linux (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Doctor P

Bug Description

I greatfuly recognized that Ubuntu Jaunty has support vor Realteks RTL8102 Chipset, found in many Netbooks based on MSI's U100.

unfourtunley the Driver is in an unofficial - internal - Beta Stage. (see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/246141)

One Issue that really troubles me is lacking support for Unicast. This renders everything thats based on MDNS useless.
Like: Gnome-Networkshare, Vino, Hotssh, Rythmbox Musicsharing, Avahi-Tools, and so on....

Symthoms:
1.) You can ping an other Network.Computer and you also can make use of his services (like webdav), but avahi-discover, can not find them.
2.) Other Computers can not find you with avahi-discover, but can make use of you services if they know your IP and TCP-Port.
3.) Broadcast ping -b 255.255.255.255 does not work for me, but im not sure about this.

I don't know if anything like a Realtek-Bugtracker exists, to report the Bug to Realtek. So i belive that it is a good idea to have a Bugreport in Launchpad, so that other Users with this Issue have some Information on it.

Goldenear (goldenear) wrote :

I can confirm this bug. It's very anoying because it prevent ipv6 autoconf from working :(

Changed in linux (Ubuntu):
status: New → Confirmed
Goldenear (goldenear) wrote :

I can confirm this bug. It's very anoying because it prevents ipv6 autoconf from working :(

CirclingTheSun (circlingthesun) wrote :

I can also confirm this on my msi wind with a fully updated version of jaunty. It's driving me up the wall :|

CirclingTheSun (circlingthesun) wrote :

I just installed Karmic Beta. Avahi is still useless and still no multicast packets getting through.

Christian Berg (xeniac) wrote :

You could be happy that only Multicast is broken in Karmic. Seems that Ubunut-Devs did some patching für the Karmic-Kernel.
Driver has been stranded in the "landing" Tree since Kernel 2.6.30, but this code seems to be broken in vanilla 2.6.31.

I tried Moblin and ubuntu-moblin with this card, both couldn't connect to any network, regardless of the security type.

Steve Beaulac (steve-sagacity) wrote :

CirclingTheSun try this and let me know if it works

type this command at the root prompt

ip link set $IFACE promisc on multicast on

CirclingTheSun (circlingthesun) wrote :

It works!! :) Wow that was easy. Thanks a stack man! Why is this not set by default?

Steve Beaulac (steve-sagacity) wrote :

I created /etc/network/if-up.d/msi-U100-fix-multicast

#!/bin/sh
set -e

case "${IFACE%%[0-9]*}" in
 wlan|wifi) ;;
 *) exit 0
esac

if [ -x /bin/ip ]; then
 ip link set $IFACE promisc on multicast on
fi

so now it works with NetworkManager

CirclingTheSun (circlingthesun) wrote :

Yeah... I forgot to say that I had no environmental variable $IFACE set so I had to replace it with wlan0 before it worked.

oh sorry didnt read the whole script. should work :)

pbkrug (pete-krug) wrote :

Sorry, but I'm still fighting this battle - msi u100 netbook with v9.10 installed. Ever since
I upgraded from 9.04, I have lost wireless.
CirclingTheSun, Steve, can you please post the full script (referenced above)? When does
this script get sourced in?
Thanks!

Mervin Beng (mervinb) wrote :

I see precisely the same issue (MSI Wind U100 / Karmic / RTL8187SE - avahi does not work; cannot be seen by others on network, although ping <IP-address> works).

This makes my MSI Wind pretty useless for ssh, backups, etc which use mDNS. How can we get priority assigned to this bug? Thanks!

The script attached here applies Steve's fix as explained in his post. It creates another script which executes whenever network manager activates your wifi.

Mervin Beng (mervinb) wrote :

Thanks Circling.

In my case, there is no network manager issue. It is the avahi multicast issue. Even without the script, the card wlan0 indicates MULTICAST is on, but the MSI cannot ping to other avahi hosts, and vice versa.

Victor Png (png-victor) wrote :

Hi, can i know where should i put the fixmulticast.sh on the system for it to work?

Whoops. I forgot to escape some characters in that the previous fix. You can run this one from anywhere and delete it when you are done.

Florian Effenberger (floeff) wrote :

Little bugfix:

ip link set $IFACE promisc
must be
ip link set \$IFACE promisc

to escape things correctly. However, IPv6 stateless autoconfiguration doesn't seem to work on my MSI Wind U-100. Anyone had success with getting that running?

Florian Effenberger (floeff) wrote :

The upstream wrong is wrong in parts. "ip link set $IFACE promisc on multicast on" does not solve the problem for me, at least not for IPv6 autoconfiguration packets. They don't work at all.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: kernel-needs-review kernel-uncat
tags: added: kernel-net kernel-reviewed
removed: kernel-needs-review kernel-uncat
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Unknown → Medium
Changed in linux:
status: Confirmed → Expired

Christian Berg, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.