Keyboard Layout options: The "X86AudioRaiseVolume" button stopped working in Logitech keyboard models

Bug #35824 reported by Teemu Likonen
38
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This may actually be a bug in X Window components but I'm not sure. Anyway, recently with Dapper's updates the "Volume up" (X86AudioRaiseVolume) button in Logitech keyboard models stopped working. Also the little window that displays the volume bar does not appear anymore. "Volume down" works perfectly and it displays the volume bar window. I can assign "Volume up" button to any shortcut (with Keyboard Shortcuts options), though, so in this sence the button is working.

The "System Settings / Regional & Accessibility / Keyboard Layout" window shows that I have command

   setxkbmap -model logicdp -layout fi -variant basic

in use. I believe "Volume up" button worked yesterday before I updated my Kubuntu Dapper.

Revision history for this message
Luka Renko (lure) wrote :

I think this has not much to do with kde-systemsettings, but most probably xconfig-keyboard (new version was released yesterday), which provides keyboard layouts or hotkey-setup (which does hotkey mapping for notebooks - very inlikely it would mess your system).

You should run "xev" in terminal and press the Volume Up/Down keys and see how they map.

Revision history for this message
Teemu Likonen (dtw) wrote :

"xev" seems to recognize both Volume up and Volume down perfectly. Also, I can map both keys with "xbindkeys" tool. It's just that in KDE the Volume up does not do anything.

(Yes, I can see now that this is not about kde-systemsettings.)

Kenny Duffus (kduffus)
Changed in kde-systemsettings:
assignee: nobody → kubuntu-team
Revision history for this message
Teemu Likonen (dtw) wrote :

Thought first this is a bug in KDE but actually it is caused by the xkeyboard-config package.

Revision history for this message
Teemu Likonen (dtw) wrote : Re: The "X86AudioRaiseVolume" button stopped working in Logitech keyboard models

Recent update in Dapper's "xkeyboard-config" package changed the file "/etc/X11/xkb/symbols/inet" and at the same time "Volume up" button in Logitech keyboards stopped working with KDE.
("xev" and "xbindkeys -k" still recognize the key.)

I tried to replace this particular "inet" file with some old version found from my backups and "Volume up" works perfectly.

Revision history for this message
Teemu Likonen (dtw) wrote :

I think I know now what is the problem. New "/etc/X11/xkb/symbols/inet" file contains the following section:

xkb_symbols "logitech_base" {
    key <I01> { [ XF86AudioMedia ] };
    [...]
    key <I2F> { [ XF86AudioRaiseVolume ] };
    key <I30> { [ XF86AudioRaiseVolume ] };
    [...]
    key <I6D> { [ XF86AudioMedia ] };
}

I'm using "logicdp" (Logitech Cordless Desktop Pro) keyboard model and these two buttons, XF86AudioMedia and XF86AudioRaiseVolume, cause previously mentioned problems with KDE. As we can see, there are two definitions for these keys. If I comment out the ones that do not apply to my keyboard, these keys work correctly with KDE.

The older "inet" file worked fine because there was a unique section for every Logitech keyboard model. This new "inet" has generic logitech_base section that is included to every logiXXXX keyboard model.

Well, this is all I can do. Hope this is solved soon somehow - whether it's xkeyboard-config's or KDE's problem.

Revision history for this message
Seth Kinast (seth) wrote :

Confirming due to multiple reports, but this isn't a Kubuntu bug. Reassigning.

Revision history for this message
Jeldert (jeldert) wrote :

What is the status of this bug? Is someone working on it?

In Gutsy I have the same problem (with the XF86AudioMedia key on a Logitech Ultra X). It is recognized by the Keyboard Shortcuts program, but the key itself does not initate the action assosiated with it.

The strange thing is, when I say I have a general keyboard (Generic 105-key (Intl) PC) the media key is recognized as "0xed", and does work.

Revision history for this message
Bogdan Butnaru (bogdanb) wrote :

I'm not sure if this is relevant for such an old bug. I have a Dell Latitude where the volume keys (up, down and mute) worked since at least Feisty. I've updated to Hardy since the first alpha and they were working very well. But a couple days ago they just stopped working. Any pointers?

Revision history for this message
Jeldert (jeldert) wrote :

In Hardy the XF86AudioMedia key on a Logitech Ultra X is still not working. I did a clean install, so I cannot confirm that it worked in the alpha, as was the case with Bogdan.

Revision history for this message
Bryce Harrington (bryce) wrote :

Not really an xkeyboard-config issue; more of a hotkey problem.
See http://wiki.ubuntu.com/Hotkeys for more help in tracking down hotkey problems.

Revision history for this message
Steve Langasek (vorlon) wrote :

In jaunty the mentioned keymaps are no longer used at all. Do you still see the same problem with these keys? They should now be correctly mapped by default in the kernel.

affects: hotkey-setup (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Bogdan Butnaru (bogdanb) wrote :

At least in my case they're working now. However I've customized my keyboard settings a lot since, I'm not sure if it's because of that.

Revision history for this message
Jeldert (jeldert) wrote :

Using Ubuntu 9.04:

When selecting the Logitech Ultra-X keyboard the XF86AudioMedia is recognized as such by the Keyboard Shortcuts program, and works.

When selecting the general keyboard (Generic 105-key (Intl) PC), the key is also recognized as XF86AudioMedia, instead of "0xed", and also works.

Revision history for this message
Stefan Bader (smb) wrote :

Closing this bug according to the last comments. Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers