Ubuntu

my laptop doesn't shutdown or reboot. i've posted an image.

Reported by Lorenzo Pompili on 2009-04-04
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Auto-NDISwrapper
Undecided
Unassigned
acpid
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

my laptop doesn't shutdown or reboot. i've posted an image.

http://img9.imageshack.us/img9/2366/08032009s.jpg

most people in the italian ubuntu forum have the same problem. In first it was an nvidia problem. The fix was that i came back to 174.xx. But now i've this problem with 18x and 17x. Strange. Some days yes and some days not.

Sorry for the bad english

Ian Weisser (ian-weisser) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies Thanks in advance!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

root@myself-laptop:~# uname -a
Linux myself-laptop 2.6.28-11-generic #40-Ubuntu SMP Fri Apr 3 17:39:41 UTC 2009 x86_64 GNU/Linux

description: updated
Changed in linux (Ubuntu):
status: Incomplete → New

Apr 7 23:12:36 myself-laptop console-kit-daemon[2541]: GLib-GObject-WARNING: instance of invalid non-instantiatable type `<invalid>'
Apr 7 23:12:36 myself-laptop console-kit-daemon[2541]: GLib-GObject-CRITICAL: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Apr 7 23:12:36 myself-laptop console-kit-daemon[2541]: GLib-GObject-CRITICAL: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Apr 7 23:12:40 myself-laptop bonobo-activation-server (myself-7251): could not associate with desktop session: Failed to connect to socket /tmp/dbus-fYfgDiY3hE: Connessione rifiutata
Apr 7 23:12:42 myself-laptop bluetoothd[2796]: bridge pan0 removed
Apr 7 23:12:42 myself-laptop bluetoothd[2796]: Stopping SDP server
Apr 7 23:12:42 myself-laptop bluetoothd[2796]: Exit
Apr 7 23:12:43 myself-laptop exiting on signal 15
Apr 7 23:14:47 myself-laptop syslogd 1.5.0#5ubuntu3: restart.

it's possibile that this is the problem?

Uff, i've got same problem on other pcs

I notice you have a Dell. Can you try booting with the "reboot=b" boot option to see if it allows you to at least reboot? For help on how to try the reboot=b option do the following, press 'Escape' key at the 3 second pause by Grub bootloader. Then press 'e' (edit) on the kernel entry, followed by 'e' again on the kernel line. Add "reboot=b" (without quotes) to the end of the line and press 'b' to boot. Once you've booted try rebooting to see if it works. If it does, please attach the output of:

sudo dmidecode > dmidecode.log

Changed in linux (Ubuntu):
status: New → Incomplete

same thing, sometimes it reboot/shutdown and sometimes nothing. I've also other pc's with this problem. In the italian forum of ubuntu an user says that 23 pc in his school have this problem

http://forum.ubuntu-it.org/index.php?topic=264563.0 this is the link of the bug in the ubuntu italian forum

srikar (srikar-arepalli) wrote :

@Bug reporter.
ThankQ.

Even i have the same problem.And i get the same thing what you have shown in the image.Is there any fix?

srikar (srikar-arepalli) wrote :

my reports

1)uname -a

  Linux srikar-desktop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

2)dmesg > dmesg.log
***file attached*****

3)sudo lspci -vvnn > lspci-vvnn.log
***file attached****

My system Specification's

Running ubuntu jaunty 64 bit ,p4,1gb ram,ATI radeon 200 series onboard graphic card,intel processor.

srikar (srikar-arepalli) on 2009-04-25
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

i think that in the stable version they have fixed it. I'm testing ubuntu 9.04 stable. no problems for this two days. I'm going to continue this test :-)

srikar (srikar-arepalli) wrote :

I am having this problem with stable one of jaunty.I did not have any problem with beta version.

lyralemos (lyralemos) wrote :

I'm also having this problem with jaunty stable (amd64 - clean install).

I've notove that a few people have the same problem here: http://ubuntuforums.org/showthread.php?t=1134201&highlight=jaunty+shutdown

frank (dallco) wrote :

I'm confirming this problem with jaunty stable (amd64 - clean install).

Dell inspiron 1720, 4 Gig, 8600m gt, t7250@2ghz

Pls feel free to ask for additional info.

frank can u post your logs?

frank (dallco) wrote :
frank (dallco) wrote :
frank (dallco) wrote :

If you need any other info pls specify the name and location or command so I can reproduce it for you.

booga (stoffregen) wrote :

same problem here, compaq laptop.

Linux name 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

booga (stoffregen) wrote :

same for me here.
I have a hp pavillion 6680ev, T7500 GeForce 8400gs.
It has to do with the wireless card. If it's enabled then i cant't shutdown.
Clean install kubuntu 9.04 64 bit.

frank (dallco) wrote :

I have to correct myself. It does not function when I used suspend to ram before. The shutdown does function correct when I have not used te suspend to ran function. Maybe my problem is not related to this bug.

i think that is another problem because suspend or not, some times i can't
shutdown. On my other pc (t5870 4500mhd 2gb hynix 320 samsung) i can't
shutdown or reboot ever. (sorry for the bad english)

2009/4/28 frank <email address hidden>

> I have to correct myself. It does not function when I used suspend to
> ram before. The shutdown does function correct when I have not used te
> suspend to ran function. Maybe my problem is not related to this bug.
>
> --
> my laptop doesn't shutdown or reboot. i've posted an image.
> https://bugs.launchpad.net/bugs/355054
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Confirmed
>
> Bug description:
> my laptop doesn't shutdown or reboot. i've posted an image.
>
>
> http://img9.imageshack.us/img9/2366/08032009s.jpg
>
> most people in the italian ubuntu forum have the same problem. In first it
> was an nvidia problem. The fix was that i came back to 174.xx. But now i've
> this problem with 18x and 17x. Strange. Some days yes and some days not.
>
> Sorry for the bad english
>

i think that is another problem because suspend or not, some times i can't shutdown. On my other pc (t5870 4500mhd 2gb hynix 320 samsung) i can't shutdown or reboot ever. (sorry for the bad english)

Blas Lopez (blas) wrote :

Same problem experienced in my Acer Aspire 6530 after update to 9.04 (no problem with previous 8.10 version).

Linux ignatius 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

Some messages in the screen:

JBD: Detected IO errors while flushing file data on sdb1
sd.4:0:0:0 [sd] Result: hardbyte = DID_BAD_TARGET driverbyte = DRIVER_OK, SUGGEST_OK

and no more message.

PS. If I start in recovery mode and make a fix broken pakages it appears always the powermanagement-interface seems to be broken and it can be removed....

Maurizio (maurizio.g) wrote :

I'm having troubles with shutdown/reboot as well. I'm running a fresh Kubuntu Jaunty 64 bit install.

Sometimes, on restarting, the screen hangs with a console showing only:

Will now restart

And nothing happens...

Maurizio (maurizio.g) wrote :

the same happens when I want to shut it down: it hangs with written: "Will now halt"

I want to add that this is a regression, because I had used Ubuntu 7.04 and 7.10 (64 bit as well) in the past, without this issue.

I am doubtful that this comes from the fact that I'm using KDE now

cheers

no maurizio, this problem is not a kde bug

2009/5/2 Maurizio <email address hidden>

> the same happens when I want to shut it down: it hangs with written:
> "Will now halt"
>
> I want to add that this is a regression, because I had used Ubuntu 7.04
> and 7.10 (64 bit as well) in the past, without this issue.
>
> I am doubtful that this comes from the fact that I'm using KDE now
>
> cheers
>
> --
> my laptop doesn't shutdown or reboot. i've posted an image.
> https://bugs.launchpad.net/bugs/355054
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Confirmed
>
> Bug description:
> my laptop doesn't shutdown or reboot. i've posted an image.
>
>
> http://img9.imageshack.us/img9/2366/08032009s.jpg
>
> most people in the italian ubuntu forum have the same problem. In first it
> was an nvidia problem. The fix was that i came back to 174.xx. But now i've
> this problem with 18x and 17x. Strange. Some days yes and some days not.
>
> Sorry for the bad english
>

I have the same problem with 9.04 64bit and Lenovo n200.

Blas Lopez (blas) wrote :

I found in another post (sorry but I can't find now the URL) a solution thats works for me:

In your /etc/init.d/alsa-utils file finds the " stop)" line and adds these lines:

## start workarround for bug 355054
        ifconfig eth0 down
        ifconfig wlan0 down
## end workarround for bug 355054

In my case the problem is only appears when the notebook pluged in, there is no problem when it uses its battery.

i've this problem when it's plugged in and not

Maurizio (maurizio.g) wrote :

also in my case the problem shows both with AC plug in and without.

moreover, now the problem is happening always (whenever I reboot or shut down), while previoulsy it didn't happen every time.

the only change I can point at, is having enabled pulseaudio for the whole system, and the pulseaudio applet.

i seem to rememeber that I've also seen a problem in killing alsa (a bad command to alsamixer) during a failed shutdown

ndee (ndee-gmx) wrote :

Hi,

same here, seems to be a wireless card issue. After switching it of with the shortcut button the system halts. Even if not in use but activated no shutdown runs smooth anymore.

Specs:
ThinkPad R61
Linux ndee-tp 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
--
ndee@ndee-tp:~$ lsmod | grep -i iw
iwlagn 114820 0
iwlcore 106496 1 iwlagn
mac80211 251144 2 iwlagn,iwlcore
led_class 13064 2 iwlcore,thinkpad_acpi
cfg80211 43168 3 iwlagn,iwlcore,mac80211
--
ndee@ndee-tp:~$ dmesg | grep -i wl
[ 13.915511] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
[ 13.915514] iwlagn: Copyright(c) 2003-2008 Intel Corporation
[ 13.915645] iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 13.915684] iwlagn 0000:03:00.0: setting latency timer to 64
[ 13.915758] iwlagn: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
[ 13.955980] iwlagn: Tunable channels: 13 802.11bg, 19 802.11a channels
[ 13.956100] iwlagn 0000:03:00.0: irq 2295 for MSI/MSI-X
[ 13.957053] phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 32.880279] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-4965-2.ucode
[ 33.900878] iwlagn: Radio disabled by HW RF Kill switch
[ 33.913270] ADDRCONF(NETDEV_UP): wlan0: link is not ready
--

Maurizio (maurizio.g) wrote :

thanks for the hint

I tried to manually switch off the wireless (wifi + bluetooth) and I could then shut down the machine. I noticed a crash of the KDE4 bluetooth manager

by the way, I switched from network manager to wicd because I have a fixed IP WPA2 protected home wireless network, and I couldn't manage to make it work with network manager (even though I tried hard)

YAFU (yafu) wrote :

I have the same problem here.
Is this bug confirmed? Is someone working on a fix to be included in a future update?
My system:Kubuntu 9.04 64bits on a desktop PC Asus M2a-vm.
I think the problem is caused by the wireless card, as already mentioned.
When I close the network manager (wicd in my case) and before shutdown or reboot I run:
$ sudo ifconfig wlan0 down
everything works fine.

I have the same problem on my HP Pavilion dv6000 running 9.04 64 bit.

Shutdown does not work in about 40% of attempts and requires me to hold down the power button to power off the laptop. It appears to happen more often when the laptop has been running for more than a day. I can reboot normally after powering down with the power button.

I have been using Ubuntu since 7.04 without ever having a shutdown problem. The issue appeared as soon as I upgraded to 9.04 from 8.10.

My shutdown experience when it completes normally appears to be far slower than with 8.10. In fact my startup experience appears to be also slower. Jaunty was meant to increase the speed of the startup and this definitely is not the case for me.

srikar (srikar-arepalli) wrote :

I installed new kubuntu,upgraded it.And now i dont have the problem.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

ehm... and what is the fix?

Barry Carroll (baz8080) wrote :

I also think it's a wireless card issue. I have an intel 5100 and i'm running Jaunty 64-bit.

If I shutdown I get the same stacktrace as you have posted in your screenshot. If I remove the wifi modules before shutdown there are no problems.

Maurizio (maurizio.g) wrote :

It is certainly an issue with wifi on this pc as well: I have a Kubuntu 64
bit and if I manually turn off the hardware switch of the wifi card, I am
then enabled to shutdown the pc properly

On Sat, May 23, 2009 at 1:05 PM, Barry Carroll <email address hidden> wrote:

> I also think it's a wireless card issue. I have an intel 5100 and i'm
> running Jaunty 64-bit.
>
> If I shutdown I get the same stacktrace as you have posted in your
> screenshot. If I remove the wifi modules before shutdown there are no
> problems.
>
> --
> my laptop doesn't shutdown or reboot. i've posted an image.
> https://bugs.launchpad.net/bugs/355054
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Fix Released
>
> Bug description:
> my laptop doesn't shutdown or reboot. i've posted an image.
>
>
> http://img9.imageshack.us/img9/2366/08032009s.jpg
>
> most people in the italian ubuntu forum have the same problem. In first it
> was an nvidia problem. The fix was that i came back to 174.xx. But now i've
> this problem with 18x and 17x. Strange. Some days yes and some days not.
>
> Sorry for the bad english
>

TylerKinkade (tkinkade) wrote :

Has the fix been released or not?
I've run update manager, and I'm still having the same problem.

Dell Inspiron 9400
Linux xxxxxxxx 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

yes, same problem me too

2009/5/24 TylerKinkade <email address hidden>

> Has the fix been released or not?
> I've run update manager, and I'm still having the same problem.
>
> Dell Inspiron 9400
> Linux xxxxxxxx 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC
> 2009 x86_64 GNU/Linux
>
> --
> my laptop doesn't shutdown or reboot. i've posted an image.
> https://bugs.launchpad.net/bugs/355054
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” source package in Ubuntu: Fix Released
>
> Bug description:
> my laptop doesn't shutdown or reboot. i've posted an image.
>
>
> http://img9.imageshack.us/img9/2366/08032009s.jpg
>
> most people in the italian ubuntu forum have the same problem. In first it
> was an nvidia problem. The fix was that i came back to 174.xx. But now i've
> this problem with 18x and 17x. Strange. Some days yes and some days not.
>
> Sorry for the bad english
>

TylerKinkade (tkinkade) wrote :

A fix has not been released for Ubuntu users (as confirmed by user: "myself" 5/24/09).

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Nils Schlupp (nilsschlupp) wrote :

not auto-ndis issue

Changed in auto-ndiswrapper:
status: New → Invalid
fari81 (fmmirzaei) wrote :

Guys, this bug is very similar to this one:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/365733

Should we mark them as duplicates?

TylerKinkade (tkinkade) wrote :

look like duplicates to me.

 2.6.28-13-generic and it's all ok.

cheers

Queery1985 (djnoeth) wrote :
Download full text (6.0 KiB)

My Bug is very much the same, but it only hangs until I give it an input from the keyboard and then it power's down (like if I hit return or any other key)

messages log:
Jul 10 15:38:55 Apoptose-inducer kernel: [21878.149371] pidgin[4392]: segfault at 7fc3b5e271a8 ip 00007fc3b248963e sp 00007fc39fb2b690 error 4 in libc-2.9.so[7fc3b2411000+168000]
Jul 10 15:39:07 Apoptose-inducer bonobo-activation-server (queery-12195): could not associate with desktop session: Failed to connect to socket /tmp/dbus-6qpb4XktAH: Connection refused
Jul 10 15:39:48 Apoptose-inducer exiting on signal 15

Kernal log:
Jul 10 15:38:55 Apoptose-inducer kernel: [21878.149371] pidgin[4392]: segfault at 7fc3b5e271a8 ip 00007fc3b248963e sp 00007fc39fb2b690 error 4 in libc-2.9.so[7fc3b2411000+168000]

syslog:
Jul 10 15:38:45 Apoptose-inducer init: tty2 main process (2323) killed by TERM signal
Jul 10 15:38:45 Apoptose-inducer init: tty4 main process (2319) killed by TERM signal
Jul 10 15:38:46 Apoptose-inducer init: tty5 main process (2320) killed by TERM signal
Jul 10 15:38:46 Apoptose-inducer init: tty3 main process (2326) killed by TERM signal
Jul 10 15:38:46 Apoptose-inducer init: tty6 main process (2327) killed by TERM signal
Jul 10 15:38:46 Apoptose-inducer init: tty1 main process (3646) killed by TERM signal
Jul 10 15:38:55 Apoptose-inducer kernel: [21878.149371] pidgin[4392]: segfault at 7fc3b5e271a8 ip 00007fc3b248963e sp 00007fc39fb2b690 error 4 in libc-2.9.so[7fc3b2411000+168000]
Jul 10 15:38:57 Apoptose-inducer NetworkManager: <info> (eth1): supplicant connection state: completed -> disconnected
Jul 10 15:38:57 Apoptose-inducer NetworkManager: <debug> [1247233137.516696] periodic_update(): Roamed from BSSID 00:XX:XX:XX:XX:30 (MatiesWifi) to (none) ((none))
Jul 10 15:38:59 Apoptose-inducer NetworkManager: <info> (eth1): supplicant connection state: disconnected -> scanning
Jul 10 15:38:59 Apoptose-inducer NetworkManager: <info> (eth1): device state change: 8 -> 3
Jul 10 15:38:59 Apoptose-inducer NetworkManager: <info> (eth1): deactivating device (reason: 38).
Jul 10 15:39:00 Apoptose-inducer NetworkManager: <info> eth1: canceled DHCP transaction, dhcp client pid 4002
Jul 10 15:39:00 Apoptose-inducer NetworkManager: <WARN> nm_device_wifi_disable_encryption(): error setting key for device eth1: Invalid argument
Jul 10 15:39:06 Apoptose-inducer /USR/SBIN/CRON[12232]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | xargs -n 200 -r -0 rm)
Jul 10 15:39:07 Apoptose-inducer NetworkManager: <info> (eth1): writing resolv.conf to /sbin/resolvconf
Jul 10 15:39:07 Apoptose-inducer NetworkManager: <info> (eth0): writing resolv.conf to /sbin/resolvconf
Jul 10 15:39:07 Apoptose-inducer NetworkManager: <info> Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Jul 10 15:39:07 Apoptose-inducer avahi-daemon[3315]: Withdrawing address record for 10.110.0.229 on eth1.
Jul 10 15:39:07 Apoptose-inducer avahi-daemon[3315]: Leaving mDNS multicast group on interface eth1.IPv4 with address 10.110.0.229.
Jul 10 15:39:07 Apoptose-inducer avahi-daemon[3315]...

Read more...

Solution (for me)
apt-get install apmd
gedit /etc/modules
add this line===> apm power_off=1

cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers