[Jaunty] Microphone doesn't work at all on Eee 701SD

Bug #354705 reported by Marc Tardif on 2009-04-03
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

When attempting to record sound using Sound Recorde from the Applications menu, nothing seems to get recorded. Even trying to uninstall pulseaudio and rebooting doesn't seem to workaround the problem.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu7
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Uname: Linux 2.6.28-11-generic i686

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

The same problem also occurs when attempting to use an external microphone.

Marc Tardif (cr3) wrote :

This bug might be related to bug #354707.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Fri, 3 Apr 2009, Marc Tardif wrote:

> When attempting to record sound using Sound Recorde from the
> Applications menu, nothing seems to get recorded. Even trying to
> uninstall pulseaudio and rebooting doesn't seem to workaround the
> problem.
...
> [Jaunty] Microphone doesn't work at all on Eee 701SD

  status incomplete
  done

Please attach output from running http://www.alsa-project.org/alsa-info.sh
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFJ1+jMe9GwFciKvaMRApcHAJ4pz/wWQJwFsNqzrMbmrvHWonjLhACgstv7
wp8EwHYMsz2nBB2hgYFTF80=
=I1ID
-----END PGP SIGNATURE-----

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Daniel T Chen (crimsun) on 2009-04-06
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Matt Zimmerman (mdz) wrote :
Luke Yelavich (themuso) on 2009-04-06
Changed in linux (Ubuntu):
assignee: nobody → ubuntu-audio
status: Incomplete → Triaged
Changed in linux (Ubuntu):
importance: Undecided → High
cuvy (phil-urbanoia) wrote :

i believe i had similar problems (http://urbanoia.net/?p=39). Is the issue with the mexer not knowing that CAPTURE is a switch as well as a control? Try using alsamixer and turning it on.

wsl (ws-aixx) wrote :

I shoud add that this problem does not occur on all 701-eeePC. I installed the netbook-remix on my
eeePC 701-4G (as it was sold in Germany) and sound recording works out-of-the-box (both using
the sound recorder application and skype).

Thomas Bousquet (tomato1090) wrote :

I had the same problem with my vaio, i just install Mixeur Alsa Gnome and it work.

Vincent (vin100vin) wrote :

Same problem no record, no skype. And I've some sound with Mixeur Alsa Gnome but very bad. If someone could give a simple explanation (I just try to use last Ubuntu out of the box/ sorry Xandros & XP immigrant)

wsl (ws-aixx) wrote :

on my box, skype works well (701-4G, Ubuntu 9.04 out-of-the-box). You should however check the following:

- in the mixer application, make sure that the right microphone (i-mic for internal or e-mic for external) is selected, that the microphone is enabled and set to a reasonable recording level. You have to check the tab "recording" ! By default, after the ubuntu installation, the microphone was completely disabled and the recording level set to zero.

- within skype, select "audio devices" and set for everything (microphone, speaker and for ringing) the device to "HDA Intel(hw:Intel,0)", Setting the device to "pulse" doesn't work on my box. Also disable the automatic setting of audio devices by skype, otherwise after starting skype the next time, the settings are lost again.

Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
risk (srdjan-rosic) wrote :

What worked for me, besides apropriate mixer capture settings, is adding the line

options snd-hda-intel model=3stack-dig

at the end of /etc/modprobe.d/alsa-base.conf
I then needed to reboot.

Have you tried looking in alsa-mixer and change the settings for the
capture device...
On Fri, 2009-07-24 at 07:43 +0000, risk wrote:
> What worked for me, besides apropriate mixer capture settings, is adding
> the line
>
> options snd-hda-intel model=3stack-dig
>
> at the end of /etc/modprobe.d/alsa-base.conf
> I then needed to reboot.
>

browe (brianmrowe-7effect) wrote :

I still have a problem with the mic on 9.04. I have tried some of the online solutions. I have gnome alsamixer. In sound prefs I have alsa select for sound capture. I have an external mic plugged in to the audio cable (pink one) on realtek ALC888. I get this error.
Failed to construct test pipeline for 'gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat'
I still have no skype and that is the killer. I really need to get some capture to skype out, my only phone.
In gnome-alsamixer - frontmic, mic, and capture are all enabled and maxed. I had no problems with audio capture on 8.10 before the upgrade.
My mic works because I use it on my mac for skype, while this is not working.
Sound recorder will record something I'm playing on the PC, like mp3, but not from the mic.

Leandro Marino (leandromarino) wrote :

I tried everything that is written but still don't working. Anybody knows how to get it working?

sqlpython (sqlpython) wrote :

To get jaunty 9.04 w/PulseAudio to show mic in Skype Options.....
I wrote this script to launch Skype which utilizes the
PULSE_SERVER variable
You feed the PULSE_SERVER your IPaddress for your connected device..
As you can see, for me my devices are eth0 and wlan0
Modify the script devices to your needs.
A simple ifconfig <deviceName> ...i.e. ifconfig eth0 will give back the info for that device then we just parse it ...
NOTE: I have installed my Skype in a Particular Dir /home/sqlpython/skype..
......If yours is in a different Dir CHange the Script..
...Also for Notification Sounds Move the /home/sqlpython/skype/sounds dir to
..../usr/share/skype/ .. You probably will have to create that one in as sudo user of Konqueror or Nautilus
Even with all this PulseAudio and SKype work poorly together as they will hog CPU% and result in squashing all other playbacks while Skype is connected to another Skype User VOIP.. like if you are streaming Radio music or just trying to Play a Music CD at the same time..
To put it in eloquent technical terms "PulseAudio Stinks"
In the end for my 8.10 and 9.04 installs I will probably uninstall Pulse.
Here You Go... Mic in Skype.
Quote:
#!/bin/bash

ifconfig wlan0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1 $1
ifconfig eth0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1 $2
if [ $1 -gt $2 ]
then
echo $1
PULSE_SERVER=$1 /home/sqlpython/skype/skype
fi
if [ $2 -gt $1 ]
then
echo $2
PULSE_SERVER=$2 /home/sqlpython/skype/skype
fi

Marco61 (mbp-mueller) wrote :

I'm using an eeepc 701 4G with ubuntu 8.10 nad had the same problem with skype and recorder. followingn the instructions of wsl (#11) I could make my system work again Thanks! (Skype is working well, recorder not yet buat I don't need it so bad

tags: added: cherry-pick kernel-sound
Juan Manuel (juanm-cabrera) wrote :

I have the same problem. The micro works only sometimes, like randomly. The few times it works , it is only for some minutes and then it is gone without any reason.
???

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers