Ubuntu

[ASUS M3N78-VM with onboard GeForce 8200] suspend/resume failure [non-free: nvidia]

Reported by Andreas Klien on 2009-04-03
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Manoj Iyer
Nominated for Intrepid by Gerry C.
Nominated for Karmic by Gerry C.

Bug Description

Crashed on suspend_test right on the first suspend. It didn't resume automatically and crashed on resume.

This bug is present in both Intrepid and Karmic on 32bit and 64bit.

ProblemType: KernelOops
Annotation: This occured during a previous suspend and prevented it from resuming properly.
Architecture: i386
CurrentDmesg: [ 233.000074] Clocksource tsc unstable (delta = -299820668 ns)
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
InterpreterPath: /usr/bin/python2.6
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-11-generic 2.6.28-11.39
ProcAttrCurrent: unconfined
ProcCmdLine: root=UUID=2fd5d981-a8d2-4248-856d-959c1b8f48c3 ro vga=795 profile
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.28-11.39-generic
SourcePackage: linux
Tags: resume suspend
Title: [System manufacturer System Product Name] suspend/resume failure [non-free: nvidia]
UserGroups:

Andreas Klien (x4nd1) wrote :
Grey (grevian) wrote :

I'm having a problem with this as well, If I try to Suspend to RAM, on waking up the system has 'lost' it's SATA disks and must be rebooted, I'll have to do some fiddling to get the exact messages (currently the system is setup as a media center, and it's difficult to read the console text on the TV),

XmIsTeR (xmisterhu) wrote :

The same as Grey here, with ASUS M3N78-CM.
Tried with kernel 2.6.30 too, but it didn't help.
dmesg messages on wake up are simple I/O errors.

XmIsTeR (xmisterhu) wrote :

Okay, I've managed to save the logs, by mounting an usb device to /var/log and restarting the log daemons.
Here is the logs (in attachment), which could be helpful.
Also I the exact name of the chipset is Nvidia MCP78S, but it's declared as Nvidia Geforce 8200 according to the vga onboard.
And please change the importance, I think it's a very important bug.

XmIsTeR (xmisterhu) wrote :
XmIsTeR (xmisterhu) wrote :
XmIsTeR (xmisterhu) wrote :
XmIsTeR (xmisterhu) wrote :
XmIsTeR (xmisterhu) wrote :

And just for clearify the things.
This is NOT a geforce or any vga bug, because the screen coming back succesfully from the memory when using the non-free nvidia driver, and the mouse working, etc.
It's a SATA driver bug.

Changed in linux (Ubuntu):
assignee: nobody → XmIsTeR (xmisterhu)
status: New → Confirmed
assignee: XmIsTeR (xmisterhu) → nobody

I have a Geforce 8300 (just an 8200 overclocke for what I know) and have the same bug. I'm running Ubuntu 9.04 and get a black screen with just the mouse pointer.

Grey (grevian) wrote :

Alessandro: That doesn't sound at all like the issue the rest of us are having? It's a SATA issue not a video card issue.

In reality had even some I/O errors, now I see only the black screen (don't know if it is stille related by I/O or if it is a new bug.

XmIsTeR (xmisterhu) wrote :

Alessandro:
I have to wait 10-15 seconds from the mouse showing up to get back the screen, but I'm using kubuntu(KDE), so this could make some difference in this case.
But I think that all these things are related to I/O(SATA) errors.

Yes XmisTeR for me it is the same (now), before I can't even see the black screen with the mouse pointer.. instead came that I/O problem...
I had updated X.org and the NVIDIA proprietary drivers and now it's black screen with pointer.

golem (a-klopotek) wrote :

I think it's a SATA drive issue having problem to resume properly - try passing "pci=nomsi" option to the kernel during boot - it should help and your system should suspend/resume without errors.

Grey (grevian) wrote :

golem that worked perfectly for me! (Well, almost perfectly, still sorting out a few minor and unrelated audio issues), Thank you so much!

XmIsTeR (xmisterhu) wrote :

golem, you are a genius! How did you know that?
Anyway it is perfect now.

To me it's the same, lot of errors SATA related and the black screen.

golem (a-klopotek) wrote :

I'm glad to hear my advice was helpful, at least for some of you... I spent a few days googling and searching the web and eventually found a solution. But I also wonder if you guys have problems after connecting a usb-storage device (eg. flash disk or digital camera) - in my case after connecting a usb flash disk and trying to copy some files, my usb mouse stops working after a few seconds and the usb subsystem hangs (reconnecting the mouse does not help, lsusb hangs and new usb devices that are connected are not detected) - the only solution is to hard reset the system. I think some of you having the same mainboard (mine is M3N78-VM) may be also affected by this issue - together we have more chances to find the answer :)

To me too thanks (it was mine fault).

Andreas Klien (x4nd1) wrote :

Thanks, the pci=nomsi option did the fix for me too.

It seems to me a workaround but hoping nVidia will fix it soon.

Sense Egbert Hofstede (sense) wrote :

I can confirm the same problem on an Asus M3NH78-EH with an Geforce 8200 chipset. Hibernating doesn't work as well.
I've had SATA issues with previous kernels -- Hardy Heron and lower, iirc -- so it's not a surprise this is probably caused by a SATA issue.
I'm setting the status to Triaged since we know what has caused it.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
description: updated

did some of you experience a successful suspend once after boot, and unsuccessful suspends afterwards, I have pretty much the same hardware as you guys, M3N78-EM. My screen does come back, and the pc is perfectly usable, it just immediately wakes up from suspend.

Sure, I'm using hibernate instead and I find it 'ok' (just). Suspend is faster so I hope the bug will be solved in the near future.

Chris Conway (cconway) wrote :

I'm having this problem as well with a M3N78-VM. The workaround in #19 doesn't work for me. I've got BIOS version 1009. I wonder if anybody has tried upgrading to a more recent BIOS? (http://usa.asus.com/product.aspx?P_ID=ovqEgLFRjnSClhSV&content=download)

carlton whitehead (cebesius86) wrote :

I have this problem too with an Asus M3N78-VM and BIOS 1409. Suspend works once but then doesn't work again.

Also, some other posts here indicate that USB hangs after connecting a flash drive, with the mouse hanging, then USB hanging to the point where lsusb doesn't return anything at all and just hangs. I have that too. Perhaps it should be spun off to a separate bug report.

Does anyone dual boot with this motherboard? Do you have these same problems under other OSes as well?

timsku (timsku) wrote :

I have M3N78-VM and had problems with usb devices with 32-bit Jaunty and Debian Lenny. I often had totally freezed system after about 2 mins. Using active usb hub (power sourced) for all usb devices made my mobo stable. After upgrading to BIOS 1406 everything works just fine also without usb hub. I tried several BIOS versions but 1406 did it.

Chris Conway (cconway) wrote :

I can't say for sure if this will continue to work, but I just successfully suspended three times in a row after adding the kernel option "usbcore.autosuspend=-1". Credit goes to this forum post: http://www.uluga.ubuntuforums.org/showpost.php?p=8706657&postcount=9

Full instructions:

  $ sudoedit /etc/default/grub

and add "usbcore.autosuspend=-1" to GRUB_CMDLINE_LINUX_DEFAULT. E.g.,

  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

then

  $ sudo update-grub

and reboot.

tags: added: kernel-needs-review kernel-power
Manoj Iyer (manjo) wrote :

Does this suspend resume issue occur in Lucid? Can you please verify if mainline kernel has this issue as well? http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/

tags: added: kernel-reviewed
removed: kernel-needs-review
Changed in linux (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
status: Triaged → Incomplete
Chris Conway (cconway) wrote :

Absolutely, I was having this problem in Lucid (upgraded from Medibuntu Karmic) until I applied the fix in #29.

rasos (rasos) wrote :

Fix in #29 worked for me as well.

This is my complete kernel launch patch in /etc/default/grub for an ASUS M3N78-VM hardware running Mythbuntu 10.04:

GRUB_CMDLINE_LINUX="acpi_enforce_resources=lax vmalloc=192M pci=nomsi usbcore.autosuspend=-1"

acpi_enforce_resources=lax removes an annoying "Error probing SMB2" error, seems specific for this board
vmalloc=192M reserves more memory for the drivers, otherways only 100MB are reserved, which is not enough for the nvidia nor for the nouveau graphics driver
pci=nomsi usbcore.autosuspend=-1 fixes a suspend/wakeup problem, where the board has lost its SATA drives at wakeup

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers