ixp4xx hwclock command stopped to work since beta release

Bug #353196 reported by Oliver Grawert on 2009-04-01
8
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
apex (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Oliver Grawert
Karmic
Medium
Oliver Grawert
linux (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned
Karmic
Medium
Unassigned

Bug Description

there seem to have been undocumented changes to the ixp4xx configuration/setup ... testing the beta kernel the call to hwclock suddenly results in "no known method to access the hardware clock, /dev/rtc0 not found" please revert whatever was changed without changelog entry in the linux package, this used to work flawless with the alpha images

Oliver Grawert (ogra) on 2009-04-01
tags: added: arm
Changed in linux (Ubuntu):
milestone: none → ubuntu-9.04
Amit Kucheria (amitk) on 2009-04-01
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: New → Triaged
Bryan Wu (cooloney) on 2009-04-02
Changed in linux (Ubuntu):
assignee: nobody → cooloney
Bryan Wu (cooloney) wrote :

Oliver,

Since you have the hardware, could you please post the dmesg.txt and "ls /dev/rtc*"? And which alpha version is ok for this testing? I checked with the kernel config file chages from alpha6 to beta, but did not find some RTC config changes.

Thanks
-Bryan

Oliver Grawert (ogra) wrote :

from a fresh RC install....

ogra@LKGD7F5B4:~$ sudo hwclock --show
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
ogra@LKGD7F5B4:~$ sudo hwclock --debug
hwclock from util-linux-ng 2.14.2
hwclock: Open of /dev/rtc failed, errno=2: No such file or directory.
No usable clock interface found.
Cannot access the Hardware Clock via any known method.
ogra@LKGD7F5B4:~$

Oliver Grawert (ogra) wrote :
Oliver Grawert (ogra) wrote :

ogra@LKGD7F5B4:~$ ls /dev/rtc*
ls: cannot access /dev/rtc*: No such file or directory

Oliver Grawert (ogra) wrote :

the last alpha i tested before reporting the bug with beta was alpha5 iirc

Bryan Wu (cooloney) wrote :

From the dmesg.txt, we got some rtc warnings:

---
Kernel command line: console=ttyS0,115200 rtc-x1205.probe=0,0x6f noirqdebug
Unknown boot option `rtc-x1205.probe=0,0x6f': ignoring
........
rtc_x1205: Unknown parameter `probe'
---

There was no such device file /dev/rtc0, because the rtc_x1205 modules was not installed, I guess. Could you please post 'lsmod' command result here? We might need to build in this rtc_x1205 driver to the kernel.

Oliver Grawert (ogra) wrote :

its not loaded
ogra@LKGD7F5B4:~$ lsmod
Module Size Used by
ipv6 189976 10
rtc_core 8536 0
i2c_gpio 1600 0
i2c_algo_bit 4132 1 i2c_gpio
leds_gpio 1184 0
evdev 5668 0
led_class 1444 1 leds_gpio
pxa25x_udc 11364 0
i2c_core 12400 2 i2c_gpio,i2c_algo_bit

but ...
ogra@LKGD7F5B4:~$ ls /lib/modules/2.6.28-11-ixp4xx/kernel/drivers/rtc/rtc-x1205*
/lib/modules/2.6.28-11-ixp4xx/kernel/drivers/rtc/rtc-x1205.ko

ogra@LKGD7F5B4:~$ sudo modprobe rtc_x1205
WARNING: All config files need .conf: /etc/modprobe.d/local, it will be ignored in a future release.
FATAL: Error inserting rtc_x1205 (/lib/modules/2.6.28-11-ixp4xx/kernel/drivers/rtc/rtc-x1205.ko): Unknown symbol in module, or unknown parameter (see dmesg)

and
ogra@LKGD7F5B4:~$ ls /lib/modules/2.6.28-11-ixp4xx/kernel/drivers/rtc/rtc-x1205*
/lib/modules/2.6.28-11-ixp4xx/kernel/drivers/rtc/rtc-x1205.ko

ogra@LKGD7F5B4:~$ cat /etc/modprobe.d/local
# Local module settings
# Created by the Debian installer

options rtc-x1205 probe=0,0x6f
...

so it seems this option makes it break
...
running:
sudo apex-env setenv cmdline 'console=ttyS0,115200 noirqdebug'
then removing the /etc/modprobe.d/local and running update-initramfs -u
gets me this in dmesg:

rtc-x1205 0-006f: chip found, driver version 1.0.8
rtc-x1205 0-006f: rtc core: registered rtc-x1205 as rtc0

Oliver Grawert (ogra) wrote :

based on the latest findings i'm marking this bug as invalid for linux and point it to debian-installer instead

Changed in linux (Ubuntu):
status: Triaged → Invalid
Oliver Grawert (ogra) wrote :

oh, and just to confirm, it works after that fix:

ogra@LKGD7F5B4:~$ sudo hwclock --show
[sudo] password for ogra:
Sun Apr 19 09:40:45 2009 -0.485819 seconds

Bryan Wu (cooloney) wrote :

Thanks Oliver. -Bryan

Colin Watson (cjwatson) wrote :

rtc-x1205.probe=0,0x6f is passed by apex:

./src/mach-ixp42x/debian-nslu2-armeb_config:148:CONFIG_ENV_DEFAULT_CMDLINE="console=ttyS0,115200 rtc-x1205.probe=0,0x6f noirqdebug"
./src/mach-ixp42x/debian-nslu2-armeb_config:150:CONFIG_ENV_DEFAULT_CMDLINE_ALT="console=ttyS0,115200 rtc-x1205.probe=0,0x6f noirqdebug"
./src/mach-ixp42x/debian-nslu2-arm_config:148:CONFIG_ENV_DEFAULT_CMDLINE="console=ttyS0,115200 rtc-x1205.probe=0,0x6f noirqdebug"
./src/mach-ixp42x/debian-nslu2-arm_config:150:CONFIG_ENV_DEFAULT_CMDLINE_ALT="console=ttyS0,115200 rtc-x1205.probe=0,0x6f noirqdebug"

affects: debian-installer (Ubuntu) → apex (Ubuntu)
Oliver Grawert (ogra) wrote :

milestoning for jaunty-updates, subscribing ubuntu-sru

Changed in apex (Ubuntu):
importance: Undecided → Medium
milestone: none → jaunty-updates
status: New → Confirmed
Oliver Grawert (ogra) wrote :

uploaded to jaunty-proposed

Oliver Grawert (ogra) wrote :

apex (1.4.15.2ubuntu3.1) jaunty-proposed; urgency=low

  * rtc-x1205 does not accept the probe module option in 2.6.28, drop it from
    the default cmdline setting in debian-nslu2-armel_config and
    debian-nslu2-armeb_config (LP: #353196)

 -- Oliver Grawert <email address hidden> Mon, 20 Apr 2009 11:12:28 +0200

Amit Kucheria (amitk) on 2009-04-20
Changed in linux (Ubuntu):
assignee: Bryan Wu (cooloney) → nobody
Oliver Grawert (ogra) wrote :

for the release note task:

"Due to a bug in the bootloader setup for ixp4xx the driver for the real time clock can not be loaded properly at boot. In bug 353196 a proper workaround is documented to overcome the problem"

Martin Pitt (pitti) on 2009-04-23
Changed in linux (Ubuntu Jaunty):
milestone: ubuntu-9.04 → none
Changed in apex (Ubuntu Jaunty):
assignee: nobody → Oliver Grawert (ogra)
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Release notes text added:

== Real-time clock driver not loaded on ARM NSLU2 ==

On ARM NSLU2 systems, the driver for the real-time clock is not loaded correctly on startup. You can work around this after installation by running the following command: {{{
sudo apex-env setenv cmdline 'console=ttyS0,115200 noirqdebug'
}}} then remove the `/etc/modprobe.d/local` file and run `update-initramfs -u`. (Bug:353196)

Changed in ubuntu-release-notes:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Accepted apex into jaunty-proposed-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Beattie (sbeattie) on 2009-05-01
tags: added: hw-specific
Paul Larson (pwlars) on 2009-06-05
tags: added: armel
removed: arm
Oliver Grawert (ogra) wrote :

we wont support armv5 systems in karmic, closing karmic task as wontfix

Changed in apex (Ubuntu Karmic):
status: Fix Committed → Won't Fix
Oliver Grawert (ogra) wrote :

the fix works fine in jaunty-updates, pitti can you close the task as fix released ?

Martin Pitt (pitti) on 2009-06-25
Changed in apex (Ubuntu):
assignee: Oliver Grawert (ogra) → nobody
milestone: jaunty-updates → none
status: Fix Committed → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apex - 1.4.15.2ubuntu3.1

---------------
apex (1.4.15.2ubuntu3.1) jaunty-proposed; urgency=low

  * rtc-x1205 does not accept the probe module option in 2.6.28, drop it from
    the default cmdline setting in debian-nslu2-armel_config and
    debian-nslu2-armeb_config (LP: #353196)

 -- Oliver Grawert <email address hidden> Mon, 20 Apr 2009 11:12:28 +0200

Changed in apex (Ubuntu Jaunty):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments