[i945gm] UXA failed resume after hibernate (UXA bug)

Bug #352207 reported by ari197
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

After enabling UXA, X cannot resume after hibernate, but could resume after suspend. I'm using 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu2
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-11-generic i686

Revision history for this message
ari197 (arianto-nugroho) wrote :
Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Revision history for this message
Luka Renko (lure) wrote :

This sounds like bug 347587: can you attach /var/log/gdm.log and/or /var/log/kdm.log?

Revision history for this message
ari197 (arianto-nugroho) wrote :

Hi .. attached is the /var/log/kdm.log

Revision history for this message
Luka Renko (lure) wrote :

No indication about assertion in your kdm.log, therefore we cannot confirm it is the same issue as bug 347587

Revision history for this message
ari197 (arianto-nugroho) wrote : Re: [Bug 352207] Re: UXA failed resume after hibernate
  • kdm.log Edit (498.7 KiB, application/octet-stream; name="kdm.log")

Actually I put it in the web, anyhow, here it is.

On Wed, Apr 8, 2009 at 4:27 PM, Luka Renko <email address hidden> wrote:

> No indication about assertion in your kdm.log, therefore we cannot
> confirm it is the same issue as bug 347587
>
> --
> UXA failed resume after hibernate
> https://bugs.launchpad.net/bugs/352207
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After enabling UXA, X cannot resume after hibernate, but could resume after
> suspend. I'm using 00:02.0 VGA compatible controller [0300]: Intel
> Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics
> Controller [8086:27a2] (rev 03)
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu2
> ProcEnviron:
> LANGUAGE=
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version
> 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009
> SourcePackage: xserver-xorg-video-intel
> Uname: Linux 2.6.28-11-generic i686
>

--
Arianto C Nugroho
Datacraft Indonesia
Managed Services Department
http://www.linkedin.com/in/ariantonugroho

Revision history for this message
ari197 (arianto-nugroho) wrote : Re: UXA failed resume after hibernate

Found something new, if I go to text console from X (CTRL-ALT-F1 for example) then back to X (CTRL-ALT-F7) then the screen will just go blank. So I don't think that X failed to load, it just failed to show anything at all..

Bryce Harrington (bryce)
summary: - UXA failed resume after hibernate
+ [i945gm] UXA failed resume after hibernate
Bryce Harrington (bryce)
summary: - [i945gm] UXA failed resume after hibernate
+ [i945gm] UXA failed resume after hibernate (UXA bug)
Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Bryce Harrington (bryce) wrote :

For Karmic we're making UXA bugs like these a top priority, so I would like to forward this one upstream. First though, we need to verify the issue still exists with the latest upstream release. Would you please install and test the 2.7.0 driver and reproduce the bug, and let us know ASAP? A PPA with a Jaunty version of this driver is available at: https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
ari197 (arianto-nugroho) wrote : Re: [Bug 352207] Re: [i945gm] UXA failed resume after hibernate (UXA bug)

Hi,

I'm sorry to say that the same problem still exist on the latest update.

On Sat, May 2, 2009 at 3:15 AM, Bryce Harrington
<email address hidden>wrote:

> For Karmic we're making UXA bugs like these a top priority, so I would
> like to forward this one upstream. First though, we need to verify the
> issue still exists with the latest upstream release. Would you please
> install and test the 2.7.0 driver and reproduce the bug, and let us know
> ASAP? A PPA with a Jaunty version of this driver is available at:
> https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/<https://edge.launchpad.net/%7Eubuntu-x-swat/+archive/x-updates/>
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> [i945gm] UXA failed resume after hibernate (UXA bug)
> https://bugs.launchpad.net/bugs/352207
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After enabling UXA, X cannot resume after hibernate, but could resume after
> suspend. I'm using 00:02.0 VGA compatible controller [0300]: Intel
> Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics
> Controller [8086:27a2] (rev 03)
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu2
> ProcEnviron:
> LANGUAGE=
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version
> 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009
> SourcePackage: xserver-xorg-video-intel
> Uname: Linux 2.6.28-11-generic i686
>

--
Arianto C Nugroho
Datacraft Indonesia
Managed Services Department
http://www.linkedin.com/in/ariantonugroho

Revision history for this message
Bryce Harrington (bryce) wrote :

Too bad, but we can send this one upstream. Please attach the Xorg.0.log from after testing with the 2.7.0 driver.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
ari197 (arianto-nugroho) wrote :

Hi,

Here I attached 2 Xorg.log, 1 after waking-up from hibernation (Xorg.log.1),
the second one after going back from text mode (Xorg.log.2)

On Sat, May 2, 2009 at 9:45 AM, Bryce Harrington
<email address hidden>wrote:

> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Incomplete => New
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: New => Incomplete
>
> --
> [i945gm] UXA failed resume after hibernate (UXA bug)
> https://bugs.launchpad.net/bugs/352207
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> After enabling UXA, X cannot resume after hibernate, but could resume after
> suspend. I'm using 00:02.0 VGA compatible controller [0300]: Intel
> Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics
> Controller [8086:27a2] (rev 03)
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu2
> ProcEnviron:
> LANGUAGE=
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version
> 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009
> SourcePackage: xserver-xorg-video-intel
> Uname: Linux 2.6.28-11-generic i686
>

--
Arianto C Nugroho
Datacraft Indonesia
Managed Services Department
http://www.linkedin.com/in/ariantonugroho

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
In , Bryce Harrington (bryce) wrote :

Forwarding this bug from a ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/352207

[Problem]
After enabling UXA, X cannot resume after hibernate, but could resume after suspend.

If I go to text console from X (CTRL-ALT-F1 for example) then back to X (CTRL-ALT-F7) then the screen will just go blank. So I don't think that X failed to load, it just failed to show anything at all.

Here I attached 2 Xorg.log, 1 after waking-up from hibernation (Xorg.log.1),
the second one after going back from text mode (Xorg.log.2)

 distro: Ubuntu
 architecture: i686
 kernel: 2.6.28-11-generic
 xserver-xorg: 1:7.4~5ubuntu16
 mesa: 7.3-1ubuntu4
 libdrm: 2.4.5-0ubuntu3
 -intel: 2:2.6.3-0ubuntu2
 -ati: 1:6.12.1-0ubuntu1

The 2.7.0 driver from x-updates was also tested and found to have the same issue.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
 Subsystem: Micro-Star International Co., Ltd. Device [1462:0571]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
 Subsystem: Micro-Star International Co., Ltd. Device [1462:0571]

Revision history for this message
In , Bryce Harrington (bryce) wrote :

Created an attachment (id=25500)
XorgLog.txt

Revision history for this message
In , Bryce Harrington (bryce) wrote :

Created an attachment (id=25501)
XorgConf.txt

Revision history for this message
In , Bryce Harrington (bryce) wrote :

Created an attachment (id=25502)
kdm.log

Revision history for this message
In , Bryce Harrington (bryce) wrote :

Created an attachment (id=25503)
20090504-Xorg.log.1

Revision history for this message
In , Bryce Harrington (bryce) wrote :

Created an attachment (id=25504)
20090504-Xorg.log.2

Revision history for this message
In , Gordon Jin (gordon-jin) wrote :

Yifei, can you reproduce this on 945GM?

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi ari,

I've forwarded your bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=21576 - please subscribe to that bug in case upstream needs further information or wishes you to test something.

Also, in the case they wish you to test an even newer version of the driver, check here for a recent git snapshot: https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce)
tags: added: resume
Revision history for this message
In , Gordon Jin (gordon-jin) wrote :

We can't reproduce it with upstream code on our 945GM.

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Adjusting severity: crashes & hangs should be marked critical.

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Also I'm a little confused about the summary; it sounds like regular VT switch was broken as well? Or was it just VT switch after resuming from hibernate?

Anyway, please try upstream bits as Gordon suggests and let us know. Thanks.

Revision history for this message
In , Yifei-chen (yifei-chen) wrote :

Still, we cannot reproduce it on our 945GM with:
distro: Fedora 9
Libdrm: (master)1bae8844cafd70f6196116f6e84b0f36c069e976
Mesa: (master)53c2cc8fefa07723fc456d94eda292e201c41dae
xserver: (master)c2b668e6fff11c52f2a3f0dc3f4d1fc2c5bcf3e6
xf86_video_intel: (master)8d27247829fe4f55691ce68f9f4b14810fb34b32
kernel: 2.6.30-rc4

hibernate works fine, and vt switch works fine too after/before hibernate.

Revision history for this message
Andrew Ivanov (aa.ivanov) wrote :

Hi!

Today I came across something that seems interesting to me. After resuming from hibernation I'm getting blank screen for X. Text mode is working (I can use CTRL-ALT-F1 and run things on the text terminal), and I can verify that the programs in my graphical session are working. I simply can't see them. Just as ari197 wrote in comment 6.

The thing is: even though I cannot see my X session, I can make the laptop suspend by closing the lid for example. And once I resume from suspend I can again see the graphical screen. So far I have found no explanation why suspending with X invisible will result in X visible after resume.

My video hardware is:
andrew@sat11:~$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

I'm running xserver-xorg-video-intel version 2.7.1 from http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu with UXA Accel-Method. For suspend/hibernate I'm using uswsusp version 0.8-1.1ubuntu3 because of some issues with the default method (overheating, unexpected poweroffs, etc).

Please let me know if any further information is needed.

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Yeah, this works well for me on an AspireOne...

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Spoke too soon.. my machine hard hung shortly after returning from hibernate... investigating.

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Ah no I think something else was broken in my environment (was running some debug code). Resume from hibernate appears ok with current bits.

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Arg no, right after I hit commit on my last comment it hung again...

Revision history for this message
In , yakuizhao (yakui-zhao) wrote :

(In reply to comment #14)
> Arg no, right after I hit commit on my last comment it hung again...
How about doing the hibernation/resume under the console mode and then start X?Does the system still hang after starting X?
Thanks.

Revision history for this message
In , yakuizhao (yakui-zhao) wrote :

Created an attachment (id=27321)
Restore the modeset for every activated crtc

Will you please try the attached patch on the latest linus git tree and see whether the issue still exists?

Thanks.

Revision history for this message
In , yakuizhao (yakui-zhao) wrote :

Ping Bryce?

Revision history for this message
In , Oleksij Rempel (olerem) wrote :

This patch solved same resume issue on my pc (intel DG45ID)

Revision history for this message
In , Oleksij Rempel (olerem) wrote :

Created an attachment (id=27404)
dmesg_after_w_patch

Revision history for this message
In , Oleksij Rempel (olerem) wrote :

I have other bug related to resume on this pc.
http://bugzilla.kernel.org/show_bug.cgi?id=13710

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress
Revision history for this message
In , Bryce Harrington (bryce) wrote :

ykzhav, note that I forwarded this from a ubuntu reporter, ari197. I am not experiencing this bug myself.

I have asked ari197 to subscribe to this bug, and now have provided .debs of the git version of the driver including your patch for them to test with.

Revision history for this message
Bryce Harrington (bryce) wrote :

ari197: Upstream has provided a patch for you to test.

In case you don't want to build the driver yourself, I've set up a PPA for this bug for you to test with against Karmic:

 https://edge.launchpad.net/~bryceharrington/+archive/orange

It may take a couple hours from the time of this email before the packages are built for you.

Please report your findings to the upstream bug at:
 http://bugs.freedesktop.org/attachment.cgi?id=27321

Revision history for this message
In , yakuizhao (yakui-zhao) wrote :

According to the discussion/comments I make some changes about the patch in comment #16. Now the patch set is already sent to intel-gfx mailing list.
    >http://lists.freedesktop.org/archives/intel-gfx/2009-July/003255.html
    >http://lists.freedesktop.org/archives/intel-gfx/2009-July/003256.html
    >http://lists.freedesktop.org/archives/intel-gfx/2009-July/003257.html

    Patch 1: resumes the modesetting for every activated crtc
    Patch 2: disable the unused connectors while resuming the modesetting
    Patch 3: Split the suspend/resume into KMS/UMS path to avoid resuming the modesetting registers twice in KMS mode.

thanks.

Revision history for this message
In , yakuizhao (yakui-zhao) wrote :

Since the mentioned patch set is already shipped, the bug will be marked as resolved.
   >Patch 1/3: commit 354ff96772540d2e836194bf14dd9c05c274055c
Author: Zhao Yakui <email address hidden>
Date: Wed Jul 8 14:13:12 2009 +0800
    drm/i915: Restore the KMS modeset for every activated CRTC
   >Patch 2/3: commit af4fcb574efa90373b02ae0bb8b54d710c32eeb4
Author: Zhao Yakui <email address hidden>
Date: Wed Jul 8 14:13:13 2009 +0800
    drm: Disable the unused connectors explicitly when resuming with KMS.
   >Patch 3/3: commit fccdaba4317604602e5802c3afc4021f2fb8132e
Author: Zhao Yakui <email address hidden>
Date: Wed Jul 8 14:13:14 2009 +0800
    drm/i915: Avoid saving/restore the modesetting registers twice in KMS mode

   If the issue still exists after the test, please reopen it.

   Thanks.

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :

According to the upstream report, this was fixed with three kernel patches, so re-filing against the kernel for verification/backporting/etc.

Patches are:
http://lists.freedesktop.org/archives/intel-gfx/2009-July/003255.html
http://lists.freedesktop.org/archives/intel-gfx/2009-July/003256.html
http://lists.freedesktop.org/archives/intel-gfx/2009-July/003257.html

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → New
tags: added: xorg-needs-kernel-fix
Changed in linux (Ubuntu):
status: New → Triaged
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

After examining the patches Bryce referenced in the links above, I see these are already included in the current Karmic kernel tree (see below). I'm marking this Fix Released against the linux (Ubuntu) kernel package.

@ari197, if this is not resolved for you with the latest Karmic Alpha kernel (currently 2.6.31-4.21) , please feel free to reopen by setting the status back to New. Thanks.

ogasawara@emiko:~/ubuntu-karmic$ git log 354ff96772540d2e836194bf14dd9c05c274055c
commit 354ff96772540d2e836194bf14dd9c05c274055c
Author: Zhao Yakui <email address hidden>
Date: Wed Jul 8 14:13:12 2009 +0800

    drm/i915: Restore the KMS modeset for every activated CRTC

    Restore the modeset for every activated CRTC in course of resume.
    This is realized by calling the function of drm_helper_resume_force_mode.
    Note: it is meaningful only for the KMS mode.

    https://bugs.freedesktop.org/show_bug.cgi?id=21719
    https://bugs.freedesktop.org/show_bug.cgi?id=21708
    https://bugs.freedesktop.org/show_bug.cgi?id=22285
    https://bugs.freedesktop.org/show_bug.cgi?id=22263

    Signed-off-by: Zhao Yakui <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

ogasawara@emiko:~/ubuntu-karmic$ git log -p af4fcb574efa90373b02ae0bb8b54d710c32eeb4
commit af4fcb574efa90373b02ae0bb8b54d710c32eeb4
Author: Zhao Yakui <email address hidden>
Date: Wed Jul 8 14:13:13 2009 +0800

    drm: Disable the unused connectors explicitly when resuming with KMS.

    Signed-off-by: Zhao Yakui <email address hidden>
    Acked-by: Jesse Barnes <email address hidden>
    Acked-by: Dave Airlie <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

ogasawara@emiko:~/ubuntu-karmic$ git log -p fccdaba4317604602e5802c3afc4021f2fb8132e
commit fccdaba4317604602e5802c3afc4021f2fb8132e
Author: Zhao Yakui <email address hidden>
Date: Wed Jul 8 14:13:14 2009 +0800

    drm/i915: Avoid saving/restore the modesetting registers twice in KMS mode

    In KMS mode we now use the normal mode-setting paths to set the modes
    back to the current configuration, so we don't need to also run the more
    limited non-KMS implementation of modesetting for resume.

    Signed-off-by: Zhao Yakui <email address hidden>
    Acked-by: Jesse Barnes <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.