please add lenovo-sl-laptop to ubuntu sauce

Bug #351586 reported by zdzichu on 2009-03-30
108
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ike Panhc
linux-backports-modules-2.6.27 (Ubuntu)
Medium
Unassigned
linux-backports-modules-2.6.28 (Ubuntu)
Medium
Unassigned

Bug Description

SRU justification:

Impact: Lenovo-SL laptops are missing some important functionality as the thinkpad-acpi driver does not support these models.

Fix: For Intrepid and Jaunty we add this driver to the backports-modules package, for Karmic it was included in the ubuntu-modules (in the kernel-package)

Testcase: see below

---

Please add driver for Lenovo SL Thinkpads to kernel. Those laptops are not really Thinkpads, and without additional driver they are half-working. Things which won't function properly without driver:
- bluetooth
- volume keys
- brightness control

Not working volume keys are minor thing, but no functioning BT and brightness are real issues.

Driver is available here: http://github.com/tetromino/lenovo-sl-laptop/tree/master
It compiles without problem with Jaunty Beta kernel, I've tested it on Thinkpad SL500.
It is being proposed for inclusion in kernel proper: http://patchwork.kernel.org/patch/7427/
Additionaly, as it only adding functionality, it won't cause any regressions.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Konrad Paumann (kopa) wrote :

There are also patches for the brightness control in:
http://bugzilla.kernel.org/show_bug.cgi?id=12249

Ike Panhc (ikepanhc) wrote :

Since I am using an SL400.
Its good for me to have this issue

Changed in linux:
assignee: nobody → ikepanhc
status: Triaged → In Progress
zdzichu (zdzichu-gmail) wrote :

Ike, how's going with adding this patch? As 9.04 is in RC stage, getting this fix later may require cumbersome SRU process.

Ike Panhc (ikepanhc) wrote :

Hi Zdzichu,

9.04 has been freeze for release, and now only accept for SRU patches.
I will add the driver as an backport module with Jaunty and Intrepid.

Johannes Hessellund (osos) wrote :

@Ike

When do you suppose the module will be in backports ?

Ike Panhc (ikepanhc) wrote :

Hi Johannes,

I try to contact with the author of the driver, to have more information such as willing to merge into kernel upstream or any planning upgrade.

Unfortunately I have not got any response. I will try to send another mail for this

Stefan Bader (smb) wrote :

Committed to Intrepid LBM

Changed in linux-backports-modules-2.6.27 (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Stefan Bader (smb) wrote :

Committed to Jaunty LBM

Changed in linux-backports-modules-2.6.28 (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Stefan Bader (smb) wrote :

Karmic carries the driver in the ubuntu modules

Changed in linux (Ubuntu):
status: In Progress → Fix Released
description: updated
Martin Pitt (pitti) wrote :

Accepted linux-backports-modules-2.6.28 into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I am running Karmic on a SL300, but none of the functionality provided by this module works yet. Is there anything you need to do to enable it?

Martin Pitt (pitti) wrote :

Accepted linux-backports-modules-2.6.27 into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Konrad Paumann (kopa) wrote :

Like Wouter I don't see any changes in functionality on jaunty.
linux-backports-modules-2.6.28-13-generic version 2.6.28-13.14
linux-backports-modules-jaunty-generic version 2.6.28-13.17

do we need to enable backport modules?

Amol (amolmodi) wrote :

The new modules are working great on my SL300. For those who don't have it working, I suggest making sure that your keyboard shortcuts for volume up, volume down and volume mute are set to XF86AudioRaiseVolume, XF86AudioLowerVolume and XF86AudioMute respectively.

Oh, audio keys etc. are working fine.

Its just the backlight control, that has still problems.

Is your backlight control working as it should?

On Mon, Jun 15, 2009 at 17:25, Amol<email address hidden> wrote:
> The new modules are working great on my SL300. For those who don't have
> it working, I suggest making sure that your keyboard shortcuts for
> volume up, volume down and volume mute are set to XF86AudioRaiseVolume,
> XF86AudioLowerVolume and XF86AudioMute respectively.
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Konrad Paumann
Adolf-Kolping-Straße 11/22
2000 Stockerau
Austria
+43 650 8409088

Martin Pitt (pitti) on 2009-06-16
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.28 - 2.6.28-13.14

---------------
linux-backports-modules-2.6.28 (2.6.28-13.14) jaunty-proposed; urgency=low

  [ Ike Panhc ]

  * Add driver for Lenovo SL Thinkpads
    - LP: #351586
  * SAUCE: Add dmi pattern for Lenovo SL laptop
    - LP: #351586

  [ Stefan Bader ]

  * Bump ABI for proposed kernel
  * Add lenovo-sl-laptop in backport package
    - LP: #351586

linux-backports-modules-2.6.28 (2.6.28-12.13) jaunty-proposed; urgency=low

  [Stefan Bader]

  * Bump ABI for proposed kernel

 -- Stefan Bader <email address hidden> Mon, 11 May 2009 17:26:22 +0200

Changed in linux-backports-modules-2.6.28 (Ubuntu):
status: Fix Committed → Fix Released
Cloves Almeida (cjalmeida) wrote :

Volume and bluetooth is working OK.

For the beginners, you must install de "linux-backports-modules-<distro>" and then "modprobe lenovo_sl_laptop".

As reported, brightness control is still not working.

The workaround is to execute

echo 85 > /proc/video/VGA/LCDD/brightness

Mikkel Andersen (msalia) wrote :

.. or echoing a value from 0 to 13 (it appears) into /sys/class/backlight/acpi_video0/brightness (using a SL500). But this sys entry doesn't appear to depend on having the lenovo-sl-laptop loaded.

What is the status on this bug?

Martin Pitt (pitti) wrote :

Copied to intrepid-updates

Changed in linux-backports-modules-2.6.27 (Ubuntu):
status: Fix Committed → Fix Released
Gary Trakhman (gary-trakhman) wrote :

The module is missing from 2.6.31-1fix and 2.6.31-2

Michael Helmling (supermihi) wrote :
Download full text (4.6 KiB)

I think this is because the module doesn't compile with 2.6.31, I get this:

michael@michi-sl300:~/linux-kram/lenovo-sl-laptop$ LC_ALL=C make
make -C /lib/modules/2.6.31-2-generic/build M=/home/michael/linux-kram/lenovo-sl-laptop modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.31-2-generic'
  CC [M] /home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.o
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: In function 'bluetooth_get_radiosw':
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:227: error: 'RFKILL_STATE_HARD_BLOCKED' undeclared (first use in this function)
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:227: error: (Each undeclared identifier is reported only once
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:227: error: for each function it appears in.)
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:233: error: 'RFKILL_STATE_UNBLOCKED' undeclared (first use in this function)
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:233: error: 'RFKILL_STATE_SOFT_BLOCKED' undeclared (first use in this function)
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: In function 'bluetooth_update_rfk':
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:246: error: implicit declaration of function 'rfkill_force_state'
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: In function 'bluetooth_enable_show':
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:291: error: 'RFKILL_STATE_UNBLOCKED' undeclared (first use in this function)
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: At top level:
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:322: warning: 'enum rfkill_state' declared inside parameter list
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:322: warning: its scope is only this definition or declaration, which is probably not what you want
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: In function 'bluetooth_rfk_get':
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:329: error: dereferencing pointer to incomplete type
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: At top level:
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:333: warning: 'enum rfkill_state' declared inside parameter list
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:333: error: parameter 2 ('state') has incomplete type
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: In function 'bluetooth_rfk_set':
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:335: error: 'RFKILL_STATE_UNBLOCKED' undeclared (first use in this function)
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: At top level:
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:342: warning: 'enum rfkill_state' declared inside parameter list
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:343: warning: 'enum rfkill_state' declared inside parameter list
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c: In function 'lensl_new_rfkill':
/home/michael/linux-kram/lenovo-sl-laptop/lenovo-sl-laptop.c:346: ...

Read more...

Ike Panhc (ikepanhc) wrote :

Hi Micheal,

Yes it is. I am trying to figure out the change and let it work again, but it seems not only a minor change. There are also some feedback comes from last post on the linux-acpi mailing list. I am looking them now.

Gary Trakhman (gary-trakhman) wrote :

until then I guess we can just comment out the bluetooth and rfkill functionality? It's unfortunate that brightness has to be broken due to an unrealated issue.

Michael Helmling (supermihi) wrote :

Yes, if you completely comment out the two bluetooth related sections the module compiles again and you at least have backlight control, keys, etc.

Ike Panhc (ikepanhc) wrote :

Hi,

I wrote to the author, and I think the first thing we shall do is to push the driver to upstream.

The author said the major point before pushing to upstream is not to polling for the hotkey, it shall be event driven. I am trying to find interface of the hotkey event.

direx (direx.1) wrote :

The author commited a new version to the git repo which should work with 2.6.31.

Gary Trakhman (gary-trakhman) wrote :

yup, works for me! Please include it in the next kernel.

On Sun, Aug 9, 2009 at 9:32 AM, direx<email address hidden> wrote:
> The author commited a new version to the git repo which should work with
> 2.6.31.
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Gary Trakhman (gary-trakhman) wrote :

it might be nice to increase the hotkey polling Hz to about 20 or so
near the end of the .c file. The default is 5Hz, feels too slow to
me.

On Sun, Aug 9, 2009 at 11:38 AM, Grigory
Trakhman<email address hidden> wrote:
> yup, works for me!  Please include it in the next kernel.
>
> On Sun, Aug 9, 2009 at 9:32 AM, direx<email address hidden> wrote:
>> The author commited a new version to the git repo which should work with
>> 2.6.31.
>>
>> --
>> please add lenovo-sl-laptop to ubuntu sauce
>> https://bugs.launchpad.net/bugs/351586
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>

Ike Panhc (ikepanhc) wrote :

Hi direx/Gary

I saw that too. I will apply after review them.

I have found a way to use event-driving method to handle hotkey. I have mail the patch to the author for reviewing. So, the poling frequency will not a problem anymore.

Gary Trakhman (gary-trakhman) wrote :

neato, so it can go into mainline after all? That's good news for SL
series users. Does this driver also work on ideapads?

On Sun, Aug 9, 2009 at 6:59 PM, Ike Panhc<email address hidden> wrote:
> Hi direx/Gary
>
> I saw that too. I will apply after review them.
>
> I have found a way to use event-driving method to handle hotkey. I have
> mail the patch to the author for reviewing. So, the poling frequency
> will not a problem anymore.
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

What's the status on this issue in karmic?
I have an SL500 with karmic alpha6 and volume up/down and mute keys don't work (kernel: 2.6.31-10, is the above mentioned module still missing?).
For brightness I have the issue described in Bug #368506 (it's toggling between two phases for brightness up/down - this is probably because it has Intel GMA 4500MHD as all laptops mentioned in that bug - so may be not Lenovo specific).
Other keys, like change video output, stop/start music, printscreen, numlock seem to be working on SL500.

@Gergely Fábián
You have to manualy load it (modprobe lenovo-sl-laptop or add it to /etc/modules), see Bug #448157

Gary Trakhman (gary-trakhman) wrote :

also do acpi_backlight=vendor in kernel config

On Sat, Oct 10, 2009 at 1:38 PM, Jonathan Ernst <email address hidden> wrote:
> @Gergely Fábián
> You have to manualy load it (modprobe lenovo-sl-laptop or add it to /etc/modules), see Bug #448157
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Gary Trakhman (gary-trakhman) wrote :

sorry, in grub.cfg

On Sat, Oct 10, 2009 at 3:39 PM, Gary Trakhman <email address hidden> wrote:
> also do acpi_backlight=vendor in kernel config
>
> On Sat, Oct 10, 2009 at 1:38 PM, Jonathan Ernst <email address hidden> wrote:
>> @Gergely Fábián
>> You have to manualy load it (modprobe lenovo-sl-laptop or add it to /etc/modules), see Bug #448157
>>
>> --
>> please add lenovo-sl-laptop to ubuntu sauce
>> https://bugs.launchpad.net/bugs/351586
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>

Ike Panhc (ikepanhc) wrote :

Hi,

You will have lenovo-sl-laptop support in karmic. I will check if its ok in karmic beta or not.

I have modified the driver and send to linux-acpi mailing list. Hope there will be accepted by upstream soon.

http://patchwork.kernel.org/patch/49912/

Gary Trakhman (gary-trakhman) wrote :

what would it take to have it automatically configured on sl-laptops?

On Sun, Oct 11, 2009 at 9:26 PM, Ike Panhc <email address hidden> wrote:
> Hi,
>
> You will have lenovo-sl-laptop support in karmic. I will check if its ok
> in karmic beta or not.
>
> I have modified the driver and send to linux-acpi mailing list. Hope
> there will be accepted by upstream soon.
>
> http://patchwork.kernel.org/patch/49912/
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ike Panhc (ikepanhc) wrote :

It will, if not, please show me the result of "cat /sys/class/dmi/id/modalias".

Gary Trakhman (gary-trakhman) wrote :

I will try it with a livecd, I've had mine hard-coded to load in
/etc/modules for a while

On Sun, Oct 11, 2009 at 10:01 PM, Ike Panhc <email address hidden> wrote:
> It will, if not, please show me the result of "cat
> /sys/class/dmi/id/modalias".
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

@Ike Panhc
Thanks for working on it !

On current karmic it doesn't autoload with a SL400. I will post see Bug #448157 to bug #448157 once I get a new chance to see this laptop.

I can confirm on a SL300 running latest Karmic that brightness, sleep, play/pause/next/previous keys now all work out of the box. The volume up/down, mute and lock screen keys don't work though. They do work after a modprobe lenovo-sl-laptop.

cat /sys/class/dmi/id/modalias:

dmi:bvnLENOVO:bvr6AET52WW:bd12/10/2008:svnLENOVO:pn273852G:pvrThinkPadSL300:rvnLENOVO:rn273852G:rvrLENOVO6AET52WW:cvnLENOVO:ct10:cvrLENOVO6AET52WW:

Here are my output, it looks abit different:

dmi:bvnLENOVO:bvr6AET59WW:bd08/26/2009:svnLENOVO:pn2746AQG:pvrThinkPadSL:rvnLENOVO:rn2746AQG:rvrLENOVO6AET59WW:cvnLENOVO:ct10:cvrLENOVO6AET59WW:

Ike Panhc (ikepanhc) wrote :

Hi all,

Thanks for the report, well, the messages you post does not match the patten in the driver. Alan Jenkins suggests me to use the hotkey device as the pattern - well, sounds like a good idea.

Due to that Karmic has been freezed, Could you add a command "modprobe lenovo-sl-laptop" into /etc/rc.local. I will think about which way is better for udev to autoload this module.

zdzichu (zdzichu-gmail) wrote :

$ cat /sys/class/dmi/id/modalias
dmi:bvnLENOVO:bvr6AET50WW:bd11/10/2008:svnLENOVO:pn27464EG:pvrThinkPadSL500:rvnLENOVO:rn27464EG:rvrLENOVO6AET50WW:cvnLENOVO:ct10:cvrLENOVO6AET50WW:

Gary Trakhman (gary-trakhman) wrote :

dmi:bvnLENOVO:bvr6AET59WW:bd08/26/2009:svnLENOVO:pn2738CTO:pvrThinkPadSL300:rvnLENOVO:rn2738CTO:rvrLENOVO6AET59WW:cvnLENOVO:ct10:cvrLENOVO6AET59WW:

On Sat, Oct 24, 2009 at 10:09 AM, zdzichu <email address hidden> wrote:
> $ cat /sys/class/dmi/id/modalias
> dmi:bvnLENOVO:bvr6AET50WW:bd11/10/2008:svnLENOVO:pn27464EG:pvrThinkPadSL500:rvnLENOVO:rn27464EG:rvrLENOVO6AET50WW:cvnLENOVO:ct10:cvrLENOVO6AET50WW:
>
> --
> please add lenovo-sl-laptop to ubuntu sauce
> https://bugs.launchpad.net/bugs/351586
> You received this bug notification because you are a direct subscriber
> of the bug.
>

dmi:bvnLENOVO:bvr6AET58WW:bd05/29/2009:svnLENOVO:pn27466FG:pvrThinkPadSL:rvnLENOVO:rn27466FG:rvrLENOVO6AET58WW:cvnLENOVO:ct10:cvrLENOVO6AET58WW:

Konrad Paumann (kopa) wrote :

dmi:bvnLENOVO:bvr6AET57WW:bd04/01/2009:svnLENOVO:pn27382LG:pvrThinkPadSL300:rvnLENOVO:rn27382LG:rvrLENOVO6AET57WW:cvnLENOVO:ct10:cvrLENOVO6AET57WW:

I reopened the bug as it is still not completely fixed.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Ike Panhc (ikepanhc) wrote :

I have been suggested to use acpi:ATK0101 to detect if this is a Lenovo SL300/SL400 laptops. It works better and the commit is in upstream kernel after .32

commit 14f8af311e7d3e4198cbaade84a34f86505dcb37
Author: Ike Panhc <email address hidden>
Date: Thu Dec 3 07:45:11 2009 +0000

    asus-laptop: add Lenovo SL hotkey support

    Lenovo SL series laptop has a very similar DSDT with Asus laptops. We can
    easily have the extra ACPI function support with little modification in
    asus-laptop.c

    Here is the hotkey enablement for Lenovo SL series laptop.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Ike Panhc (ikepanhc) wrote :

Please reopen the bug if anyone find the hotkey is not workable on Ubuntu maverick or later

Michael Helmling (supermihi) wrote :

The hotkeys are working fine; however, the lenovo-sl-laptop module does also enable fan control which is not possible with asus-laptop. This is quite important since a lot of the Lenovo SL series laptops seem to have firmware bugs (or, at least, annoyances) causing the fan to run unnecessarily fast even if the laptop is idle. I would very much apprechiate if this fan controlling capability would somehow find it's way into the standard ubuntu kernel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.