[LENOVO 17045UG] suspend/resume failure

Bug #350178 reported by Jane Silber on 2009-03-28
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

Failed to resume after suspend. It *may* have been that the battery ran out while it was suspended, because I may have some funkiness in my battery. Or that could be entirely unrelated :)

ProblemType: KernelOops
Annotation: This occured during a previous suspend and prevented it from resuming properly.
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
InterpreterPath: /usr/bin/python2.6
MachineType: LENOVO 17045UG
Package: linux-image-2.6.28-11-generic 2.6.28-11.38
ProcAttrCurrent: unconfined
ProcCmdLine: root=UUID=53516ec1-432b-4321-8311-c62548033ef1 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.28-11.38-generic
SourcePackage: linux
StressLog: Error: [Errno 2] No such file or directory: '/var/lib/pm-utils/stress.log'
Tags: resume suspend
Title: [LENOVO 17045UG] suspend/resume failure
UserGroups:

Jane Silber (silbs) wrote :

Hi Jane,

Not sure if the following may have applied to your battery or not . . .

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-67765

Unfortunately the Battery Verification Tool they provide is for Windows. It also seems you have a ThinkPad X60s which may have since exceeded the expiration date to get a replacement. Regardless, I'll have the kernel team take a look. Thanks.

Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
Marf (marcuswiederhold) wrote :

Hallo zusammen!

Sounds like my problem if I put my Lenovo 3000 N500 into "suspend to ram" (standby) it will suspend correct. But instead to resume it reboots! "Suspend to disk" (hibernate) has a complete reboot as result!

I had read some HowTo's to localize the problem, so i tried this (source: https://wiki.ubuntu.com/DebuggingKernelSuspend#%2522resume-trace%2522%2520debugging%2520procedure%2520for%2520finding%2520buggy%2520drivers) :
[code]
sudo su
echo 1 > /sys/power/pm_trace
pm-suspend
[/code]

After the failed resume from suspend I restart my notebook and run on the console:
[code]
sudo su
cd /tmp
dmesg > dmesg.txt
grep "hash matches" dmesg.txt > dmesg_hash_matches.txt
[/code]

My dmesg_hash_matches.txt contains one line:
[ 2.646589] hash matches /build/buildd/linux-2.6.28/drivers/base/power/main.c:296

Maybe a problem with the driver? ... :-( I don't know (I'm just in Linux noob ;-) )

I also tried alternative suspend&resume tools like s2ram but it change nothing.
With Ubuntu 8.10 I didn't had any problems like that, maybe its really the driver in the Kernel?

Mit freundlichen Grüßen
Marfy :-)

Marf (marcuswiederhold) wrote :

Hallo zusammen!

A member and myself have tried to fix my problem via fine tuning of the pm-utils - without success. For more detail please see the original Topic at ubuntuusers.de http://forum.ubuntuusers.de/topic/mit-gnome-64bit-standby-to-ram-weckt-bildschi/

We reached the point: fix the ACPI. The problem here is, my ACPI-DSDT didn't have typical errors or warnings. The Intel ASL-Compiler produce the following output if I compile the standard DSDT.DSL:
=============================================================
marf@graphitdrake:~$ iasl -sa dsdt.dsl

Intel ACPI Component Architecture

ASL Optimizing Compiler version 20081204 [Jan 10 2009]

Copyright (C) 2000 - 2008 Intel Corporation

Supports ACPI Specification Revision 3.0a

dsdt.dsl 4667: Name (_VPC, 0x0140)

Warning 1098 - Unknown reserved name ^ (_VPC)

dsdt.dsl 4682: Method (_CFG, 0, NotSerialized)

Warning 1098 - Unknown reserved name ^ (_CFG)

dsdt.dsl 4810: Method (VPCM, 2, Serialized)

Warning 1087 - ^ Not all control paths return a value (VPCM)

ASL Input: dsdt.dsl - 8186 lines, 259376 bytes, 2987 keywords

AML Output: dsdt.aml - 27419 bytes, 724 named objects, 2263 executable opcodes

Compilation complete. 0 Errors, 3 Warnings, 0 Remarks, 7 Optimizations
=================================================================
The hole DSDT.DSL-File can you find here: http://paste.ubuntuusers.de/394966/

Is it possible that the ACPI-DSDT cause the problems?

By the way I figured out if I close the lid of my notebook it reboots. The settings of the Gnome-Power-Manager will completely ignored! Maybe the problems have the same cause?

Mit freundlichen Grüßen
Marfy :o)

Manoj Iyer (manjo) wrote :

Marf,

You said in your earlier comment:
My dmesg_hash_matches.txt contains one line:
[ 2.646589] hash matches /build/buildd/linux-2.6.28/drivers/base/power/main.c:296

Can you post the trace from the begning of the function? there is a TRACE_DEVICE(dev); call at the begning of the function, atleast that will give us idea which device is failing on resume.

Thanks

Marf (marcuswiederhold) wrote :

Hallo Manoj,

if I had right understood, you want my complete dmesg-output? You can find it on Ubuntuusers.de using this URL: http://paste.ubuntuusers.de/394883/ . If you are also interested in my lsmod-output, please use this URL: http://paste.ubuntuusers.de/394885/ .

I'm very sorry if I understand you wrong but my English is "a little bit" rusty *smile*

Thanks for your help!

PS:
Please note that I using now the Kernel-Version 2.6.28-13 but I still having the same issues.

Marf (marcuswiederhold) wrote :

Befor I forget... just a margin note ...

I also tested the 2nd Alpha of Ubuntu 9.10 and I also observed the same problems as in Jaunty.

Mit freundlichen Grüßen
Marf :-)

Marf (marcuswiederhold) wrote :

Hallo zusammen!

I continued my tests with the Ubuntu 9.10 Alpha version. In the 3th Alpha the problems with my notebook lid (closing the lid caused a reboot) are fixed! Unfortunately Suspend to Ram (StR) and Suspend to Disk are (StD) still buggy: the resume after StR fails and caused a reboot and StD results a immediate reboot.

If someone need more details, please say what you need and I try to get the information.

Mit freundlichen Grüßen
Marf :-)

Mitch Towner (kermiac) wrote :

Closed invalid bug task
@Gerry C. I have subscribed you to this bug so that you will hopefully see this message. Please visit #ubuntu-bugs on the freenode IRC network & ask for advice before adjusting bug reports that are already triaged. There are plenty of people in that channel that would be more than happy to help you with learning bug triaging. Thanks

Changed in acpi (Ubuntu):
status: New → Invalid

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers