Comment 22 for bug 349314

I tried Andy's 2.6.28-11.38lp349314apw1 kernel on my Mac mini Core Duo with Intel GMA950 on mdz's recommendation after following Bug #339555 and Bug #353245 but have inconclusive results.

After my initial Intrepid to Jaunty upgrade video performance was basically unusable even with all Visual Effects disabled. Just moving windows around the screen resulted in choppy refresh, and switching workspaces took 2-3 seconds for all the windows to redraw.

I eventually tested using a Jaunty Desktop Beta i386 LiveCD and performance was normal; video was just as fast, crisp, and smooth as I was used to with Intrepid.

I then reboot back to the internal disk and video performance was mysteriously better. Still not on par with Intrepid but usable. No configuration changes or package upgrades were made.

A dist-upgrade was done to pick up the latest packages but still no additional improvement.

I then installed Andy's 2.6.28-11.38lp349314apw1 kernel and performance seems better compared to my original unusable Intrepid to Jaunty upgrade, but performance doesn't come close to my test on the Jaunty Desktop Beta i386 LiveCD.

Hence, my inconclusive results.

My unscientific test is simple...create 4 workspaces (2 rows, 2 columns), open a Firefox window on each workspace, then rapidly switch between workspaces with Ctrl-Alt-Arrow. On Intrepid and the Jaunty Desktop Beta i386 LiveCD switching workspaces is smooth and fluid. On my upgraded Jaunty install it sometimes takes 2-3 seconds to switch workspaces as the windows choppily animate across the screen.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

(II) intel(0): Attempting memory allocation with tiled buffers.
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on back buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on depth buffer: rejected by kernel
(II) intel(0): Tiled allocation successful.