Keyboard/mouse unresponsive for several seconds after resume

Bug #346310 reported by Matt Zimmerman
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Medium
Unassigned
Nominated for Lucid by karlrt

Bug Description

Binary package hint: xserver-xorg-input-evdev

Each time I resume from suspend, when I start typing into the gnome-screensaver unlock dialog, I find that it doesn't respond. I also can't move the mouse. After several seconds, they start working again. This is easily reproducible on my system.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-input-evdev 1:2.1.1-1ubuntu3
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcVersion: Linux version 2.6.28-11-generic (buildd@yellow) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #35-Ubuntu SMP Wed Mar 18 21:55:34 UTC 2009
SourcePackage: xserver-xorg-input-evdev
Uname: Linux 2.6.28-11-generic x86_64

Revision history for this message
Matt Zimmerman (mdz) wrote :
Revision history for this message
Bryce Harrington (bryce) wrote :

I finally got a reply from peter on this a little while ago...

From: Peter Hutterer <email address hidden>

Sorry, this one nearly got lost.

Bryce Harrington wrote:
> We've been noticing that there is occasionally a slight but noticeable
> delay after resuming from suspend before keyboard input is accepted,
> which we've traced to the EvdevReopenTimer() routine (commit
> 32768f8acd49f49a3daa7965fc2672ca13306780).
>
> Could you explain what causes the file descriptor to be openable but
> not able to be read? Is there a way the lag could be reduced, if not
> eliminated?

Don't know, but the kernel that shipped with F9 had this quite frequently.
I don't see this happening anymore, so you can try ripping out the timer
code and see if it just comes back most of the time anyway.

Changed in xserver-xorg-input-evdev (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Matt Zimmerman (mdz)
Changed in xserver-xorg-input-evdev (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce)
tags: added: jaunty
Revision history for this message
alx5000 (alx5000) wrote :

I used to experience this bug in 9.04, and it hasn't gone away in a fresh 9.10 install.

The delay doesn't always happen, but when it does, it takes 20 seconds or so for the keyboard and touchpad to start responding.

tags: added: karmic
Revision history for this message
Matt Zimmerman (mdz) wrote :

I still see this in current Lucid as well. I'm not at all certain that the problem lies in xserver-xorg-input-evdev. A good test would be to suspend and resume on the console, to see if the problem only occurs under X.

affects: xserver-xorg-input-evdev (Ubuntu) → linux (Ubuntu)
Revision history for this message
Matt Zimmerman (mdz) wrote :

I just confirmed that the same thing happens on the console, so I think we can rule out the X stack. It must be the kernel or lower.

Revision history for this message
alx5000 (alx5000) wrote :

Matt,

I wouldn't be so sure about it being a kernel issue since, at least in my case, I can switch to a text console (Ctrl+Alt+F1) while the keyboard and mouse are unresponsive in the X session. If I Ctrl+Alt+F7 back, the mouse and keyboard still don't respond, but I can still switch back and forth to vt1. After some 28-29 seconds since resuming, they start working all right again.

Another thing that I've noticed is that this tends to happen only when I'm running on battery, and not when the AC adaptor is connected, but I have to test this last hypothesis more thoroughly.

Revision history for this message
Matt Zimmerman (mdz) wrote : Re: [Bug 346310] Re: Keyboard/mouse unresponsive for several seconds after resume

On Sat, Jan 30, 2010 at 03:25:17PM -0000, alx5000 wrote:
> I wouldn't be so sure about it being a kernel issue since, at least in
> my case, I can switch to a text console (Ctrl+Alt+F1) while the keyboard
> and mouse are unresponsive in the X session. If I Ctrl+Alt+F7 back, the
> mouse and keyboard still don't respond, but I can still switch back and
> forth to vt1. After some 28-29 seconds since resuming, they start
> working all right again.

When you switch to vt1, does the keyboard work? If not, I think this is
consistent with it being a kernel issue.

> Another thing that I've noticed is that this tends to happen only when
> I'm running on battery, and not when the AC adaptor is connected, but I
> have to test this last hypothesis more thoroughly.

It happens every time for me, though it is a much shorter duration than in
your case (perhaps 5 seconds). It is possible that our problems have
different root causes.

--
 - mdz

Revision history for this message
alx5000 (alx5000) wrote : Re: [Bug 346310] Re: Keyboard/mouse unresponsive for several seconds after resume

Yes, I can actually type and work in vt1, so mine must be a X or kde-related
issue.

Revision history for this message
Kevin Gustavson (kgustavson) wrote :

Add me as another data point. I've been irritated by this issue since doing a fresh install of 9.10. I always have the 5 second delay; both in gdm and in the console. I'm running 9.10 64bit on a Lenovo T60.

Revision history for this message
alx5000 (alx5000) wrote :

I think I found what's causing my problem: npviewer.bin.

I've tried suspending several times in a row, and every time npviewer was left running in the background, Xorg woke up using 100% CPU, and thus ignored all keyboard and mouse input.

If npviewer was killed before suspending, it seems to work all right. I'll try to do some more tests but, if I'm right about this, all I have to do is kill npviewer on suspend.

Revision history for this message
Matt Zimmerman (mdz) wrote : Re: [Bug 346310] Re: Keyboard/mouse unresponsive for several seconds after resume

On Sun, Feb 14, 2010 at 02:09:06PM -0000, alx5000 wrote:
> I think I found what's causing my problem: npviewer.bin.
>
> I've tried suspending several times in a row, and every time npviewer
> was left running in the background, Xorg woke up using 100% CPU, and
> thus ignored all keyboard and mouse input.
>
> If npviewer was killed before suspending, it seems to work all right.
> I'll try to do some more tests but, if I'm right about this, all I have
> to do is kill npviewer on suspend.

Sounds like you have a different problem. I tried killing npviewer, but I
still get the same (short, a few seconds) delay on resume.

--
 - mdz

Revision history for this message
karlrt (karlrt) wrote :

in my case (karmic and lucid beta1) the system is only unresponsive for like 5 -10 seconds. I cannot switch to vt1, the system is totally unresponsive, no key or touchpad / trackpoint is working (lenovo t61)

Revision history for this message
karlrt (karlrt) wrote :

Somehow it does not happen on all t61. Mine is a intel-onboard 14,1 widescreen model with a t7500 processor.

Cannot reproduce with another t61: 6460-6WG, hardware details see: http://www-307.ibm.com/pc/support/site.wss/quickPath.do?quickPathEntry=64606WG it has nvidia grafics and an older processor.

Revision history for this message
karlrt (karlrt) wrote :

for me, killing gdm and suspending with pm-suspend or /etc/acpi/sleep.sh -force doesnt solve the problem, so it is clearly not np-viewer related, must be kernel problem. (takes about 5 sec after console shows up to be able to type)

Revision history for this message
matt s (matt-smalley) wrote :

Thinkpad x201 and ubuntu 10.04.1. At first I thought it was wireless hanging the system until it picked up a connection, but I tried suspending and resuming w/ the card off (via hardware switch) and it was the same 3-4 seconds of unresponsiveness. Let me know what else I can provide/test.

Revision history for this message
Matt Zimmerman (mdz) wrote :

I no longer see this behavior in 10.10.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Matt Zimmerman (mdz) wrote :

If you still see this behavior, you must have a different issue, so please file a separate bug.

Revision history for this message
karlrt (karlrt) wrote :

I will do so, just tested on maverick amd64, its still the same: i can type, but mouse is unresponsive for about 5-10 sec.

Revision history for this message
karlrt (karlrt) wrote :

if any of the other people are still affected like me, this is the new bug: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/660783

Revision history for this message
Kenrick Bingham (loxo) wrote :

As for matt s in #15, I have the same problem with my ThinkPad X201 running Ubuntu 10.04.1. It would be great to have a fix also for 10.04.1.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers