gprs/3g driver in 9.04

Bug #345002 reported by Bor_Ed on 2009-03-18
90
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Declined for Karmic by Scott Kitterman
Jaunty
Undecided
Mario
udev (Ubuntu)
Low
Scott James Remnant (Canonical)
Declined for Karmic by Scott Kitterman
Jaunty
Undecided
Unassigned

Bug Description

SRU justification:

Impact: The builtin machanism will not attach some 3g modems if usbserial is not a module.

Fix: Change back usbserial to be a module.

Testcase: Modem is not detected without special boot arguments when the driver is built in. It will be detected when the driver is a module.

Binary package hint: kernel-package

usbserial driver seems to be removed from ubuntu 9.04 kernel.
However, Huawei U120/Vodafone 715 phone works only with that driver.
Kernel version:
2.6.28-10-generic #33-Ubuntu SMP Tue Mar 17 12:27:50 UTC 2009 i686 GNU/Linu
lsusb for the device:
Bus 004 Device 002: ID 12d1:1009 Huawei Technologies Co., Ltd. U120

Pete Graner (pgraner) wrote :

Its now built into the Jaunty kernel, you don't need to use the module anymore. You should have your /dev/TTYUSBx devices created at boot.

Changed in kernel-package:
assignee: nobody → pgraner
importance: Undecided → Low
status: New → Incomplete
Bor_Ed (ari-mittila-gmail) wrote :

Kernel message from attaching the device to usb:
Mar 18 23:05:21 POMI kernel: [ 295.212037] usb 4-1: new full speed USB device using uhci_hcd and address 3
Mar 18 23:05:21 POMI kernel: [ 295.393283] usb 4-1: configuration #1 chosen from 1 choice

Seems that the built-in driver doesn't have the device identified?
Can you add the mentioned device/vendor to next build of 2.6.28 if you keep the module as built-in to kernel or could you move it to userland so it could be given parameters to run devices that aren't listed in the headers?

Pete Graner (pgraner) wrote :

Have you ever had this device working in Ubuntu? If so what version? Did you need any module options to get it working? I can't find reference to this device ever being supported in the kernel source.

Bor_Ed (ari-mittila-gmail) wrote :

The device has worked on ubuntu versions 8.04 and 8.10.
I had to add vendor and product options to /etc/modules to get the usbserial driver to recognize the device.

Pete Graner (pgraner) wrote :

@Bor_Ed

As a short term workaround until we can get it added pls try and report back with:

Built in modules can have module params passed on the kernel command line: can you try booting with:

usbserial.vendor=0x12d1 usbserial.product=0x1099

You will need to press ESC during to grub pause upon restart/power on.

Arrow down to the kernel you wish to boot.

press "e" (for edit)

Arrow down to the 2nd line (the command line)

Press Enter to begin editing

Arrow to the end of the line and add:

usbserial.vendor=0x12d1 usbserial.product=0x1099

When done press enter. Then press "b" to boot

Bor_Ed (ari-mittila-gmail) wrote :

[15577.706085] usb 4-1: new full speed USB device using uhci_hcd and address 2
[15577.901865] usb 4-1: configuration #1 chosen from 1 choice
[15577.904396] usbserial_generic 4-1:1.0: generic converter detected
[15577.904514] usb 4-1: generic converter now attached to ttyUSB0
[15577.907246] usbserial_generic 4-1:1.1: generic converter detected
[15577.907533] usb 4-1: generic converter now attached to ttyUSB1

After adding the mentioned parameters to /boot/grub/menu.lst...
Any change to have the device id included on future kernels without such hack?

And thanks for helping even this far :D

Bor_Ed wrote:
> [15577.706085] usb 4-1: new full speed USB device using uhci_hcd and address 2
> [15577.901865] usb 4-1: configuration #1 chosen from 1 choice
> [15577.904396] usbserial_generic 4-1:1.0: generic converter detected
> [15577.904514] usb 4-1: generic converter now attached to ttyUSB0
> [15577.907246] usbserial_generic 4-1:1.1: generic converter detected
> [15577.907533] usb 4-1: generic converter now attached to ttyUSB1
>
> After adding the mentioned parameters to /boot/grub/menu.lst...
> Any change to have the device id included on future kernels without such hack?
>
> And thanks for helping even this far :D
>

Working on the patch now. Should be in the next upload.

Pete Graner (pgraner) wrote :

@Bor_Ed

Can you provide the output of lsmod

Thanks

Bor_Ed (ari-mittila-gmail) wrote :

http://pastebin.com/m6d67479f a bit too long to be pasted here, valid for a month on the link...

Pete Graner (pgraner) wrote :

There is no good way to work around this bug. usbserial doesn't have a list of ID's in the driver that can be quirked. The only way with the usbserial driver compiled in is to use the work around documented above which is not a good solution.

We will be moving the driver back into a module.

Tim Gardner (timg-tpi) wrote :
affects: kernel-package (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
milestone: none → ubuntu-9.04
status: Incomplete → Fix Committed
Stefan Bader (smb) on 2009-04-16
description: updated
Bor_Ed (ari-mittila-gmail) wrote :

I would like to add again that the device string needs to be added to /etc/modules or other suitable place too (udev handler or such) to get the module loaded for the device.

Pete Graner (pgraner) on 2009-04-16
Changed in udev (Ubuntu):
assignee: nobody → scott
importance: Undecided → Low
milestone: none → jaunty-updates
status: New → Confirmed

Why has a udev task been opened on this bug?

If we want to add a particular id set to the usbserial module, we should add it *to the module* - I will not work around this in userspace in either udev or module-init-tools

(though it's quite acceptable for a user to do it themselves)

Changed in udev (Ubuntu):
status: Confirmed → Incomplete
Timbba (timbba) wrote :

Fix is committed to have a module instead built-in to kernel, but... When will this be released for Jaunty?

Steve Langasek (vorlon) wrote :

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) on 2009-05-01
tags: added: hw-specific
mattycoze (mattycoze) wrote :

I've enabled the -proposed repositories in the package manager, but I'm not sure what packages need installing to fix this problem on my laptop.

Can someone please post what needs to be downloaded and installed... are they 'verification-needed' and 'hw-specific'?

Marked the udev tasks as Invalid

Changed in udev (Ubuntu Jaunty):
status: New → Invalid
Changed in udev (Ubuntu):
status: Incomplete → Invalid
Bor_Ed (ari-mittila-gmail) wrote :

I've been busy on other issues but here it comes:
2.6.28-12-generic #43-Ubuntu SMP Fri May 1 19:27:06 UTC 2009 i686 GNU/Linux << package seems to have the usbserial.ko built as module and the device id can be added to /etc/modules
Big thanks to all working with the issue.

Same problem, same solution for AT91xx USB devices like

XAiOX iTackU GPS logger: usbserial.vendor=0x03EB usbserial.product=0x6125 (tested)
Gisteq PhotoTrackr GPS logger: usbserial.vendor=0x03EB usbserial.product=0x6126 (estimated)

So I vote for usbserial as a module too.

Affected application see http://itu4l.schimmelnetz.de

Josua Dietze (digidietze) wrote :

New 3G devices pop up all the time. It's awkward for users during testing to reboot all the time, just to change vendor/product ID and other parameters for "usbserial". Please bring back the "usbserial" module.

Annother (indirectly) affected application: http://www.draisberghof.de/usb_modeswitch/

Pete Graner (pgraner) wrote :

@Josua

The module is no longer complied in the kernel. You can get it now by enabling the -proposed repo and updating the kernel, or you can wait until it hits the -updates repo.

Changed in linux (Ubuntu):
milestone: ubuntu-9.04 → jaunty-updates

Me too affected , after upgrading from working 8.10 to 9.04 ZTE MF628 Modem does not work.

LanceKates (lancekates) wrote :

For those interested, 9.04 seems to be able to automatically detect some of these 3g modems.

Specifically, I have the Sierra Compass 597, with Sprint. It was activated on my laptop with my previous os (Windows) and now in 9.04 appears to be wholly plug and play. I didn't even need to disable my wifi in my laptop to start using the air card.

Josua Dietze (digidietze) wrote :

Sierra (the corporation) is actively developing an open kernel driver for their USB devices. I wish all manufacturers would follow their example (by the way Option does it too).

ubuntu_user (purwadijoko) wrote :

I have problem too, about this case.
If i use usb live or cd-live ubuntu how i can add usbserial option ?
where i must write
usbserial.vendor= ................. usbserial.product=..........................

I can't see grub/menu.list in my ubuntu drive ?

ramnarayan (ramnarayan) wrote :

Hi

This is regarding a device - Huawei ETS 2288 (CDMA Fixed Wireless Data Phone) its details are
vendor=0x0451 usbserial.product=0x3410

This *used to work on 7.04 and 7.10* and stopped being able to work on 9.04 and 8.10

The issue is the same as for the rest of the devices so would love to see this device work out of the box in future Ubuntu's as well as post expected update on 9.04 as well.

ram

ramnarayan (ramnarayan) wrote :

Hi

Tried to follow Peter Graner's suggestion of adding a line during the boot sequence

so did that
added
usbserial.vendor=0x0451 usbserial.product=0x3410

then booted and then tried wvdial and got this error

laptop:~$ sudo wvdial 93
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding.

So whats wrong

thanks
ram

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-13.44

---------------
linux (2.6.28-13.44) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement"
  * Revert "SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for
    Intel8x0"
  * Revert "SAUCE: [jaunty] ALSA: Fix buffer positions and checks"

linux (2.6.28-12.43) jaunty-proposed; urgency=low

  [ Amit Kucheria ]

  * Enable SYN_COOKIES for iop32x and versatile flavours
    - LP: #361687
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Brad Figg ]

  * [jaunty] Add missing mvsas (Marvel SAS 6440) module configuration.
    - LP: #352336

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Daniel T Chen ]

  * SAUCE: [jaunty] ALSA: Fix buffer positions and checks
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for Intel8x0
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement
    - LP: #345627

  [ Luke Yelavich ]

  * disable CONFIG_SND_HDA_INPUT_BEEP on amd64 and i386
    - LP: #331589

  [ Makito SHIOKAWA ]

  * [ARM] 5404/1: Fix condition in arm_elf_read_implies_exec() to set
    READ_IMPLIES_EXEC
    - LP: #364358

  [ Manoj Iyer ]

  * SAUCE: Added quirk to fix key release for Samsung NC20
    - LP: #360247

  [ Oleg Nesterov ]

  * posix timers: fix RLIMIT_CPU && fork()
    - LP: #361508

  [ Scott James Remnant ]

  * [Config] Disable libusual and the ub driver
    - LP: #364538

  [ Stefan Bader ]

  * Disable unwanted staging builds
    - LP: #366144
  * Remove prism2_usb driver from ubuntu and use the one from staging
    - LP: #325366
  * SAUCE: Make rtl8187se depend on WIRELESS_EXT
    - LP: #366144
  * Disable CONFIG_RTL8187SE for armel.versatile
    - LP: #366144

  [ Tejun Heo ]

  * libata: handle SEMB signature better
    - LP: #257790

  [ Tim Gardner ]

  * Set USB_SERIAL=m for i386/amd64
    - LP: #345002
  * SAUCE: Jaunty - aic79xx - set reset delay to 5 seconds, down from 15.
    - LP: #79542
  * SAUCE: (drop after 2.6.28) Wifi suspend/resume scan timeout fixes
    - LP: #336055
  * Sony laptop: Sony Vaio laptops do not enable wwan power by default.
    - LP: #364678

  [ Tyler Hicks ]

  * SAUCE: (drop after 2.6.28) eCryptfs: Larger buffer for encrypted
    symlink targets
    - LP: #357345

  [ Upstream Kernel Changes ]

  * V4L/DVB (9999): gspca - zc3xx: Webcam 046d:089d added.
    - LP: #326674
  * V4L/DVB (10044): gspca - pac7311: Webcam 093a:2620 added.
    - LP: #363195
  * hwmon: (it87) Add support for the ITE IT8720F
    - LP: #357766
  * vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * drm/i915: add support for G41 chipset
    - LP: #365958

 -- Stefan Bader <email address hidden> Mon, 25 May 2009 17:30:40 +0200

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
ramnarayan (ramnarayan) wrote :
Download full text (3.2 KiB)

/dev/ttyUSB0 error continues

see below
am trying to set up device Huawei ETS 2288 FWT CDMA data phone and this is the process and the error i get

June 20th 2009

After update to latest kernal for Ubuntu 9.04 in which the bug regardin setting up usbserrial modem / device was recitified

uname -a
$ uname -a
Linux ram-laptop 2.6.28-13-generic #44-Ubuntu SMP Tue Jun 2 07:57:31 UTC 2009 i686 GNU/Linux

dmesg
[ 1561.028072] usb 2-2: new full speed USB device using uhci_hcd and address 2
[ 1561.220236] usb 2-2: configuration #1 chosen from 1 choice
[ 1561.301994] usbcore: registered new interface driver usbserial
[ 1561.302027] USB Serial support registered for generic
[ 1561.302106] usbcore: registered new interface driver usbserial_generic
[ 1561.302110] usbserial: USB Serial Driver core
[ 1561.317962] USB Serial support registered for TI USB 3410 1 port adapter
[ 1561.317989] USB Serial support registered for TI USB 5052 2 port adapter
[ 1561.318023] ti_usb_3410_5052 2-2:1.0: TI USB 3410 1 port adapter converter detected
[ 1561.318033] usb 2-2: firmware: requesting ti_usb-v0451-p3410.fw
[ 1561.324629] usb 2-2: firmware: requesting ti_3410.fw
[ 1561.948049] usb 2-2: reset full speed USB device using uhci_hcd and address 2
[ 1562.099101] usb 2-2: device firmware changed
[ 1562.099131] ti_usb_3410_5052: probe of 2-2:1.0 failed with error -5
[ 1562.099150] usb 2-2: USB disconnect, address 2
[ 1562.099160] usbcore: registered new interface driver ti_usb_3410_5052
[ 1562.099163] ti_usb_3410_5052: v0.9:TI USB 3410/5052 Serial Driver
[ 1562.214592] usb 2-2: new full speed USB device using uhci_hcd and address 3
[ 1562.432244] usb 2-2: configuration #1 chosen from 2 choices
[ 1562.434201] ti_usb_3410_5052 2-2:1.0: TI USB 3410 1 port adapter converter detected
[ 1562.434219] ti_usb_3410_5052: probe of 2-2:1.0 failed with error -5
[ 1562.437185] ti_usb_3410_5052 2-2:2.0: TI USB 3410 1 port adapter converter detected
[ 1562.437292] usb 2-2: TI USB 3410 1 port adapter converter now attached to ttyUSB0

modprobe - works

~$ sudo modprobe usbserial vendor=0x0451 product-0x3410

No error message

details from wvdial.conf
[Modem0]
Modem = /dev/ttyUSB0
Baud = 115200
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
FlowControl = Hardware (CRTSCTS)
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
# Init3 = at+crm=1;+cmux=1;+cps=33;+cta=0
Modem Type = Analog Modem
Baud = 115200
New PPPD = yes
Modem = /dev/ttyUSB0
Idle Seconds = 90
Auto Reconnect = off

[Dialer 92]
Modem = /dev/ttyUSB0
Baud = 230400
Phone = #777
Init1 = ATZ
Stupid Mode = 1
Dial Command = ATDT
Username = 5XXXXX92
Password = 5XXXXX92
# below line error in spelling crtcts which should be crtscts
# PPPD Options = crtcts multilink usepeerdns lock defaultroute
# PPPD Options = crtscts multilink usepeerdns lock defaultroute
# Inherits = Modem0

$ sudo wvdial 92
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB0: Input/output error
--> Cannot open /dev/ttyUSB0: Input/output error
--> Cannot open /dev/ttyUSB0: Input/output error

So am not sure what problem exists and why this error continues to appear

**
some one suggested that this might be an error with wvdial - anyone thinks that...

Read more...

pistance (pistance) wrote :

i m bigginer in ubuntu 9.04, i have zte mf628 modem, i want to connect it to internet,
i want to explain to me ?
thanks for help :)

Hi
To solve this in ubuntu 904 I found the following work around:

in a terminal type the following
sudo nautilus (This will bring up the admin file manger)

the go to file system / boot /grub
under grub you will find "menu.lst" (I advise that you make a copy of
this file ;- to do this just copy and past it in the same directory)
then open this file and add the line "usbserial vendor=0x12d1
product=0x1411" to the end of the line that looks like the following
 "kernel /boot/vmlinuz-2.6.28-11-generic
root=UUID=7a427095-4b6f-4d3c-a486-65d5b6d27491 ro xforcevesa quiet
splash" and reboot

this will active the usb device at boot up (you might have to unplug the
modem once ubuntu has started ) once you have rebooted ubuntu should
pick up your modem under the network connection and you will be able to
set it there

Sould you have any problems please mail me and I will gladly help you

Kind Regards
Frans Gabriel
TEL 073 861 4383
HOME 011 021 2011
E-Mail <email address hidden>

lepay (arcmelta) wrote :

thanks very much

Changed in linux (Ubuntu):
assignee: Pete Graner (pgraner) → nobody
Changed in linux (Ubuntu Jaunty):
assignee: nobody → lepay (arcmelta)
Martin Pitt (pitti) on 2009-07-20
Changed in linux (Ubuntu Jaunty):
assignee: lepay (arcmelta) → nobody
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
ramnarayan (ramnarayan) wrote :

Hi

What does Confirmed mean ?
That the bug is in existence and will be rectified or that its already been rectified.

I am continuing to still have the same problem the said device Huawei ets 2288 Serial to USB still does not work

ram

Trond Husoe (tr-huso) wrote :

My onboard 3g/umds-card works, but it wvdial does not connect to it after suspend.
One funny thing though is that when I run the commands from wvdial and checks them by tailing /dev/ttyUSBx (sometimes it is 1, sometimes it is 2 and sometimes it is 0...) I can see that the modem is getting the commands, but wvdial still comes back with Modem not responding

Example (I have configured wvdial.conf to check how strong the signals are when running this command):
$ wvdial signal
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT+CSQ
--> Sending: ATQ0
--> Re-Sending: AT+CSQ
--> Modem not responding.

In the tail-window I get:
AT+CSQ
+CSQ: 1,99

OK

Please let me know if there are some log-files I shall send back.

Output of lsusb:
Bus 002 Device 003: ID 413c:8137 Dell Computer Corp. Wireless 5520 Voda L Mobile Broadband (3G HSDPA) Minicard Status Port

ramnarayan (ramnarayan) wrote :
Download full text (3.2 KiB)

The strange case of the Huawei ETS 2288 CDMA data phone on 7.10 and 9.04

As you may have tracked on this list i have been having major headaches trying to setp the above device on 9.04. Initially there was a usbserial bug and then it simply does not work.

But

Linux ram-laptop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

[ 14.244000] usb 3-1: reset full speed USB device using uhci_hcd and address 2
[ 14.384000] usb 3-1: device firmware changed
[ 14.384000] usb 3-1: USB disconnect, address 2
[ 14.384000] ti_usb_3410_5052: probe of 3-1:1.0 failed with error -5
[ 14.500000] usb 3-1: new full speed USB device using uhci_hcd and address 3
[ 14.716000] usb 3-1: configuration #1 chosen from 2 choices
[ 14.720000] ti_usb_3410_5052 3-1:1.0: TI USB 3410 1 port adapter converter detected
[ 14.720000] ti_usb_3410_5052: probe of 3-1:1.0 failed with error -5
[ 14.720000] usbcore: registered new interface driver ti_usb_3410_5052
[ 14.720000] /build/buildd/linux-source-2.6.22-2.6.22/drivers/usb/serial/ti_usb_3410_5052.c: TI USB 3410/5052 Serial Driver v0.9
[ 14.732000] ti_usb_3410_5052 3-1:2.0: TI USB 3410 1 port adapter converter detected
[ 14.732000] usb 3-1: TI USB 3410 1 port adapter converter now attached to ttyUSB0
[ 14.800000] ti_usb_3410_5052_1 ttyUSB0: TI USB 3410 1 port adapter converter now disconnected from ttyUSB0
[ 14.800000] ti_usb_3410_5052 3-1:2.0: device disconnected
[ 14.808000] ti_usb_3410_5052 3-1:2.0: TI USB 3410 1 port adapter converter detected
[ 14.808000] usb 3-1: TI USB 3410 1 port adapter converter now attached to ttyUSB0

and this is the rules file that is added

-$ /etc/udev/rules.d/026_ti_usb_3410.rules

#TI USB 3410

SUBSYSTEM=="usb_device" ACTION=="add" SYSFS{idVendor}=="0451",SYSFS{idProduct}=="3410" \

SYSFS{bNumConfigurations}=="2" \

SYSFS{bConfigurationValue}=="1" \

RUN+="/bin/sh -c 'echo 2 > /sys%p/device/bConfigurationValue'"

After this wvdial connects the device
***

On 9.04 the problem has been two fold initially in the 2.6.28.11 kernal there was a bug (https://bugs.launchpad.net/bugs/345002) to do with recognizing the cdma device and connecting it to the right /ttyUSB0 place, seemingly this has been resolved in kernal 2.6.28.13. But the said device 2288 still did / does not work - atleast not normally. The bug resolves the issue of the device being identified and being connected to /dev/ttyUSB0 by defualt, but It only works in this strange method outlined in the next para:-

first i need to boot up in 7.10 and run the device , after this i do a reboot and boot up into 9.04 and immediately startup the device - again using wvdial, and *strangely, if it connects on the first try the device works properly. If the connection gets broken then i get the error message

/ttyUSB0 input output error

**
it seems that the problem is that 9.04 does not load the right driver to the device, which someone told me is a dumb device and gets reset each time it gets attached to an OS.

So my question is how can i get 9.04 to load the right driver (without having to do the 7.10 and reboot thingaamajig)

Is there a way i can extract the correct firmware loaded in in 7.10 a...

Read more...

Mario (mariohs) on 2009-12-08
Changed in linux (Ubuntu Jaunty):
assignee: nobody → Mario (mariohs)
Changed in linux (Ubuntu Jaunty):
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed
Steve Langasek (vorlon) wrote :

Do not change bug states without explanation.

Changed in linux (Ubuntu Jaunty):
status: Confirmed → Fix Released
zakotani (zakotani) on 2010-02-06
Changed in linux (Ubuntu):
status: Confirmed → In Progress

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers