Ubuntu

no sound on nvidia-based Mac Mini (Macmini3,1)

Reported by David D Miller on 2009-03-17
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I just installed Ubuntu Intrepid on a paid of new nvidia-based Mac Minis (March 2009 model). Neither one has working sound. I've walked through the entirety of http://help.ubuntu.com/community/SoundTroubleshooting and tried everything on there short of recompiling ALSA from source. Plan to try that next, but if that fixes it, then you guys still need a bug report because the distributed build will need to be fixed, too. :)

Another thing that confuses me is that the troubleshooting tips on that page all seem to refer to ALSA for everything, while Intrepid appears to use PulseAudio instead. The only device that shows up in alsamixergui is PulseAudio. I did try uninstalling pulseaudio and just using bare ALSA, but that didn't change anything. I also installed the PulseAudio Device Chooser, and the only device it lists is "Default".

Everything in the system seems to claim that sound is working, and it all goes through the motions. There's just no sound coming out of the speakers. I do get the boot chime, and sound works in OS X.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: linux-image-2.6.27-11-generic 2.6.27-11.27
ProcCmdLine: root=UUID=c7151270-9d7a-4a98-b29f-8e1722385315 ro quiet splash
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-11.27-generic
SourcePackage: linux

David D Miller (justdave) wrote :
David D Miller (justdave) wrote :

I get the following repeating periodically in /var/log/messages:

Mar 16 19:44:23 basementhtpc pulseaudio[8217]: ltdl-bind-now.c: Failed to find original dlopen loader.
Mar 16 19:44:23 basementhtpc pulseaudio[8227]: pid.c: Stale PID file, overwriting.
Mar 16 19:44:23 basementhtpc pulseaudio[8227]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Mar 16 19:44:23 basementhtpc pulseaudio[8227]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

David D Miller (justdave) wrote :

And /var/log/syslog has the following two lines in addition to the ones above:

Mar 16 19:44:44 basementhtpc pulseaudio[8227]: module-x11-xsmp.c: X11 session manager not running.
Mar 16 19:44:44 basementhtpc pulseaudio[8227]: module.c: Failed to load module "module-x11-xsmp" (argument: ""): initialization failed.

bug 300275 mentions that error message, but no indication of what hardware it's on, and no resolution yet.

Hi David,

Just curious if you could also test the most recent pre-release of Jaunty 9.04, currently Alpha 6 - http://cdimage.ubuntu.com/releases/jaunty/ . If you could also please download and run http://alsa-project.org/alsa-info.sh with the --no-upload option:

./alsa-info.sh --no-upload

Then attach the resulting alsa-info.txt file to this bug report. Thanks in advance.

Changed in linux (Ubuntu):
status: New → Incomplete
David D Miller (justdave) wrote :

I've switched to 64bit instead of 32bit since I posted the original batch of attachments, but nothing changed with regards to the symptoms. Here's the alsa-info.txt you requested. I have a jaunty iso torrenting right now.

David D Miller (justdave) wrote :

Upgraded to jaunty with no change. Revised alsa-info.txt output from jaunty attached.

Changed in linux:
status: Incomplete → New

Architecture: amd64
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

So, some experimenting....

I hooked up a Griffin iMic USB Audio connector figuring a USB output was probably a standard supported thing...

Went into the GNOME Sound panel and hit the Test button.

With it set to Automatic, still no sound.
Manually chose Griffin Tech iMic USB Audio (ALSA), and I get an error: "audiotest wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback."
Manually chose Griffin Tech iMic USB Audio (OSS), and it works and I get sound.

Manually chose HDA NVidia ALC883 Analog (ALSA), which is the built-in sound, and got the identical error I got above with the iMic via ALSA.
Manually chose HDA NVidia ALC883 Digital (ALSA), and it goes through the motions but produces no sound.
Manually chose HDA NVidia ALC883 Analog (OSS), and it goes through the motions but produces no sound.

Changed in linux (Ubuntu):
assignee: nobody → ubuntu-audio
importance: Undecided → Medium
status: New → Triaged
thomateverte (tom-kitom) wrote :

Hello,

Did you try the suggested solution in this link (bottom of the page) : http://blog.costan.us/2009/03/ubuntu-810-or-904-on-mac-mini.html

It is suggested to add the following line to /etc/modprobe.d/alsa-base :

options snd-hda-intel model=imac24

David D Miller (justdave) wrote :

Woot, that works!!! Thanks! I'd been through bunches of different models thinking something like that might trigger it, but that one wasn't one that was tried. Can't remember where I found it, but there was a list of available models for the hda-intel driver somewhere, and I don't believe that one was on it for the ALC889A codec. Probably an out-of-date list.

I'm assuming the bug probably needs to stay open because the installer should be able to figure that out and configure it for you when you install, right?

Just because that option works for analog sound output, doesn't mean it will work for sound input either analog or digital, or digital sound output. Please test all of these if you can, to be sure that everything indeed does work.

David D Miller (justdave) wrote :

I have no way to test the digital audio. Don't have any other equipment
that'll talk to it. I'll see what I can do about testing the input though.

David D Miller (justdave) wrote :

The model=imac24 trick does not work for me on Intrepid, only on Jaunty. I still can't get sound working on Intrepid. (And mythbuntu-control-centre hangs Xorg when you try to apply config changes on Jaunty still, so I can't use Jaunty for my set-top box yet)

David D Miller (justdave) wrote :

my mythbuntu-control-centre issue was apparently something to do with compiz... I was having that hang anytime a dialog window showed up (as opposed to a normal window). I disabled the effects and it stopped hanging. So I have my mythtv stuff mostly working on jaunty now. I have two of these minis though, and have jaunty on one and intrepid on the other, so I'm more than happy to test stuff on either.

David D Miller (justdave) wrote :

OK, turns out the model=imac24 does work on Intrepid, it just needed a reboot ("rmmod snd-hda-intel && modprobe snd-hda-intel" without gdm running wasn't enough for some reason, though that did activate it on jaunty).

Philippe Normand (philn) wrote :

That model=imac24 doesn't work for me on jaunty with my nvidia-based mac mini. Any other hint?

Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
Pedro Alves (alves-ped) wrote :

> That model=imac24 doesn't work for me on jaunty with my nvidia-based mac mini. Any other hint?

Same thing for me. Did you ever solve this? I've done everything
I could find including making sure channels aren't muted, and even
going through Part A of http://ubuntuforums.org/showthread.php?t=789578 .

Any other hint?

I'm attaching my alsa-info.txt.

Darren Hammond (hammondchips) wrote :

I used model=mbp3 on mine after searching the net for similar postings

I can get sound out of the rear jack, but not from the built-in speaker

Pedro Alves (alves-ped) wrote :

read jack, good idea. I get sound out of of the rear jack (analog), with
either "model=mbp3" or "model=imac24", no difference. Still no sound from the built-in
speaker. I can't try digital/optical, as I don't have anything to connect it to.

I'm now running alsa from https://launchpad.net/~themuso/+archive/ppa , but it makes
no difference.

Luke Yelavich (themuso) wrote :

I managed to get my hands on a MacMini 3m1, and have written a quirk to make the hardware work properly out of the box. I'll post back here when the commit is in the crack of the day alsa builds for karmic and lucid, so that people can install those packages and get their audio working properly.

Torsti Schulz (torsti-schulz) wrote :

On my late 2009 Macmini3,1, running Lucid Lynx amd64, changing the model to mb5 solved the no-sound problem. I have not tested sound input or digital channels yet, and sound quality when using headphones is not good. The internal speakers do not seem to mute when headphones are plugged in. When the S/PDIF channel is unmuted it seems to be constantly on (I get a red light from the optical audio output jack).

A file created by alsa-info.sh is at http://www.alsa-project.org/db/?f=c7942ef843ebc8f28b5bbdba34c9a8d7803ebeba

So temporary solution for some Macmini3,1's is:
options snd-hda-intel model=mb5

I'll try to test some more later, to see what is working and what not whether if I should file a separate bug report.

Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Phil Dibowitz (jaymzh) wrote :

I'm also having this problem - with the latest Mac Mini.

I've tried:

model=mb5
model=intel-mac-auto
model=macmini
model=macmini3
model=mb3
model=mb5
model=imac24
model=imac27

Any other ideas? I'm attaching an also-info dump

Phil Dibowitz (jaymzh) wrote :

aha! I found a page (https://help.ubuntu.com/community/Macmini4-1/Maverick) that pointed me to model=mbp55, which works great.

Luke Yelavich (themuso) wrote :

Phil, your machine is a MacMini4,1, so this bug is not valid for you.

In order to get this hardware working, someone will likely need physical access to this hardware, however I won't know for sure till I get home and look at my Mac Mini 3,1 and compare the audio codec differences.

You could also try the instructions at the following URL to try the latest drivers:

https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

Please file a separate bug if the above URL doesn't help.

Phil Dibowitz (jaymzh) wrote :

Luke - yeah, I realized that after I posted, and found the link I posted about half an hour ago to the MacMini4,1 guide, which has working instructions (model=mbp55, as I mentioned).

Thanks,
- Phil

Has anyone succeeded in getting _line input_ working with a MacMini 3,1 on any Ubuntu release?
First, I've checked with a kernel version 2.6.32: input is functional, output doesn't work.
Kernel of subsequent versions do it the other way: output works fine but input is broken.

I've done quite a lot of tests, with many different kernels, using "ubuntu-audio-dev" PPA, specifying "model=macmini31", etc.
Alas, nothing worked :-(

I'd be grateful if someone could provide a solution!

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers