iwl3945 slow down after some time to 100kbps, unload/load module return speed to 1.5mbps

Bug #340418 reported by Virus on 2009-03-10
134
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Linux
In Progress
Unknown
linux (Ubuntu)
Medium
Andy Whitcroft
Declined for Jaunty by Jeremy Foshee
Declined for Karmic by Jeremy Foshee
Declined for Lucid by Jeremy Foshee
Declined for Maverick by Jeremy Foshee

Bug Description

problem with iwl3945 driver at "Intel Corporation PRO/Wireless 3945ABG Network Connection" adapter. speed after some time down to 100kbps. after module unload/load - 1.5Mbps. then all repeat.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: linux-image-2.6.27-11-generic 2.6.27-11.27
ProcCmdLine: root=UUID=5614b79d-7147-4c43-ac53-59cceda51ab5 ro quiet nosplash cyr
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=ru_RU.KOI8-R
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-11.27-generic
SourcePackage: linux

Virus (lanchpad) wrote :
Virus (lanchpad) wrote :

Please, commit this patch to package/kernel http://www.intellinuxwireless.org/bugzilla/attachment.cgi?id=1858

Virus (lanchpad) wrote :

Provided patch do not fix this issue. Check this thread for more info, please http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1932

Changed in linux:
status: Unknown → In Progress
Changed in linux:
status: In Progress → Fix Released
Virus (lanchpad) wrote :

not fixed yet. please, reopen.

Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → In Progress
Virus (lanchpad) wrote :

I was reinstall my kubuntu to last 9.04 (kernel 2.6.28-11-generic) but issue
not fixed. I was compile last compat-wireless - issue not fixed. Please, help.

evgheni (evgheni-ermolaev) wrote :

This problem comes and goes ever since 7.04.
I noticed one thing: When I turn on another laptop nearby (also with wireless Intel but another card) and connect it to the same network the speed goes back up (to 800 in my case)

Changed in linux:
status: In Progress → Confirmed
Virus (lanchpad) wrote :

not fixed yet. please, reopen.

Changed in linux:
status: Confirmed → In Progress
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Espen (espenbe) wrote :

I can confirm the same behaviour in Karmic alpha 6.

The module iwl3945 is being used and the computer is a DELL Latitude d820.

Output from "dmesg | grep -i iwl3945":

[ 80.021081] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 80.021085] iwl3945: Copyright(c) 2003-2009 Intel Corporation
[ 80.021212] iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 80.021227] iwl3945 0000:0c:00.0: setting latency timer to 64
[ 80.093138] iwl3945 0000:0c:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 80.093142] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 80.093301] iwl3945 0000:0c:00.0: irq 29 for MSI/MSI-X
[ 87.125725] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
[ 89.059763] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9

happyjon (happyjon) wrote :

i've got the same problem in 9.04. is there a temporary workaround? can i use another driver?

Virus (lanchpad) wrote :

Problem still not fixed.

Please, help.

shabong (shabong) wrote :

dmesg | grep -i iwl3945
[ 20.791597] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 20.791601] iwl3945: Copyright(c) 2003-2009 Intel Corporation
[ 20.791779] iwl3945 0000:06:00.0: enabling device (0000 -> 0002)
[ 20.791793] iwl3945 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 20.791813] iwl3945 0000:06:00.0: setting latency timer to 64
[ 20.862768] iwl3945 0000:06:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 20.862773] iwl3945 0000:06:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 20.862934] iwl3945 0000:06:00.0: irq 29 for MSI/MSI-X
[ 44.272958] iwl3945 0000:06:00.0: firmware: requesting lbm-iwlwifi-3945-2.ucode
[ 44.331307] iwl3945 0000:06:00.0: loaded firmware version 15.32.2.9
[ 48.512567] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 55.830103] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 59.540121] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 65.220065] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 70.180051] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 84.430210] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 91.482555] iwl3945 0000:06:00.0: Failed to get channel info for channel 140 [0]
[ 1316.640023] iwl3945 0000:06:00.0: Card state received: HW:Kill SW:On
[ 1316.773322] iwl3945 0000:06:00.0: Error sending REPLY_LEDS_CMD: enqueue_hcmd failed: -5
[ 1316.782709] iwl3945 0000:06:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0x040

shabong (shabong) wrote :

is someone addressing this issue or should I go download winblows?

Voyageur (igorekm) wrote :

Just the same issue with my wireless card (Acer 5920):
    06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
After some time the speed goes down to 100 kbps.
The bug is detected in Kubuntu Jaunty and in Kubuntu Karmic Beta! Please, help! The bug is rather important!

Mathieu Gauthier (oustedaisse) wrote :

I have this issue only from Karmic, my 3945ABG works well in Jaunty !

Espen (espenbe) wrote :

I have had this issue since Ubuntu 8.10 (or was it 8.04?). Put ipw3945 back to the kernel source, please.

Mathieu Gauthier (oustedaisse) wrote :

Hum yes... another way : I have upgraded my access point (Linksys WRT54GL) from DD-WRT v24 sp1 firmware to Tomato 1.25 (in details, 1.25.8515 .5 RAF ND Thor MOD) few days ago.

I will try on another access point (new HP AP) at my office with my computer (Dell D620) and check is connection slow down as it does with my Linksys...

Cyril Adrian (cadrian) wrote :

I also have the problem, in Karmic. It was already a bit slow in Jaunty but in Karmic it's to the point of not being useable.
I don't own the access point and cannot upgrade my laptop. What are the options?

bert07 (marien.bert) wrote :

Have any of you tried this. (Worked for my 2500rt on Ubuntu 08.10 and 09.04)

Add to /etc/rc.local

ifconfig wlan0 up
iwconfig wlan0 rate 54M fixed

exit 0

bnj (b2besses) wrote :

Same problem Linux 2.6.31-14-generic / Ubuntu Karmic
This suggestion does not change anythig on this issue for me
ifconfig wlan0 up
iwconfig wlan0 rate 54M fixed (I have alos tried lower rates)
The only way to restore the network is to reset the wifi with the following command
sudo modprobe -r iwl3945 && sudo modprobe iwl3945
Interresting details
- slow downs only happend on heavy loads (rates > 200 kB/s) on upload or upload
- when I stream my audio output to my ISP set top box I have a lot of sound glitch even if the ping is very low (3 to 8 ms). It works perfectly with wired connection.
Finally the wifi connection do the job for the web BUT it's not reliable for any local networking

Espen (espenbe) wrote :

None of the hints to improve the download/upload transfer rate in this thread actually helped me. What helped me was to replace my WLAN-router. I had a Linksys WRT54GL which did not give me a proper transfer rate. I complained to the salesman who gave me a new one (a new Linksys WRT54GL). With the new one I got exactly the same response.

Then I bought a cheap DLINK-router just to test, and wow - it worked like anything. After a week I still have about 7Mbit/s download speed. The Macs in our house did not have any problems getting full speed from the Linksys router though...

OK - I haven't really solved the problem, but now it works for me and I'm happy (but still a bit confused).

alump (sami-viitanen) wrote :

My iwl3945 have been working fine, then came Karmic. Now speed drops to 150kbps way too often. And this happens with multiple different WLAN boxes. Reconnecting in network manager is my workaround for this problem. But is there any better option?

xens (r-aviolat) wrote :

same problem on DELL Latitude D630

Nicholas Kamper (nick125) wrote :

I think that everyone here that is having the issue should report which access point they are having the issue with and whether the problem can be replicated with a different access point. It seems that quite a few people that are having this issue (myself included) are using the Linksys WRT54GL router, and some have reported that the issue goes away when using a different access point.

I'm using an Intel 3945ABG card in my Dell XPS m1330 in Karmic (Kernel 2.6.31-17-generic) and I'm having a similar issue. For the first 20-30 minutes after the connection is established, it works fine at a full 7mbit. However, after that point, it begins to degrade until I rmmod/modprobe iwl3945...and the cycle continues. I haven't noticed the issue with a Ubiquiti NS2L AP, so I'm starting to wonder if this is related to the WRT54GL.

evgheni (evgheni-ermolaev) wrote :

Hi Nick,
I had the same problem for at least two years. It appeared on Belkin and Netgear routers. The problem only appears when signal is quite low. Then the card scales down the speed and being unable to raise it back. Reconnecting usually helps for a few minutes, but then the same problem. In windows XP with the same conditions the speed is fine. Intel just really need to fix the driver, or rewrite it.

Nicholas Kamper (nick125) wrote :

evgheni,

The thing that's weird is that, for me, the signal strength seems fine. It's consistently in the -70 to -60dBm range (40-50/70 in link quality). But yeah, it seems that the Intel driver is quite poor. Infact, I would almost say that I've had better luck with ndiswrapper. I will say that for me, the issue didn't appear until I upgraded to Karmic.

I'll search around on the upstream bug tracker and see if I find anything of use, although it seems unlikely. Most of the "slow speed" bugs are quite vague.

Virus (lanchpad) wrote :

I think intel developers need more debug data here:

http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=1932

Please, send them if you can.

Becouse i change notebook to other one for solve this bug, any patch from intellinuxwireless was not help me.

Kim (kimoskamot) wrote :

Here suffering this bug with a Comtrend HG536+.

I got a second hand Zyxel P660HW for testing, I'll try to configure it and share the results with you.

Mathieu Gauthier (oustedaisse) wrote :

Dell D620 with iwl3945 and Linksys WRT54GL (1.1) for AP

NOK with latest version of DD-WRT
OK with an older version of DD-WRT (like January 2009)
NOK with all versions of Tomato

OK with HP AP (I don't know with model)
OK with Ralink RT2880 (wlan card include in Freebox v5, a French STB)

Nejc Saje (nejc-saje) wrote :

I had the exact same problem, solved it after many, many hours of trying all sorts of things. Solution in my case: G-Only wireless mode on WRT54GL.

Hope it works for someone else too.

Xavier (chantry-xavier) wrote :

Thanks a lot Nejc Saje , you're my hero !
I first noticed this problem more than 2 years ago :
http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=1592#c2
And never found a solution. I've been away most of that period, but that bug still annoyed me a lot during several months.

I've put more details after discovering your tip in the current intel bug :
http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=1932#c141

What didn't help me is that openwrt did not provide a way to configure this by default. After seeing your comment, I quickly got help from an openwrt developer to do that, and in the future version it should be possible to configure that out of the box.

I have the same problem using an apple airport express as AP. In my case the problem is clearly related
to distance to the AP and signal strength. If I am close to the AP (say 5 m), there is never any problem.
At 15 m, download rate suddenly drops to 100 kB / s. In that case, iwconfig reports "Link Quality=40/70 Signal level=-70 dBm".
If the module is reloaded, transfer rate is good again, but only for some minutes.

This bug exists since the birth of iwl3945... I have had it since 8.04 ! Any chance to see it fixed one day ?
What can we do to help ?

bert07 (marien.bert) wrote :

All this 'slowlyness' of certain netcards started with kernel 2.6.25 or 2.6.26.
I have the same problem since with my rt2500 (Belkin PCMCIA).
In the beginning of this problem, I could work around it for Puppy, Ubuntu and Mandriva. But when it came to kernel 2.6.28 that work-around didn't work any more.

As you can see (read) the problem is been around for a long time now. And I can see that this bug is in progress. But that doesn't help those who are 'infected' by this bug.

For what it's worth, I'll note the work-around again here. Maybe it might ring a bell for the people working on this bug.

---+---
Add to /etc/rc.local

ifconfig wlan0 up
iwconfig wlan0 rate 54M fixed

exit 0
---+---

In Puppy, I had to use this as a batch-file, because the file /etc/rc.local did not exist.

And as I said: since kernel 2.6.28 this doesn't work any more.

themuddler (mike-udall) wrote :

Nejc Saje:

Thanks! Solved it for me with a Thomson 585v7 router and Asus A8SC laptop. Selecting 'g' only worked a treat!

Jeremy Foshee (jeremyfoshee) wrote :

Declining the Maverick specific nomination for now and leaving this open against the actively developed Ubuntu kernel (which happens to be Maverick at this time). Will re-open the nomination should a fix be narrowed down which we can confirm specifically resolves this issue in Maverick.

~JFo

Changed in linux (Ubuntu):
status: In Progress → Confirmed
Derek Dolney (nospam-dolney) wrote :

I experienced this issue on gentoo. I eventually figured out that it was caused by power management for the wireless device. Check whether your kernel was built with CONFIG_CFG80211_DEFAULT_PS. I can transfer data all night without the speed drop if I disable this option.

As an alternative to rebuilding your kernel, there may be a boot option to disable power management, or you can try iwconfig wlan0 power off, but I get "Operation not supported" with iwconfig and I'm not sure why.

Unfortunately, disabling CONFIG_CFG_DEFAULT_PS does not solve the problem for me (also on gentoo, using gentoo-sources-2.6.35-r5).

I'm also on a mixed-mode wireless router (802.11bgn), which can not be set to g-only.

Eric Appleman (erappleman) wrote :

Bummer. I thought we had found a magic bullet?

What about the IEEE80211_HW_SUPPORTS_PS option?

I don't have a IEEE80211_HW_SUPPORTS_PS option in my kernel.

Eric Appleman (erappleman) wrote :

I hope the people that read this bug have some perspective on how serious things are.

Maverick will be the SIXTH release plagued by this issue.

Axel Pospischil (apos) wrote :

Hi there,

i am on Ubuntu lucid and a Thinkpad T61 with Intel Corporation PRO/Wireless 3945ABG [Golan] (via lspci).
Module is the iwl3945.
Access Point is an Linksys/Cisco WRT160Nv2 Router.

I solved the following problem
  [ 1860.200063] iwl3945 0000:03:00.0: Failed to get channel info for channel 140 [0]
 [ 1868.760025] iwl3945 0000:03:00.0: Failed to get channel info for channel 140 [0]
 [ 1886.540076] iwl3945 0000:03:00.0: Failed to get channel info for channel 100 [0]
 [...]
according to this thread: http://lists4.opensuse.org/opensuse-bugs/2010-08/msg00974.html

Therefore I added to "/etc/modprobe.d/options-iwl3945.conf":
  options iwl3945 disable_hw_scan=0

For testing purpose do
  rmmod -f iwl3945 && modprobe iwl3945 disable_hw_scan=0

I am happy now ;)

Greets Axel

Pako (elektrobank01) wrote :

Are you intend to do something about the bug?

Eric Appleman (erappleman) wrote :

Max speeds over time using Live USB sessions

Gutsy (ipw3945): 24 Mbps
Karmic (iwl3945): 16 Mbps
Lucid (iwl3945): 16 Mbps
Maverick (iwl3945): 1-3 Mbps
Natty (iwl3945): 1-3 Mbps
Natty (ndiswrapper): 24 Mbps

Andy Whitcroft (apw) wrote :

The fixes for this issue appear to be in mainline v2.6.30 and later. This means that the fixes will be in all releases Karmic and later. Therefore I am closing the development task Fix Released.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Andy Whitcroft (apw)
data (data) wrote :

Andy, please reconsider closing the bug. I am on an up2date Maverick, and this problem still persists. Only reassociating fixes this.

uname -a
Linux judy-laptop 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686 GNU/Linux

aus (aus.) wrote :

This issue seems to be the same as https://bugs.launchpad.net/ubuntu/+source/linux/+bug/621265
I've marked this one as duplicate. Under the #621265 progress is being made in narrowing down the problem.

Hi all, I installed Wicd and removed network-manager and now all works fine. Don't ask me why....
I've a VAIO FZ21E with IWL3945 (Intel PRO/Wireless) card.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.