regression - Ericsson F3507g (e.g. 0bdb:1900) WWAN Card not detected after 2.6.27-10 kernel

Bug #334413 reported by sog on 2009-02-25
58
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

In previous iterations of the Ubuntu kernel - <=2.6.27-10 - the Ericsson F3507g on board WWAN device could be made to function properly using instructions such as those found here:

http://www.thinkwiki.org/wiki/Ericsson_F3507g_Mobile_Broadband_Module

Subsequent to the introduction of the 2.6.27-11 kernel, the module is broken. Behavior is that the standard scripts from the above link are unable to progress beyond the "Powering up WWAN device" step. Nor does the device LED on my Thinkpad X301 activate. Essentially, kernels >= 2.6.27-11 render the device inoperable by virtue of the inability to activate it.

Happy to attach device logs as requested.

Kwinz (ldm) wrote :

I can confirm the bug.
Ericsson F3507g is broken on my Lenovo ThinkBook W500
and Kernel 2.6.27-11-generic.

Frédéric Junod (fredj) wrote :

I can confirm this bug on thinkpad x301 and kernel 2.6.28-11-generic (jaunty).

Users have reported [1] that patching the kernel [2] make it works.

[1] http://ubuntuforums.org/showthread.php?t=934013
[2] http://www.spinics.net/lists/linux-usb/msg10344.html

Alexander Sack (asac) wrote :

leann, can you check whether this bug is reported upstream and triage it? its not that all f3507g cards don't work. just a few usb ids seem to be affected. However, seems the affected module has been built into some thinkpads which means that there are probably a few folks affected by this.

Also note that according to Bug 363812 (which probably is a dupe) they don't even show up in lsusb (and suddenly it works after hibernate!)

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
summary: - Ericsson F3507g WWAN Card Broken
+ regression - Ericsson F3507g (e.g. 0bdb:1900) WWAN Card not detected
+ after 2.6.27-10 kernel
Alexander Sack (asac) wrote :

> Users have reported [1] that patching the kernel [2] make it works.

i dont think thats the problem anymore. In bug 364812 the user reports that the device is not even showing up in lsusb; also he reports that it suddenly works after resuming from hibernate. Can anyone confirm that behaviour (also post your usb ids if they dont match what i added to bug title).

Hi Alexander,

The patch referenced at http://www.spinics.net/lists/linux-usb/msg10344.html didn't seem to get pulled in, not sure why. Anyways, I'll try and get this on the kernel team's radar. Thanks.

Changed in linux (Ubuntu):
assignee: Leann Ogasawara (leannogasawara) → nobody
importance: Undecided → Medium
status: New → Triaged

And just to clarify, it didn't get pulled in upstream.

Alexander Sack (asac) wrote :

Leann, thanks.

The patch in http://www.spinics.net/lists/linux-usb/msg10344.html was wrong. and was backed out after 2.6.27 ... the device is a cdc-acm device and i think the device id is properly added there (maybe verify).

the oddness - which i believe is also the cause of this bug - is however that in bug 364812 the device doesn't even show up in lsusb output until the user hibernates/resumes!!! ... interestingly enough after resume from hibernate the usb device shows up in the lsusb and the driver suddenly starts working (e.g. it claims the device). Not sure how all these pieces fit together.

Alexander Sack (asac) wrote :

since other f3507g devices (rebranded) seem to work properly, i will also try to get ericsson folks look at this bug. maybe there was something special with the device with this id.

Chris Jones (cmsj) wrote :

fwiw the f3507g in a thinkpad X301 is detected fine in the 2.6.31 kernels in Karmic.

@sog, since you are the original bug reporter, care to confirm Chris' previous comment (comment #9). ISO images for Karmic can be found at http://cdimage.ubuntu.com/releases/karmic/ . Thanks.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
James Ward (jamesward) wrote :

It is detected fine for me with the latest Karmic but after I suspend and resume it is no longer there.

Frédéric Junod (fredj) wrote :

Do not work for me with the latest (2.6.31-4-generic) kermic kernel.
I will include some basic logs, tell me if something else would be useful.

Frédéric Junod (fredj) wrote :
Frédéric Junod (fredj) wrote :

Note that cdc-acm is in /etc/modules

Frédéric Junod (fredj) wrote :
Chris Jones (cmsj) wrote :

I'm running -4 with asac's network-manager/trunk PPA and I am able to connect via the modem.

(re it disappearing after suspend/resume, check the value of /sys/devices/platform/thinkpad_acpi/wwan_enable, I've noticed the thinkpad_acpi driver seems to unconditionally disable the device a lot)

Like Frédéric, I cannot see the Ericsson modem with lsusb. It is not there at boot up, nor after suspend/resume. I'm running kernel 2.6.31.8-generic on a Thinkpad X200s.

If there's anything we can do to fix this PLEASE let me know! This is quite a problem for me...

Kwinz (ldm) wrote :

~/ uname -a
Linux kwinz-laptop 2.6.31-9-generic #29-Ubuntu SMP Sun Aug 30 17:39:26 UTC 2009 x86_64 GNU/Linux

First
~/ wvdial 3G
works (3G is my wvdial script)

then I do a
~/ /etc/acpi/sleep.sh sleep

and wake up again

~/ wvdial 3G
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyACM1: No such file or directory
--> Cannot open /dev/ttyACM1: No such file or directory
--> Cannot open /dev/ttyACM1: No such file or directory

then i tried
echo 1 > /sys/devices/platform/thinkpad_acpi/wwan_enable
/home/kwinz/ modprobe cdc_acm

now I get
~/ cat /dev/ttyACM*
cat: /dev/ttyACM0: No such device
cat: /dev/ttyACM1: Input/output error
cat: /dev/ttyACM2: Input/output error
cat: /dev/ttyACM3: Input/output error

and
~/ lsusb
Bus 002 Device 003: ID 0bdb:1900 Ericsson Business Mobile Networks BV

Please fellow Ubuntu victims, take this straight to http://bugzilla.kernel.org so we might get a fix in the next kernel release.

Kwinz: just tell me what to say and I'll report it to Kernel.org. I fear that I don't understand the problem well enough to report it right now other than to say 'HEY! This has gone all wrong!'

Vitaly Minko (vitaly-minko) wrote :

Kwinz, try this patch: http://www.spinics.net/lists/linux-usb/msg22102.html
It works fine for me.

Kwinz (ldm) wrote :

The patch attached by Vitaly Minko does it's magic. Ty!
After standby you have to reload cdc_acm and reinitialize the card with the pin but it works.

John Stephenson (jmdsdf) wrote :

Kwinz, this patch also seemed to fix my U.S. Robotics 5637 Modem (0baf:0303) which was previously gave the same Input/Output Error when accessing /dev/ttyACM0 with kernels 2.6.31-4 to 2.6.31-11. I recompiled using 2.6.31.11.22 from source with this patch, and it works beautifully. This is appears to be reported upstream at http://bugzilla.kernel.org/show_bug.cgi?id=14103 Hopefully this means it will included for a fix with 2.6.31.1. I hope Karmic will include the fix too.

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Looks like the patch to fix this issue is now in the upstream kernel. I'll cherrypick the patch and build a Karmic test kernel for everyone to test. Please stay tuned . . .

ogasawara@emiko:~/linux-2.6$ git show 7af25b4b34a2439020d78da765a3bed0ff73f25c
commit 7af25b4b34a2439020d78da765a3bed0ff73f25c
Author: Oliver Neukum <email address hidden>
Date: Tue Sep 8 23:51:28 2009 +0200

    USB: fix cdc-acm regression in open

    cdc-acm needs to set a flag during open to tell the
    tty layer that the device is initialized

    Signed-off-by: Oliver Neukum <email address hidden>
    Cc: Marcel Holtmann <email address hidden>
    Cc: Paul Martin <email address hidden>
    Cc: stable <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress

I've built both 32 and 64bit test kernels which include the patch referenced above. They are available at:

http://people.canonical.com/~ogasawara/lp334413/

Please test and let me know your results. Thanks.

tried these and they do enable the F3507g. the issue, as noted previously,
is that the device fails after a suspend/resume cycle. on fresh boot it's
fine, once the machine's been suspended you lose the device.

On Tue, Sep 29, 2009 at 9:03 AM, Leann Ogasawara <
<email address hidden>> wrote:

> I've built both 32 and 64bit test kernels which include the patch
> referenced above. They are available at:
>
> http://people.canonical.com/~ogasawara/lp334413/
>
> Please test and let me know your results. Thanks.
>
> --
> regression - Ericsson F3507g (e.g. 0bdb:1900) WWAN Card not detected after
> 2.6.27-10 kernel
> https://bugs.launchpad.net/bugs/334413
> You received this bug notification because you are a direct subscriber
> of the bug.
>

James Ward (jamesward) wrote :

I'm still seeing this problem on the latest karmic. However if I switch my kill switch on and then off then I do see the option to connect to a mobile broadband network in NetworkManager.

Claire Newman (claire-newman) wrote :

Can folks on this bug try the following after a suspend/resume (as root):

 cat enable > /proc/acpi/ibm/wan

Please report if that reactivates the card for you.

sog (sogrady) wrote :

tried that via sudo: got a "Pemission denied"

On Sunday, November 1, 2009, Claire Newman <email address hidden> wrote:
> Can folks on this bug try the following after a suspend/resume (as
> root):
>
>  cat enable > /proc/acpi/ibm/wan
>
> Please report if that reactivates the card for you.
>
> --
> regression -  Ericsson F3507g (e.g. 0bdb:1900) WWAN Card not detected after 2.6.27-10 kernel
> https://bugs.launchpad.net/bugs/334413
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Chris Jones (cmsj) wrote :

sog: cat enable | sudo tee /proc/acpi/ibm/wan

Chris Jones (cmsj) wrote :

gah, sorry, the command is wrong anyway, it should be:

echo enable | sudo tee /proc/acpi/ibm/wan

cat will look for a file ;)

sog (sogrady) wrote :

i thought the cat command was a bit odd ;)

anyway, that command restores access to the device for me here:
NetworkManager can see it.

On Tue, Nov 3, 2009 at 11:42 AM, Chris Jones <email address hidden>wrote:

> gah, sorry, the command is wrong anyway, it should be:
>
> echo enable | sudo tee /proc/acpi/ibm/wan
>
> cat will look for a file ;)
>
> --
> regression - Ericsson F3507g (e.g. 0bdb:1900) WWAN Card not detected after
> 2.6.27-10 kernel
> https://bugs.launchpad.net/bugs/334413
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Florian Kisser (flok) wrote :

have the same problem on a lenovo t400s.

echo enable > /proc/acpi/ibm/wan
makes it work again :)

Jerone Young (jerone) wrote :

This issue has been resolved upstream. It was an issue in thinkpad-acpi.

It is in 2.6.33 though not sure which 2.6.32.X release it made it into.

The commit mentioned in comment #23 is currently in the lucid kernel:

ogasawara@yoji:~/ubuntu-lucid$ git show 7af25b4b34a2439020d78da765a3bed0ff73f25c
commit 7af25b4b34a2439020d78da765a3bed0ff73f25c
Author: Oliver Neukum <email address hidden>
Date: Tue Sep 8 23:51:28 2009 +0200

    USB: fix cdc-acm regression in open

And based on Jerone's comment #33, I can verify the thinkpad-acpi driver has been backported from 2.6.34-rc1 into Lucid.

ogasawara@yoji:~/ubuntu-lucid$ git show 9013f4991549b363768eea2b1bbfc6076de242f3
commit 9013f4991549b363768eea2b1bbfc6076de242f3
Author: Stefan Bader <email address hidden>
Date: Wed Mar 31 10:39:24 2010 +0200

    UBUNTU: SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1

Based on the above, I assume this is no longer an issue and am marking this Fix Released. If this is not the case, please re-open by setting the status back to New. Thanks.

Changed in linux (Ubuntu):
assignee: Leann Ogasawara (leannogasawara) → nobody
status: In Progress → Fix Released
bbjh1 (bbjh1) wrote :

Hi,

I am sorry if my questions seem stupid I am just a newbie with all this. I am trying to make the ttyACM0 device to work on y board but I am getting input/output error. I found here and on many other sites that I need to add a patch (comment #20). I was wondering if someone can help me and provide me with steps on how to add the patch and where should I add it.

Thank you.

bbjh1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.