Ubuntu 2.6.27-11.27-generic no cpuscaling-Error inserting acpi_cpufreq

Bug #332846 reported by graysky on 2009-02-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.27-11-generic

This bug relates to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/288592 but I as advised to open a new bug report. I have an Xeon processor (X3360) on DFI LP LT P35 T2R motherboard (P35-based). I'm running ubuntu-8.10-desktop-amd64. The out-of-the-box kernel does not allow me to use cpu scaling to alter my processor's speed. This is in contrast to other LINUX distros in which cpu scaling works just fine without altering any BIOS settings (Debian/Lenny-amd64, Arch/Overlord-amd64).

When I log into Gnome, the CPU Frequency Scaling Monitor tells me, "CPU frequency scaling unsupported. You will not be able to modify the frequency of your machine. Your machine may be misconfigured or not have hardware support for CPU frequency scaling."

It seems as though the problem lies (in part) with the inability to load the acpi-cpufreq kernel module. It is physically present:

$ ls -lh /lib/modules/2.6.27-11-generic/kernel/arch/x86/kernel/cpu/cpufreq
total 64K
-rw-r--r-- 1 root root 25K 2009-01-29 15:52 acpi-cpufreq.ko
-rw-r--r-- 1 root root 35K 2009-01-29 15:52 powernow-k8.ko

But I cannot get the kernel to load the module:

# modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.27-11-generic/kernel/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

I am able to compile my own kernel (2.6.27.10 from kernel.org) making some changes to the 2.6.27-11-generic config file (basically disabling some debugging options which cause my debs to be HUGE if I go with the standard config-2.6.27-11-generic), and when I boot into it, cpu scaling magically works with no other changes on my part.

FYI, here is the guide I used to compile my own kernel: http://technowizah.com/2005/12/debian-how-to-custom-kernel-compile.html

I will say that the dmesg gives a ton of ACPI Errors when I boot into the stock kernel. This is in stark contrast to the custom compiled kernel I'm using wherein there are not ACPI Errors at all and cpu scaling works just fine.

graysky (da-audiophile) wrote :
graysky (da-audiophile) wrote :
graysky (da-audiophile) wrote :
graysky (da-audiophile) wrote :
graysky (da-audiophile) on 2009-02-22
description: updated
jernej (jernej-makovsek) wrote :

Same problems here.

Well... I mean, it`s not like it`s some stupid GUI bug... How can you be serious about the server market?

same here, too. With Intel Celeron M

It's definitely not a BIOS prob, because I had feisty before and it was working there.

Howie Rosenshine (hcr02) wrote :

I don't know if I'd be that quick to rule out any bios issue.

I have 2 virtually identical systems (AMD 5200+, ASUS M3N78-VM motherboard)

One has been working fine with CPU scaling on both 2.6.27-11 and (pre-release)
2.6.27-12.

The second didn't have CPU scaling enabled. When I recently tried to enable
cpu scaling I ran into pretty much the exact problem described above.

The bios appeared "correct" i.e. it showed all the "right" settings like "able to change freq: yes"
etc. This machine had been running 2.6.27-11, and now 2.6.27-12, like the first.

As I had run out of things to try (like others), I cleared the NVRAM to factory setting
and after rebooting, cpu scaling started working fine.

I certainly thought I had looked at everything that mattered in the bios,
but apparently I hadn't.

I'm afraid I still can't say what exactly the bios issue was. Even though the motherboards
are the same, the bios(es) are slightly different revs, and it's kind of hard to do
a "diff" on bios at any rate. But the factory bios reset definitely resolved the issue
on the second machine.

Your mileage may vary, of course, but I thought this info might be of some help,
particularly to anyone who pokes at their bios.

graysky (da-audiophile) wrote :

I wish someone could get to the bottom of this. I just tried using the Jaunty kernel and this is present in it as well so it doesn't seem like there will be any relief in the near future either :(

graysky (da-audiophile) wrote :

I figured it out! I took a clue from my /var/log/dmesg

[ 4.633657] [Firmware Bug]: BIOS needs update for CPU frequency support
[ 4.633718] ACPI Error (psloop-0136): Found unknown opcode 20 at AML address ffff88012d27c633 offset 4F, ignoring [20080926]
[ 4.633722] ACPI Error (psloop-0136): Found unknown opcode 6F at AML address ffff88012d27c638 offset 54, ignoring [20080926]
[ 4.633726] ACPI Error (psloop-0136): Found unknown opcode 20 at AML address ffff88012d27c63c offset 58, ignoring [20080926]
[ 4.633729] ACPI Error (psloop-0136): Found unknown opcode 6F at AML address ffff88012d27c640 offset 5C, ignoring [20080926]

That line that reads, "Firmware Bug: BIOS needs update for CPU frequency support" was really bugging me. So I took a risk, d/l'ed the latest BIOS for my board, flashed, reset all my custom BIOS settings, and rebooted into my new kernel. I'm now able to use acpi-cpufreq and scaling works smoothly :)

I think you can safely close this ticket and pass on the information to folks experiencing this same symptom: flash your BIOS!

Hmm I've got the newest Bios that dell offers on their website.
But now I looked closer at my bios setup and didn't find an option to enable/disable CPU scaling.
And I do not get the message graysky gets in dmesg.

Robstarusa (rob-naseca) wrote :

I also have a dell with dual xeon 5060's. I also do not get the error graysky is getting. Mine is a precision 690. Cpu scaling does not work. I have this working great on my Q6600 at home & my 3 athlon 45W cpu's at home.

stupid me ... i knew i had forgotten something, and yeah if you have an intel centrino m you can't use the the speedstep_centrino module, but you need to use the p4clockmod module...

so it works for me now :)
cheers, arne

Jeremy Foshee (jeremyfoshee) wrote :

Hi graysky,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 332846

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers