Ubuntu

s2disk[3330]: segfault at 0 ip 0000000000000000 sp 00007fff942ccdf8 error 14 in s2disk[400000+8000]

Reported by Fernando Miguel on 2009-02-18
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Andy Whitcroft
uswsusp (Ubuntu)
Undecided
Unassigned

Bug Description

laptop fails to hibernate

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-8-generic 2.6.28-8.23
ProcCmdLine: root=UUID=a8aa4adb-b3e6-4e1d-b4ad-e6cd704788b2 ro
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-8.23-generic
SourcePackage: linux

Related branches

Andy Whitcroft (apw) wrote :

@BUGabundo -- hibernate is using s2disk to perform the hibernate, and that is segfaulting:

    [ 30.980137] s2disk[3330]: segfault at 0 ip 0000000000000000 sp 00007fff942ccdf8 error 14 in s2disk[400000+8000]

This is a non-default configuration. It would be worth first trying the kernel hibernate support to see if that works here. Normally this is selected in /etc/pm/config.d/00sleep_module. I am expecting to find something like this in there:

    SLEEP_MODULE="uswsusp"

If so could we try commenting that out, and retry the pm-himbernate test.

Changed in linux:
assignee: nobody → apw
status: New → In Progress

using "kernel" it works...

$ apt-cache policy uswsusp
uswsusp:
  Installed: 0.8-1.1ubuntu1
  Candidate: 0.8-1.1ubuntu1
  Version table:
 *** 0.8-1.1ubuntu1 0
        500 ftp://darkstar.ist.utl.pt jaunty/universe Packages
        500 ftp://archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Andy Whitcroft (apw) wrote :

BUGabundo reports that hibernate works with this switched to kernel. So I am assuming this is a uswsusp bug. Assigning it there.

Changed in linux:
status: In Progress → Invalid
Andy Whitcroft (apw) wrote :

This looks to be a regression triggered by the sync to debian performed under bug# 241115.

Carey Underwood (cwillu) wrote :

Debian's uswsusp_0.8-1.1 installs and works fine.

Changed in uswsusp:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package uswsusp - 0.8-1.1ubuntu2

---------------
uswsusp (0.8-1.1ubuntu2) jaunty; urgency=low

  * Remove usplash support, it doesn't work (LP: #241115, #331101).

 -- Devid Antonio Filoni <email address hidden> Thu, 19 Mar 2009 15:19:44 +0100

Changed in uswsusp:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers