uvc video driver lacks VIDIOCGMBUF ioctl

Bug #331014 reported by dcam on 2009-02-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hasciicam (Ubuntu)
Undecided
Jaromil
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The UVC video driver lacks the VIDIOCGMBUF ioctl and this limits the software it can work with.

This problem can easily be reproduced as follows. Note the error it gets for the VIDIOCGMBUF ioctl.

dcampbel@vostro:~$ hasciicam
HasciiCam 0.9.1 - (h)ascii 4 the masses! - http://ascii.dyne.org
(c)2000-2003 Denis Rojo < jaromil @ dyne.org >
watch out for the (h)ASCII ROOTS http://hascii.org

Device detected is /dev/video0
Integrated Webcam
1 channels detected
max size w[1280] h[1024] - min size w[48] h[32]
Video capabilities:
VID_TYPE_CAPTURE can capture to memory
!! error in ioctl VIDIOCGMBUF: : Invalid argument

This is a right-up-to-date Intrepid....

root@vostro:~# lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dcampbel 3923 F.... pulseaudio
 /dev/snd/pcmC0D0p: dcampbel 3923 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8300000 irq 48'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,10280275,00100003'
   Controls : 12
   Simple ctrls : 7
DistroRelease: Ubuntu 10.10
HibernationDevice: RESUME=UUID=6acbb5ef-566a-41e9-8ec1-ef4d0ab03fa6
MachineType: Dell Inc. Vostro1710
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcCmdLine: root=UUID=de3674a2-2543-4e51-95ea-70f61cbad1ba ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Regression: No
RelatedPackageVersions: linux-firmware 1.38
Reproducible: Yes
Tags: maverick kernel-graphics needs-upstream-testing
Uname: Linux 2.6.35-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/09/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0X805C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd10/09/2008:svnDellInc.:pnVostro1710:pvrNull:rvnDellInc.:rn0X805C:rvr:cvnDellInc.:ct8:cvrN/A:
dmi.product.name: Vostro1710
dmi.product.version: Null
dmi.sys.vendor: Dell Inc.

exit_jones (furiajusta) wrote :

same error in up-to-date ubuntustudio 9.04.

It seems to me the problem is with hasciicam and not UVC. UVC is a v4l2 device, and as far as i can tell, VIDIOCGMBUF is a v4l1 ioctl. Should a v4l1 compatability layer be implemented in UVC, or should the ioctl be updated in hasciicam? I'm not sure.

Jeremy Foshee (jeremyfoshee) wrote :

Hi dcam,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 331014

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Neels Jordaan (neels-jordaan) wrote :

Same problem experienced with Ubuntu 10.04 LTS running kernel 2.6.32.22.generic

Chris Brunner (chris-brunner) wrote :

Same problem here, experienced with Ubuntu 10.10 running 2.6.35-22-generic

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → New

apport information

apport information

dcam (david-pastornet) wrote :

the above information is from latest Ubuntu 10.10

Paco Avila (monkiki) wrote :

Use this command line to call the program:

$ LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so hasciicam

dcam (david-pastornet) wrote :

Or for 32-bit:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so hasciicam.

Confirming that this work around does work on 2.6.35-23-generic

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: b73a1py79
Jaromil (jaromil) wrote :

Hasciicam had old V4L code to open the camera, the whole V4L infrastructure improved a lot since V4L2 is out.

I've released a new upstream package version 1.1.2 which is already uploaded in Debian and fixes this problem.

I see it already mentioned here https://launchpad.net/ubuntu/oneiric/+source/hasciicam

so i'll close the bug.

Changed in hasciicam (Ubuntu):
assignee: nobody → jaromil (jaromil)
status: New → Fix Released

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers